Copyright © 1995-2003 HobbyWare, Inc. All rights reserved.
Design & Programming by R. Scott Horton.

To my wife Christina and my daughters Jennifer and Amy for their patience and understanding as I labored many
hours over the writing of Pattern Maker and this manual.

CrossStitch Symbol fonts Copyright © 1995-2002 The Vermillion Stitchery, All rights reserved.

Some of the sample designs included in this program were produced and are copyrighted by The Vermillion
Stitchery. These fonts may not be re-sold or distributed. They may only be used as part of another design.

Some of the sample designs included in this program were produced and are copyrighted by At River's End.
These fonts may not be re-sold or distributed.

The Pattern Fonts (alphabet patterns) and clipart included in this program were produced and are copyrighted by
Kooler Design Studio. These fonts may not be re-sold or distributed. They may only be used as part of another
design.

Parts of this program licensed under U.S. Patent No. 4,558,302 and foreign counterparts.

Microsoft and Windows are registered trademarks of Microsoft Corporation. DMC is a registered trademark of
the DMC Corporation. Anchor and J&P Coats are registered trademarks of Coats & Clark. Au Ver A Soie, Soie
d'Alger is a registered trademark of Au Ver A Soie Co., Paris, France. Caron Collection Impressions,
Watercolours, Waterlilies, and Wildflowers are registered trademarks of The Caron Collection. Eterna Silk is a
trademark of Yodama, Inc. Ginnie Thompson Flower Thread is a trademark of Flower Thread Company.
Madeira is a registered trademark of Madeira KG, Freiburg. Sulky is a registered trademark of Sulky
International. Kreinik Silk Bella, Kreinik Silk Mori, Kreinik Silk Mori, Milkpaint, and Kreinik Silk Serica are
trademarks of Kreinik Manufacturing Co., Inc. Mill Hill is a trademark of Mill Hill, Inc.

Other brand names and product names may be trademarks or registered trademarks of their respective
companies and may be found in the individual chapters of this manual.

Commercial or industrial use of trademark and copyrighted works (ex. books, paintings, drawings, photos, fanciful
characters, and so forth) owned by other companies or persons, that are used in the creation of patterns without
permission is illegal and may result in either criminal or civil liability.

Information in this document is subject to change without notice.
License Agreement

This License Agreement is a legal agreement between you, either as an individual or a single entity ("You"), and HobbyWare, Inc. ("HobbyWare") for the software product identified as "Pattern Maker for cross stitch". The Software Product includes executable programs, electronic documentation, and sample cross-stitch designs/patterns ("Components" or "Software Components").

Installing this Software Product on to a hard disk or any other storage device of a computer, or loading any of the components into the memory of any computer, constitutes use of the Software and shall acknowledge your acceptance of the terms and conditions of this License Agreement and your agreement to be bound thereby.

1. GRANT OF LICENSE
HobbyWare grants you as an individual, a personal, non-exclusive, non-transferable license to install the Software Product. If you are an entity, HobbyWare grants you the right to appoint an individual within your organization to use and administer the Software Product subject to the same restrictions enforced on individual users. You may not network the Software or otherwise use it on more than one workstation or computer at the same time. Contact HobbyWare for more information regarding multi-user site licensing.

2. COPYRIGHT
Except for the licenses granted by this agreement, all right, title, and interest in and to the Software Product (including, but not limited to, all copyrights in any executable programs, modules, libraries, electronic documentation, and sample designs), any printed materials and copies of the Software Product are owned by HobbyWare. The Software Product is protected by copyright laws and international treaty provisions. Therefore you must treat the Software like any other copyrighted material except that you may (a) make one copy of the Software solely for backup or archival purposes, or (b) transfer the Software to a single hard disk, provided you keep the original solely for backup or archival purposes. You may not copy any printed materials that may accompany the Software Product.

3. OTHER RESTRICTIONS
You may not rent, lease or transfer the Software. You may not reverse engineer, decompile or disassemble the Software, except to the extent applicable law expressly prohibits the foregoing restriction. Without prejudice to any other rights, HobbyWare may terminate this License Agreement if you fail to comply with the terms and conditions of the agreement. In such event, you must destroy all copies of the Software Product.

4. LIMITED WARRANTY
If you purchased this product directly from HobbyWare, then if within 30 days of your purchase of this software product you become dissatisfied with the Software for any reason, you may return the software to HobbyWare for a refund of your purchase price (excluding shipping charges).

5. NO OTHER WARRANTIES
HobbyWare DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTY OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE SOFTWARE, THE ACCOMPANYING WRITTEN MATERIALS, AND ANY ACCOMPANYING HARDWARE.

6. LIMITATION OF LIABILITY
IN NO EVENT SHALL HOBBYWARE OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITH LIMITATION, INCIDENTAL, CONSEQUENTIAL, SPECIAL, OR EXEMPLARY DAMAGES OR LOST PROFITS, BUSINESS INTERRUPTION, OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY OF THIS HOBBYWARE PRODUCT, EVEN IF HOBBYWARE HAS BEEN ADVISED OF SUCH DAMAGES.

APART FROM THE FOREGOING LIMITED WARRANTY, THE SOFTWARE PROGRAMS ARE PROVIDED "AS-IS", WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED. THE ENTIRE RISK AS TO THE PERFORMANCE OF THE PROGRAMS IS WITH THE PURCHASER. HOBBYWARE DOES NOT WARRANT THAT THE OPERATION OF THE PROGRAMS WILL BE UNINTERRUPTED OR ERROR-FREE. HOBBYWARE ASSUMES NO RESPONSIBILITY OR LIABILITY OF ANY KIND FOR ERRORS IN THE PROGRAMS OR DOCUMENTATION, OR FOR THE CONSEQUENCES OF ANY SUCH ERRORS. THE LAWS OF THE STATE OF INDIANA GOVERN THIS AGREEMENT.
# Contents

## Overview
- Feature Overview ......................................................... 7
- Changes Included in Version 4 ........................................ 9
- How To Use this Manual .................................................. 10
- Technical Support .......................................................... 11

## Essentials
- Using the Mouse .............................................................. 13
- Window Layout .............................................................. 13
- Pattern Files .................................................................. 19
- Viewing Options ............................................................ 21

## Creating a Design
- Design Methods ............................................................ 23
- Lesson 1: Manually Creating a Design ............................... 23
- Lesson 2: Converting a Scanned Photograph ....................... 26
- Lesson 3: Tracing an Existing Chart ................................... 31
- Lesson 4: Using the Provided Clipart ................................. 39
- Summary ........................................................................ 45

## Stitch Features
- Drawing Full, Petite, Half, and Quarter Stitches .................. 47
- Erasing Full, Petite, Half, and Quarter Stitches .................. 47
- Drawing Back and Straight Stitches .................................... 47
- Erasing Back and Straight Stitches .................................... 48
- Drawing French Knots ...................................................... 49
- Erasing French Knots ....................................................... 49
- Drawing Beads ............................................................... 49
- Erasing Beads ............................................................... 49
- Drawing Specialty Stitches ............................................... 49
- Erasing Specialty Stitches ............................................... 49
- Drawing Text ............................................................... 51
- Eyedropper Tool ........................................................... 53
- Stitch Options Dialog .................................................... 53
- Creating Specialty Stitches .............................................. 55

## Editing Features
- Overview ......................................................................... 59
- Selecting a Pattern Area .................................................. 59
- Basic Editing Features .................................................... 62
- Advanced Editing Features .............................................. 66
Pattern Maker™ for cross stitch is a Windows® program that allows you to create and edit cross-stitch patterns. With this program you can see your patterns ‘come to life’ on the computer screen even before you make the first real stitch. At any time you can print the pattern using any of several formats. One of these formats provides a ‘symbolic’ view which can be used as a stitching guide. Two levels of Pattern Maker are available:

- **Standard** – Includes basic features useful to anyone designing patterns
- **Professional** – Includes advanced features useful to those designing for publication and/or kit creation.

The **Machine Embroidery** add-on feature is available for both the Standard and Professional levels. This add-on includes the capability to export designs into machine embroidery format for stitching on a machine.

This manual supports all levels of Pattern Maker. In describing the various features of the program, this manual indicates when a feature is only found in a particular level or add-on.

For information on installing and getting started, please see the **Getting Started Guide**. This manual assumes you have already installed Pattern Maker and are able to open the program.

Some levels of Pattern Maker include license management. If you would like to learn more about licensing and how to use the **Licensing Wizard** that appears when a license is not installed, see “Licensing Features” on page 164.

---

**Feature Overview**

**Basic Features**

Pattern Maker allows you to create patterns that include the following stitch types:

- Full
- Half
- Quarter
- Petite
- Back/Straight
- Specialty
- French Knot/Bead

Up to 240 floss colors can be used per design. These floss colors can be chosen from the common floss brands such as DMC® and Anchor.

Designs can have up to 999x999 full stitches.
Complete printing support is provided with Pattern Maker. This support includes print preview, color printing, and options for controlling the content and size of the printout.

The program allows a pattern to be displayed in four views:

- Stitch
- Symbolic - used for creating a stitching guide
- Solid
- Information

A pattern can be displayed or printed in any of these views. The stitch view is used for a realistic view of the pattern. The stitches are shown as cross-stitches with the colors corresponding to the floss colors. The symbolic view is used to produce a stitching guide.

All pattern editing is done using the mouse. The mouse is used to select the type of stitch, the floss color, and the location of each stitch. Drawing stitches is as simple as pointing to a location on the pattern and clicking the mouse.

**Image Importing Support**

The Image Importing feature can be used to start a new pattern by converting a scanned photograph or other graphics image. Once imported into a pattern, the design can then be manually edited and enhanced as desired.

In addition to converting an image directly into a pattern, Pattern Maker also allows an image to be inserted into a new pattern as an image. This feature allows an image to be manually traced using the stitch tools. This feature is handy when you want to use a hand-drawn sketch as a guide for your design.

**Professional Level Features**

The *Professional* level of Pattern Maker includes many features that are needed by professional designers. These include advanced editing features, exporting features, page layout features, and custom specialty stitches.

The advanced editing features of the Professional level allow the user to more precisely edit a design. For example, a free-hand selection tool is provided for choosing an arbitrarily shaped area of stitches. Also, a selection can be refined to include only certain colors and stitch types. The editing commands then only apply to that refined selection.

After creating a design, Pattern Maker allows you to create a page layout for your design using a built-in word processor. The page layout can consist of one or more pages and is automatically updated when changes are made to the design.

For designers who prefer to use other applications to create design documents, Pattern Maker also provides powerful features for exporting a design into a graphics file format. In addition, all pattern information can be exported for use in other applications.

To make getting your designs to market even easier, Pattern Maker supports Windows OLE technology. This capability allows a pattern to be inserted into a document created using another program. The other program might be a publishing or word processing program. Even after inserting in the other document, the design can still be edited at any time using Pattern Maker.

The Professional level also allows the user to create custom stitches using the Specialty Stitch editor. This editor allows high-quality representations of stitches to be drawn using straight lines, curves, and dots. Repeating stitches can also be defined to simplify the filling of areas when creating a design.

**Machine Embroidery Add-On**

The *Machine Embroidery* add-on includes the capability to export your designs to an embroidery machine. Since many of the common machine file types are supported by this feature, most embroidery machines are
supported. In addition, options are provided to allow you to specify limitations that may exist for the particular machine and/or memory card used in transferring designs.

When exporting large designs that exceed the size of the hoop, the program will automatically partition the design into sections that fit the hoop. Alignment stitches can be enabled to assist in aligning the sections during stitch-out.

For more details, “Machine Embroidery Features” on page 119.

Changes Included in Version 4

Many changes have been made to the program since version 3. This section provides an overview of those changes.

- New Stitch Types
  - Petite Stitch.
  - Straight Stitch.
  - Specialty Stitches – over 45 types. The **Professional** level includes a Specialty Stitch editor for creating custom stitches. High-quality representations can be drawn using the back stitch, straight stitch, French Knot, and curve stitch tools.
  - Beads.

- Editing
  - Free-hand selection tool for making arbitrarily shaped selections.
  - Advanced selection for limiting a selection to only certain colors and/or stitch types.
  - Eyedropper tool for inspecting the color and type of any stitch, and for ‘picking-up’ the color or type. *Note that this tool replaces the stitch color display that was shown on the status bar at the bottom of the window for previous versions.* Be sure to read the help section on this tool so you will not miss-out on its capabilities.
  - Enhanced Text tool that also supports the use of TrueType fonts in addition to cross-stitched fonts.
  - New commands for filling, stitch replacement, color replacement, back stitch outlining, and centering.
  - Improved flood fill tool that fills using full stitches and quarter stitches.
  - Selected area now ‘floats’ over the non-selected area to simplify the moving and/or copying of the design.
  - Selected area now visible while dragging to make precise positioning quicker and easier.

- Importing
  - Interactive importing is now available in addition to the wizard-based method. Use this method to quickly refine the importing settings without the need to constantly use ‘Next’ and ‘Back’ buttons of the wizard approach.
  - Foreground tool for marking image areas whose color should be given more priority.
  - Background tool for marking image areas that should not be imported.
  - Significantly improved color selection and reduction. Most images are imported with fewer and better color selections.

- Printing
  - Support for shaded repeats.
  - Support for grid numbering.

- Page Layout (New) – **Professional** level
o Create a custom page layout for a design.
o Add one or more customizable floss/thread tables.
o Add one or more chart objects.
o Add user-specified text and/or graphics.
o Export or print a layout.

• Palette
  o Up to 240 colors per design.
  o Options now presented on an ‘options’ bar which allows interactive editing of the palette while working on the design.
  o Up to 12 strands can now be specified per color.
  o A color can be added more than once to the palette to allow different options to be specified.
  o Palette symbols of a design can be chosen from multiple fonts.
  o Symbol options for back stitches, straight stitches, specialty stitches, and French Knots.
  o Several new back stitch line styles included.
  o Conversion feature for converting between floss/thread brands.
  o Undo now supports palette changes.
  o Color behind symbol now available in Standard level.
  o Stitch usage summary now available in Standard level.

• Miscellaneous
  o New file extension for pattern files (xsd).
  o Pattern preview in File Open dialog box.
  o More toolbars.
  o Ruler display.
  o Update feature for simplifying the download and installation of program maintenance releases.

Many additional small changes were made to this version as well. Be sure to read-over this manual so you do not miss-out on any new features.

How To Use this Manual

The following chapters are recommended as a starting point for using the program:

• Overview
• Essentials
• Creating a Design
• Stitch Features
• Editing Features
• Fabric Features
• Palette Features
• Printing Features
Those chapters are useful regardless of the level of Pattern Maker that you have. If you are a Professional-level user, then the following additional chapters will most likely be of interest to you:

- “Exporting Features” on page 113
- “Page Layout Features” on page 129

If you purchased the Machine Embroidery add-on, then it is essential that you read the chapter entitled “Machine Embroidery Features” on page 119.

This manual is available in two formats:

- As a PDF file that can be printed
- As a built-in help file that can be quickly accessed from the program

To open the help file while using the program, select Contents from the Help menu. You can also press the F1 key to open the built-in help or click the Help button that is shown on each dialog box. In either of those cases, the help file will open to a section that provides more information for the current feature of the program you are using.

---

**Technical Support**

If you encounter a problem or need assistance using a feature of the program, then we suggest that you first consult this manual (if in printed form) or the built-in help information (select Contents from the Help menu). While using the program, you can also press the F1 key to open the built-in help or click the Help button that is shown on each dialog box.

To see a list of frequently asked questions (FAQ), see “Troubleshooting” on page 171. Our web site also contains an FAQ list which is updated regularly. If you are experiencing a common problem or issue with the program, then information will most likely be available on our web site.

We release maintenance updates as needed to correct bugs and add minor features. These maintenance updates are available on our web site. You can either download an update directly from the web site, or use the update facility that is built-in to Pattern Maker. The update facility requires that the computer running Pattern Maker have an Internet connection. To use this facility, select Check for Updates from the Help menu, and then follow the instructions that are shown.

If you cannot find the answer to a problem or question after consulting this manual, the built-in help, or our web site, please contact us. We are very interested in making sure that you get the most from this product. In addition, we are always open to suggestions on how the program can be made more useful to you. You can reach us the following ways:

**Web Site:**  [www.hobbyware.com](http://www.hobbyware.com)

**Email:**  support@hobbyware.com

**Telephone:**  (972) 562-5411

**Mailing Address:**  HobbyWare, Inc.

P.O. Box 501996

Indianapolis, IN 46250

When contacting us regarding a problem, please have the following information available before you call. If you write or email us, please provide this information in your correspondence.

- Version of Pattern Maker you are using. To determine the version, select About Pattern Maker from the Help menu.
- Operating system version.
- Model and configuration of your computer (including the amount of RAM, the video card, and the available hard drive space).
- Printer brand, model, and driver version if a printing problem.
• **Complete** description of the problem and the steps that you used which made the problem apparent.
This chapter describes the basic aspects of Pattern Maker that you need to understand to make best use of the program.

**Using the Mouse**

All drawing and editing features of the program require the use of a mouse or other pointing device. Many operations involve positioning the mouse over some area of the displayed pattern and clicking the left or right mouse button. The following phrases are used throughout this manual:

- **Click the mouse** - to position the mouse pointer and then press and release the left mouse button. In some cases, it is necessary to press the right mouse button instead. In those cases, the manual specifically indicates the use of the right mouse button.

- **Double-click the mouse** - to position the mouse pointer and then quickly press the mouse button twice.

- **Drag using the mouse** - to position the mouse pointer over an object (ex. a handle), press and hold down the left mouse button, and then move the mouse to move the object. Releasing the mouse button releases the object being dragged.

**Window Layout**

The Pattern Maker window is organized into several areas. The following screen example shows these areas.
Title Bar
The Title Bar is located at the top of the window and appears as:

The Title Bar displays the name of the program and the name of the current pattern that is open and selected. Note that the displayed pattern name is actually the file name of the pattern.

Menu Bar
The Menu Bar is located below the Title Bar and consists of menus that are specific to this program.

The actual menus shown on the Menu Bar vary depending upon the type of window currently open in the program. The Menu Bar content also varies between the levels of Pattern Maker and whether the Machine Embroidery add-on is available.

Toolbars
The Toolbars are located below the Menu Bar. The Toolbars contain buttons which can be clicked to perform an action or to select a tool. The number of Toolbars and the number of buttons on some Toolbars depend upon the level of Pattern Maker.

The position of the Toolbars can be re-arranged. The program will remember these positions between uses of Pattern Maker.

The following describes each Toolbar and associated buttons.
**Main Toolbar**

- Create New Pattern
- Import Image
- Open Pattern
- Save Pattern
- Print Pattern
- Cut Selection
- Copy Selection
- Paste Selection
- Undo Last Edit
- Select from Pattern Library (clipart)
- View Built-in Help

**View Toolbar**

- View Design as Stitches
- View Design as Symbols
- View Design as Solids
- View Design Information
- View Design Layout
- Zoom Setting
- Zoom to Fit
- Use Previous Zoom

**Command Toolbar**

- Clear All/Selection
- Change Color
- Change Stitch Type
- Flip Horizontally
- Flip Vertically
- Rotate Clockwise
- Rotate Counter Clockwise
- Fill Empty Area of Selection
- Fill Entire Selection
- Outline Between Colors
- Outline Between Stitches and Fabric
- Outline Around the Selection

**Palette Toolbar**

- Show Palette Options
- Show Usage Report
- Highlight Color Use

**View Options Toolbar**

- Show/Hide Grid
- Enable/Disable Stitch Outlining

**Drawing Toolbar**

- Full Stitch Tool
- Petite Stitch Tool
- Half Stitch Tool
- Quarter Stitch Tool
- Back Stitch Tool
- Straight Stitch Tool
- French Knot Tool
- Bead Tool
- Specialty Stitch Tool
- Rectangular Selection Tool
- Free-Hand Selection Tool
- Text Tool
- Flood Fill Tool
- Eyedropper Tool
- Magnifier Tool

**Machine Embroidery Toolbar**

- Export to Machine File(s)
- Show Jump Stitches
- Show Hoop Boundaries
- View Exporting Results
To determine the function of any toolbar button of the Pattern Maker window, simply position the mouse pointer over the button. A pop-up description will be shown.

To show/hide a toolbar, right click on the toolbar area of the Pattern Maker window. This will open a menu which lists all available toolbars.

To move a toolbar to another location, click and drag the toolbar handle which is located on the left side of each toolbar. A box will then appear and follow the mouse. When the toolbar is released, the toolbar will be moved to that new position. A toolbar can be made to ‘float’ within the Pattern Maker window or ‘dock’ to a side.

The following steps will reset all toolbars back to their initial positions:
1. Select Preferences from the File menu to open the Preferences dialog box.
2. Click the Workspace tab.
3. Click the Reset All button. The toolbars should then be restored.
4. Click Ok.

Pattern Area

The Pattern Area is located below the Toolbar area. This area contains one or more pattern windows. Whenever a design is open, there is at least one window open in the Pattern Area for the design. These pattern windows can be arranged and sized to organize the Pattern Area. The Window menu provides various options for organizing open windows such as tiling or cascading. For more details on these options, see “Managing Multiple Design Windows” on page 176.

Depending upon the selected zoom factor for a pattern, the entire pattern may not be visible at one time. When this is the case, one or two scroll bars are displayed to allow you to scroll the window to display other areas of the pattern.

A pattern can be represented using several different viewing modes. The viewing mode is selected from the View menu. The following viewing modes are available:

- **Stitches** - The pattern is displayed as stitches.
- **Symbols** - The pattern is displayed using symbols.
- **Solid** - The pattern is displayed using filled boxes.
- **Information** - The pattern information is displayed.
- **Design Layout** – The page layout for the pattern is displayed. (Professional level only)
- **Machine Embroidery Information** - The machine embroidery exporting results are displayed. This option is only available with the Machine Embroidery add-on and only after exporting the design as a machine embroidery file.

Status Bar

The Status Bar is located at the bottom of the window.

| Ready: | 1 | 5 | DMC 646, Beaver Gray-DK |

The Status Bar displays the following information:

- Help information for a pointed-to menu or toolbar button
- Mouse pointer location (when pointer is over a design)
- Selection size (when a selection is active)
- Name/ID of the currently selected floss/thread color
Palette Bar

The Palette Bar shows the floss/thread palette of the currently selected pattern. This bar is located directly above the status bar and appears as:

A color must be added to this bar before it can be used to draw stitches. When drawing stitches, you simply click a color in this bar to choose it for drawing. The selected color is indicated by a dashed outline around it. The color ID and name is then shown below on the Status Bar. The color ID and name is also shown in a pop-up box as you move the mouse pointer over the colors of the Palette Bar.

Since the number of colors that can be selected for a pattern can be quite large, the list of colors in the Palette Bar can be scrolled using the scroll bar on the left side. To vary the number of rows shown in the Palette Bar, click and drag the window divider located at the top of the Palette Bar. Up to eight rows of colors can be shown at one time.

To shrink the color boxes so that all colors are displayed at once, select the All box.

Color boxes of the Palette Bar are displayed as gray whenever they do not have a color assignment. To assign a color or change the assignment, simply double-click the color box. This will open the Palette Options bar where you can choose the color. See the next section for more details.

The left and right arrow buttons in the upper right corner of the Palette Bar can be used to shift the position of a color within the palette. This feature is most useful in the case of the Machine Embroidery add-on where the order of the colors in the palette determines the order that they are stitch-out by the machine.

The total number of colors in the palette is displayed on the right side of the Palette Bar.

A pop-up menu is displayed when the Palette Bar is right-clicked. This menu contains many of the items that are available in the Palette menu of the Menu Bar. The Palette Bar menu also includes the following menu items:

- **Delete** – deletes the selected palette color and all uses of it in the design
- **Delete All** – deletes all colors of the palette and all uses those colors
- **Delete Unused** – deletes all colors of the palette that are currently unused
- **Select All** – selects all colors of the palette (This is useful when you want to edit the properties of all colors in the palette.)
- **Sort:**
  - **By User-Selected Order** – sorts the palette using the user-selected order
  - **By Usage** – sorts the palette from most-used to least-used in the design
  - **By Main List Order** - sorts the palette according to the order of the colors as shown in the Palette Options bar.

Palette Options Bar

The Palette Options bar is used to add colors to the palette, as well as modify the settings of the palette colors. This bar is shown below.
This bar can be opened by double-clicking a color box of the Palette Bar or by clicking the Show Palette Options button of the Palette toolbar. To close this bar, click the close button in the upper-right corner. This bar can be left open while drawing.

To adjust the height of this bar, click and drag the window divider that is located at the top of the bar.

For a more detailed discussion of the features of the Palette Options bar, see “Palette Features” on page 79.

Pattern Files

Designs created in Pattern Maker are stored in files. The format of these files is unique to Pattern Maker. The location of these files can be anywhere you choose. The default location for the storage of designs is the ‘PM Patterns’ folder under ‘My Documents’. To select a different location, select Preferences from the File menu.

Saving Pattern Files

To save a pattern, either click the Save Pattern button of the Main Toolbar or select Save from the File menu. For patterns that have not been previously saved to disk, this will open the Save As dialog box. This box allows you to name the file that will store the pattern and to choose where on your computer the new file will be placed.

After a pattern has been saved for the first time, you will want to re-save the pattern regularly as you work on it. The most efficient way to save a pattern is to click the Save Pattern button of the Main Toolbar. Since the pattern has already been given a file name, the program will save the pattern without opening any dialog boxes.

At times you may want to save the pattern to another file while still keeping the original file. To do this, select Save As from the File menu. This will open the Save As dialog where you can give the pattern file another name. The previous file will still exist. Note that all subsequent saving of the pattern will be to the new file.

Opening Pattern Files

To open a pattern file that already exists, either click the Open Pattern button of the Main Toolbar or select Open from the File menu. This will open the File Open dialog box. This is the standard Windows® dialog for choosing a file. The basic procedure for choosing a file is to first select the folder on your computer where the file resides, and then select the file from the list of files for that folder.

Pattern Maker provides a preview feature to help you in finding a particular design. When a design is selected in the file list, the pattern is displayed in the preview pane of the File Open dialog box. To show or hide the preview pane, click the Preview button. To enlarge the File Open dialog box to see more of a previewed design, click and drag the re-sizing handle in the lower-right corner of the File Open dialog box. To change the portion of the dialog box that is used for the file list or design preview, click and drag the window divider that separates the two areas of the dialog box.
The program maintains a list of the last several patterns that were opened. This list is shown near the bottom of the **File** menu. To open one of these files, simply click on the name. This makes it easy to re-open a file that you have recently used.

### Specifying Summary Information

Pattern Maker allows you to specify general information about a design. This information is included as part of the information printout of a design. It can also be selectively included in the page layout of a design.

To edit this information, select **Information** from the **File** menu. This will open the **Pattern Information** dialog as shown below.

![Pattern Information Dialog](image)

This dialog allows you to specify the following information for a pattern:

- Title of the pattern
- Designer
- Company
- Copyright
- Alternate pattern sizes - included as part of the pattern information printout.
- Notes - any additional information that you want printed as part of the pattern information.
- Font - the font to be used when printing the pattern information. When choosing the font, you may want to use a font that has a fixed character width if you plan to print notes that require a tabular format. If you do not specify a fixed character-width font, then it is very difficult to make the notes appear in columns.

The Pattern Information dialog also shows information about the current fabric selection. This information cannot be changed by this dialog.
Select **Use For New Designs** if you want these options to be used for new patterns.

**Viewing Options**

Pattern Maker provides you with several options for controlling how a pattern is displayed. The following sections address some of the more basic options.

**Changing the View Format**

Pattern Maker allows you to view a pattern in several ways.

**Stitch View**

The Stitch view presents the pattern by representing the stitches in a manner that is similar to how they actually appear.

The Stitch view can be chosen for the current window by selecting **Stitches** from the **View** menu.

**Symbolic View**

The Symbolic view presents the pattern by representing each stitch using a symbol. Each color of the pattern is assigned a unique symbol to represent it in the pattern.

The Symbolic view is usually printed for use as a stitching guide. The above example shows the ‘color-behind-symbol’ feature of the program. That feature can be turned-off for cases where only the symbol is desired.

The Symbolic view can be chosen for the current window by selecting **Symbols** from the **View** menu.

**Solid View**

The Solid view presents the pattern by representing each stitch using a solid square.

The Solid view can be chosen for the current view window by selecting **Solids** from the **View** menu.

**Magnifying or Reducing a View**

The displayed size of a pattern can be magnified or reduced. The **Zoom Factor** box of the Main Toolbar indicates the current display size relative to the true pattern size.
When a new pattern is created, the screen display corresponds to the actual size of the pattern. In this case, the Zoom Factor box shows 100%.

To change the display size of a pattern, click the down arrow of the Zoom Factor box. This will drop down a list from which you can choose a new zoom factor. Numbers that are greater than 100% will cause the pattern display to be enlarged. Numbers that are smaller than 100% will cause the pattern to be reduced. All view sizes are approximate and will vary depending upon the screen resolution that is setup for your computer.

Note that the next or previous item in the zoom factor list can be selected at any time by using the + and - keys of the numeric keypad of the keyboard (usually found on the far right side of the keyboard). The zoom factor can also be adjusted by selecting one of several commands under the View menu.

The Zoom Tool of the Drawing Toolbar can be used to zoom in or out on an area. To use it, first click on the tool, and then left click on the design to zoom in, or right click on the design to zoom out.

Another method for zooming-in or out on a specific area of a design is to first select the area using one of the selection tools. Next, change the Zoom Factor to enlarge or reduce the view. The selected area will be centered in the view when the zoom change is applied.

To switch between the current zoom factor and the previous zoom factor that was used, click the Previous Zoom button of the View Toolbar.

To switch to a zoom factor that will make the entire design fit within the pattern window, click the Zoom-to-Fit button of the View Toolbar.

Opening Multiple Views

Sometimes it can be very useful to have more than one view of a pattern available at one time. For example, you may desire to have an enlarged view of the pattern showing the area where you are working and also a reduced view of the entire pattern so you can see the overall effect of your changes as you make them.

To open an additional view (i.e. window) for a pattern, select New Window from the Window menu. You can then specify the viewing options, such as the viewing format and zoom factor, for the new window. When you make a change to the pattern in one of the view windows, all other view windows for that same pattern are automatically updated.

For more information on using multiple windows, see “Managing Multiple Design Windows” on page 176.

Other Viewing Options

Several other viewing options are available under the View menu. These include:

- **Show Grid** – select to show/hide the grid. You can also use the Show Grid button of the View toolbar.
- **Show Ruler** – select to show/hide the rulers. When the ruler is shown, you can select the measurement units by right-clicking the ruler.
- **Stitch Outlining** – select to show/hide stitch outlines. You can also use the Outline Stitches button of the View toolbar.
- **Show Centering Marks** – select to show/hide centering marks.
Creating a Design

This chapter describes how to create new designs. It includes step-by-step guides to make it easy for you to create your first design.

Design Methods

There are three main approaches to creating a new design. These include:

- Manually starting a design and drawing stitches
- Converting a scanned photograph into a design
- Tracing a scan of a hand-drawn sketch or an existing cross-stitch design

The first method is the simplest approach. It involves setting-up a blank design and then using the stitch drawing tools to place stitches where you want them. For those users who would rather build upon existing designs, you can also insert existing cross-stitch clipart into a design. In addition to the clipart included with the program, HobbyWare offers additional clipart collections.

The second method uses the conversion mode of the Image Importing feature to create a new design. In this case the program analyzes a scanned photograph (or other graphical content), and then creates a design using full cross-stitches. The stitch colors are automatically selected by the program. Since this feature only provides a starting point for a new design, you will most likely want to clean up the imported design to produce a finished design that is ready for stitching.

The third method involves tracing a scan of a hand-drawn sketch or an existing cross-stitch chart. This method is useful when you want to create a design by using a hand-drawn sketch as a guide. It is also useful when you want to modify an existing design and/or use the Machine Embroidery feature to stitch-out an existing design. In this case the scanned sketch or chart is not directly converted by the program into stitches. Instead, the importing feature is used to create an empty design with the scan as a background behind the grid.

The following lessons provide detailed instruction on creating a design. After reading and trying these lessons, you should also read-over the other sections of the manual so that you are aware of the other capabilities of the program.

Lesson 1: Manually Creating a Design

This lesson describes how to setup a new design, how to draw a simple pattern of stitches, and how to printout the design.

Part A: Creating the Design

This task involves setting-up a new design. A design that is 3 inches by 3 inches will be created. A stitch size of 14 stitches per inch will be used.
1. Select **New** from the **File** menu. This will open the Specify Fabric Properties dialog.

![Specify Fabric Properties of New Pattern dialog](image)

This dialog allows you to specify the fabric options. The options shown on the **Size** tab of this dialog are the most important options to initially specify. For more information on this dialog box, see “Fabric Features” on page 74.

2. In the box labeled **Select Stitch Size**, specify 14 for the stitches per inch horizontally. (The Square Stitch option should be selected. The Use Machine Stitch Sizes options should also be selected if you are using the Machine Embroidery add-on.)

3. For the option labeled **By Specifying the Finished Size**, specify 3 for the width and height. Also verify that the Inches option is selected.

4. Click **Ok**. You should now see a new design open that is 42 stitches wide and 42 stitches tall.

5. Select Save from the File menu to save your design. Specify a name for your design, and then click **Ok**. For more details on saving a design, see “Saving Pattern Files” on page 19.

**Part B: Drawing a Simple Design**

This task involves using the stitch tools to draw a very simple design.

6. To make it easier to see and draw the stitches, select a zoom factor of **200%** using the **Zoom Factor** drop-down list of the Toolbar.

7. Click the **Full** stitch tool of the Drawing toolbar.

8. By default, the program creates a new design using a default palette of colors. You should see that palette in the Palette Bar at the bottom of the window. Click on the red color of the Palette Bar. That color will then become the current color for drawing. For details on changing the palette, see “Palette Features” on page 79.

9. Draw the block of red stitches as shown in the example below by pressing and holding down the left mouse button, and then moving the mouse. To erase a stitch, press the right mouse button while pointing at a stitch.
10. Repeat steps 3 and 4 for the other stitch colors in the example.

11. To outline the stitches as shown in the example, first click the Back Stitch button of the Drawing toolbar.

12. For the back stitches, a new color will be added to the palette. To do this, select Colors from the Palette menu. This will open the Palette Options bar.

13. For the type of floss color, ensure that DMC is selected in the box labeled Type.

14. In the Find box of the Palette Options bar, type: 413. This will cause DMC 413 to be selected. Press the enter key of the keyboard to add it to the palette.

15. Position the mouse at the intersection of two grid lines where a stitch should begin. Click and hold the left mouse button.

16. Drag the mouse to the end point of the back stitch, and release the mouse button.

17. To delete a back stitch, click near the stitch to select it, and then right click.

18. Draw each of the back stitches shown above in the example.

19. Select Save from the File menu to save your changes.

Part C: Printing the Design

This task will use the printing features of Pattern Maker to print a symbolic chart that can be used as a guide for stitching the design.

1. Select Symbols from the View menu. This will change the view of the design to the symbolic representation as shown below.

2. Select Print Preview from the File menu. This will open the Print Preview window where each page of the printout can be displayed on the screen. Note that the detail shown on the screen is less than what will be actually printed.
3. Click the **Next Page** button of the Print Preview toolbar to see additional pages of the printout. As shown, the first page contains the chart for the design. The second page shows the list of colors used and the corresponding symbols used in the chart.

4. Click the **Close** button of the Print Preview toolbar to close the preview. The pattern window for this design will then be shown again.

5. Select **Print** from the **File** menu to print the design.

While this lesson involved a very simple example, it demonstrated the basic steps involved in creating your own designs. The following topics are recommended for extending your familiarity with the design features of the program:

- “Stitch Features” on page 47
- “Editing Features” on page 59
- “Palette Features” on page 79

---

**Lesson 2: Converting a Scanned Photograph**

This lesson describes how to create a design by importing a scanned photo or an existing graphics file.

**Part A: Scanning the Photo**

This task involves using your scanner and scanner software to perform a scan of the photo or artwork to be converted. The specific directions for scanning vary depending upon the model and brand of scanner. Please refer to the documentation that you received with your scanner for details on how to perform a scan.

Here are some recommendations that you should consider when scanning:

- Use the cropping tools of the scanner software to limit the scan to only that part of the photo that is essential.
- A DPI setting of 100 to 200 is usually sufficient.
- A color resolution of 24 bits is sufficient.
- Save the scan in the bitmap (BMP) file format.

After scanning, you should have on the hard disk of your computer an image file, which can then be selected and opened using Pattern Maker. The next part describes how to select the file and import it.

**Part B: Importing the Scanned Photo**

This task involves using the **Importing Wizard** of the program to select and convert your scanned photo. Please note that any digitized image in one of the supported image file formats can be used at this point. For example, most clipart files and image files from CD collections can be used.

Please note that the instructions below only provide that information needed for this lesson. For more detailed information on using the importing features, see “Image Importing Features” on page 102.

1. Select the **File** menu and verify that the **Use Interactive Importing** option is **NOT** checked. If it is checked, then select that option to turn-off that feature.

2. To open the Importing Wizard, select **Import Image** and then **Import Into New Pattern** from the **File** menu, or click the Import Image toolbar button . The Importing Wizard will then appear as shown below.
The Importing Wizard provides a step-by-step approach to obtaining the information needed for importing. The left side of the screen shows the prompts/questions used to help you import the image.

The **image pane** in the middle of the window is used to display the image that you have selected for importing. You can zoom-in/out the image to see it better.

The **pattern pane** on the right side of the screen is used for showing the pattern that has been created by importing. It will be updated after all of the Importing Wizard prompts have been shown.

The window divider between the **image pane** and **pattern pane** can be adjusted as desired to see more or less of one pane. Click and drag the divider to adjust the sizing.

While using the importing feature, it is recommended that you maximize the size of the Pattern Maker window to be able to see as much of the image and imported pattern as possible. To maximize the screen, click the Maximum button which is located in the upper right corner of the main Pattern Maker window.

3. On the initial screen as shown above, there are several options for selecting the image to be imported. These are:
   - **Use an Existing Image** – allows you to select an existing image stored on your computer.
   - **Scan a Photo** – allows you to use the TWAIN feature of your scanner to directly scan a photograph or other graphic into the wizard.
   - **Use the Image on the Clipboard** – allows you to select an image that was copied to the clipboard from another program.

For this lesson, the first option will be used to select a file. It is recommended that you use the example file (specified below) the first time you use this lesson. After that, you can then repeat these steps using the image that you created in Part A of this lesson.

Click **Browse** to select the file. For this example select the file called **boy.jpg**. This file is located in the following folder: `c:\My Documents\PM Patterns\Samples`. Click **Open** after making your selection. You should then see the scan displayed in the **image pane**.
4. Click **Next**.

5. Select the option labeled **Convert the Image into Full Cross Stitches**. The other option should not be selected.

6. Click **Next**.

7. This page allows you to adjust the image. This can be useful for correcting a scanned photo that was taken in less than optimum lighting conditions. For this example, use the **Contrast** adjustment to make the contrast a value of 13.

   It is also important to crop the image as much as possible before importing to ensure that only the area that you want to stitch is included in the imported pattern. To crop the image, first click the **Crop Tool**. Next, click and drag a box around that portion of the image that you want to include in the imported pattern. Click the **Crop** button to crop to the selected area. The following shows the selected area and the resulting cropped size.

8. Click **Next**.

9. The grid options page is not used for this example. Click **Next**.

10. This page is used to mark the area of the image that corresponds to the background of the image. The background area is ignored when the image is imported. The fabric of the finished design would then serve as the background. For this example, the background will not be removed. Click **Next** to continue.

11. This page is used to mark one or more areas of the image that contain the most important foreground content. By marking the more important areas, the program can give more priority to those areas when choosing colors. To select a foreground area:

   a. Select the Foreground tool.
   b. Position the mouse over the image.
   c. Click the left mouse button and hold down. Move the mouse to drag a free-hand selection around the foreground area.
   d. Use the slider control to select the percentage of the palette that should be used for the foreground area. In this case, leave the slider on the default of 75%.

   For this example, the following area as shown below was selected.
12. Click **Next**.

13. This page allows you to select the size of the pattern that will be created. In the top half you can specify the size in inches/millimeters, or you can specify the actual number of stitches to use. In both cases the height is automatically calculated to ensure the proportions of the image are maintained.

In the lower half you can specify the size of the stitch to be used. You will get the best results by choosing smaller stitch sizes.

Use the following settings for this example:
- **Size Specified in:** Inches
  - **Width** = 8
- **Stitch Size. Width** = 14 per inch

14. Click **Next**.

15. This page provides color options. Select the **Use the Colors of This Floss/Thread Type** option, and then select the **DMC** brand from the drop-down list.

For the **Maximum Number of Colors to Use** option, select 90. The program will use up to 90 colors to represent the image.

16. Click **Next**.

17. At this point the program is ready to import the image. Click **Import** to convert the image. You should then see the imported pattern appear in the pattern pane of the window. Depending upon the size of the Pattern Maker window, you may not see the entire pattern displayed. Either select a different zoom setting from the toolbar, or click the **Zoom-to-Fit** button to see more of the pattern.
18. At this point in the importing procedure you should examine the design that was created and determine whether more detail is needed or whether more color might produce a better result. In either case you can easily try different settings by simply clicking Back until the options page is shown which contains the setting that you want to tweak. After changing an option, click Next until the last page is shown, and then click Import again. The pattern will then be updated.

You will get the best results when you repeat the importing steps while experimenting with different settings.

19. For this example, click the Back button one time to return to the color-related options. For the maximum number of colors, select 50. Click Next, followed by Finish. As you can see for this example, the decrease in color did not adversely affect the result but simplified the stitching effort. That demonstrates the importance of tweaking the settings to arrive at the optimum settings.

To make it even easier to fine-tune the importing settings, Pattern Maker provides an Interactive Importing feature. This method provides the same options as the Importing Wizard, but allows access to any setting without the need to use Next and Back buttons to move between the option pages. It can also be set up to automatically re-import the image after making a change to any setting of any page. To use this mode, select Use Interactive Importing from the File menu. After selecting that option, the next time you select the importing feature, the interactive method will be used. For more details, see “Image Importing Features” on page 102.

20. After you are satisfied with the importing result, click Close to exit out of the Importing Wizard and to display the pattern in a normal design window.

21. Select Save from the File menu to save the design to a file.

Part C: Cleaning-up the Design

This task involves refining the imported image as necessary and/or desired. You can use any of the stitch drawing tools, editing features, and palette features at this point to refine the design.
In some cases you may want to touch-up areas of the design or remove areas that you do not want represented by stitches. You can also manually replace colors in the design by replacing palette colors.

The stitch usage feature of the Professional version is handy at this point for determining if any colors are used for only a few stitches. Where a color is used for only a minimal number of stitches, you may want to merge that color with another similar color of the palette that is used more in the design. For help in the merging of palette colors, see “Merging Colors of the Palette” on page 80.

Part D: Finishing the Design
This task involves saving and printing the design to create a stitching guide.

1. Select **Save** from the **File** menu to save the design to a file. It is important that you save each design in case you need to re-print or modify the design at a later time.

2. Select **Symbols** from the **View** menu to display the design using symbols.

   Either select **Print Preview** from the **File** menu to preview the printout, or select **Print** to print the design. The printout will include the chart and a listing of the colors and symbols used in the chart.

Lesson 3: Tracing an Existing Chart
This lesson describes how to create a design by importing a scan of an existing cross-stitch chart. With the exception of the grid alignment related steps, these same steps can be used to start a new design that is based on a scan of a hand-drawn sketch.

Prior to importing an existing cross-stitch chart, it is very important that you determine the copyright provisions of the design to ensure that the copyright holder allows the use of the design in this manner.

Overview
The general steps of this lesson involve the following:

1. Scanning the chart.
2. Marking the grid of the scanned chart.
3. Creating a new design that has the scan of the chart as the background with the grid of the existing chart aligned to the grid of the new design.
4. Setting-up the color palette of the design.
5. Tracing the stitches of the scanned chart.

The grid-marking step is the most important one. If the grid is not marked accurately, then the grid of the existing design will not be aligned with the grid of the new design. When not aligned, it is much more difficult to trace-over the stitches of the existing design. The steps of this lesson are designed to help you avoid that problem.

Part A: Preparing the Chart
This task involves preparing the chart for importing. As mentioned in the previous section, it is very important that the grid lines of the scanned chart line up with the grid of the new design. If they are not aligned, then tracing of the existing chart will be much harder.

Aligning the grid involves using the Grid Tool of the Importing Wizard to mark three points on the grid of the scan. From these points the program can then calculate the position of the grid lines in the scan. The three points correspond to the upper left, upper right, and lower right corners of a **square** area of the chart. This square area can be any size. However, the larger the area, the more accurate the alignment will be and the more likely the alignment will be a success on the first try.
Prior to scanning the existing chart, determine the largest convenient square area of the grid. For example, if the chart were 100x80 stitches, then a reasonable size to use for marking the grid would be 80x80 since that is the largest square size that fits in the pattern. However, any square area that mostly fits the chart should work fine as well.

After determining the size of the area to be marked, use a pencil to mark the three points on the actual chart. The following example shows a 30x30 area that has been marked on a chart.

As shown, three points that correspond to 10th-line intersections were chosen to make it easy to count the grid squares. Each point was numbered in the clockwise direction starting with the upper left corner. (The example shown above is also the scan of the chart that is used for this lesson. It was scanned with a small
Part B: Scanning the Chart

This task involves using your scanner and scanner software to perform a scan of the chart to be imported. The specific directions for scanning vary depending upon the model and brand of scanner. Please refer to the documentation that you received with your scanner for details on how to perform a scan.

Here are some recommendations that you should consider when scanning a chart:

- Ensure that the chart is completely flush on the glass of the scanner. If parts of the page being scanned are off of the glass, then the grid lines of those parts of the design will be hard to align to the grid of the new design.
- A DPI setting of 300 is usually sufficient.
- A color resolution of 24 bits is sufficient.
- Save the scan in the bitmap (BMP) file format.

After scanning, you should have on the hard disk of your computer a graphics file, which can then be selected and opened using Pattern Maker. The next part describes how to select that file and import it.

Part C: Importing the Chart into a New Design

This task involves importing the scan of the chart into a new design. The Importing Wizard of the program is used for this task.

1. Select the File menu and verify that the Use Interactive Importing option is NOT checked. If it is checked, then select that option to turn-off that feature. (Note that the interactive method can be used, but for simplicity in the following description, the wizard method is used instead.)

2. To open the Importing Wizard, select the File menu, select Import Image and then Import Into New Pattern, or click the Import Image toolbar button . The Importing Wizard will then appear as shown below.
The Importing Wizard provides a step-by-step approach to obtaining the information needed for importing. The left side of the screen shows the prompts/questions used to help you import the image.

The image pane in the middle of the window is used to display the image that you have selected for importing. You can zoom-in/out the image to see it better.

The pattern pane on the right side of the screen is used for showing the pattern that has been created by importing. It will be updated after all of the Importing Wizard prompts have been shown.

The window divider between the image pane and pattern pane can be adjusted as desired to see more or less of one pane. Click and drag the divider to adjust the sizing.

While using the importing feature, it is recommend that you maximize the size of the Pattern Maker window so you can see as much of the image and imported pattern as possible. To maximize the window, click the Maximum button which is located in the upper right corner of the main Pattern Maker window.

3. To select the scan of the chart that you created in Part B, click Browse. For the chart scan used for this example, select the file called scanned_chart.bmp. This file is located in the following folder: c:\My Documents\PM Patterns\Samples. Click Open after making your selection. You should then see the scan of the chart displayed in the image pane. Please do not be concerned at this point if the grid lines of the chart do not appear legibly. They will appear more clearly in a subsequent step.

4. Click Next. Select the option labeled Include Image as an Underlay for Tracing. The other option should not be selected. Click it to turn it off.

5. Click Next. This page of options allows you to adjust the scan. Several adjustments can be made. For this example, no adjustments will be made.

6. Click Next. The options as shown below will then be displayed.

This page of options provides the tools used to perform the grid alignment as mentioned in previous steps. The object of this step will be to use the Grid Tool to mark the three points that were circled on the chart prior to scanning.

7. Use the Zoom Tool to zoom-in on the first position that was circled on the chart. Left-clicking zooms-in while right-clicking zooms-out. Zoom-in on the first mark so that the grid line intersection is easy to see as shown below. You may also want to enlarge the image pane by moving the window divider between the image pane and the pattern pane.
If after zooming-in you find the grid lines to be very hard to see, or if they appear very blurred, then it will be necessary to back-up to the scanning step and re-scan the chart using a higher DPI so more details is available.

8. Select the **Grid Tool**. Using the Grid Tool, click on the grid line intersection corresponding to position 1. Try to be as accurate as possible in marking the intersection. An X will appear where you clicked. You should see:

Since the order for marking the points is important, the mouse pointer will indicate which point should be marked next. For example, before marking the first position, the mouse cursor will show a ‘1’ as shown below.

![Mouse Pointer 1](image)

After marking position 1, the mouse pointer will then show a ‘2’ to indicate that position 2 should then be marked. After marking all three points, the cursor will show a check mark.

If after marking the position you determine that you need to re-mark the location, then click **Undo Alignment** before marking the position again.

9. Using the scroll bar at the bottom of the image pane, scroll the image to the left such that the second position becomes visible as shown below:
10. Using the Grid Tool, click on the grid line intersection at position 2. An X will appear where you clicked. You should see:

If after marking this position you determine that you need to re-mark the location, then click **Undo Alignment**. You will then need to re-mark the first point before re-marking this point.

11. Using the scroll bar on the right side of the image pane, scroll the image up such that the third position becomes visible as shown below:
12. Using the Grid Tool, click on the grid line intersection at position 3. An X will appear where you clicked. You should see:

![Image of grid tool interaction](image)

If after marking this position you determine that you need to re-mark the location, then click **Undo Alignment**. You will need to re-mark the first and second points before re-marking this point.

13. Enter the size of the marked area in the box labeled **Mark Spacing**. For this example, an area was chosen that was 30x30 stitches in size. As a result, **30** is entered into the Mark Spacing box as shown below.

![Mark Spacing dialog](image)

14. Next, click **Align Grid**. You should then see grid lines appear. However, they may be only slightly visible behind/along the grid lines of the image.

![Aligned grid](image)

15. Compare the alignment of the grid lines. You can use the scroll bars to scroll the image to other positions. A small amount of mis-alignment is okay on the edges of the design as long as you can still determine which grid square each stitch corresponds to. If the alignment is too far off, click **Undo Alignment** and then repeat the steps used to mark the three positions.
Also note that the order of marking the three points is critical. They must be marked in the order shown by this example (upper left, upper right, and then lower right).

If you still have trouble aligning the grid, then try re-scanning the chart. Be sure that the page is completely flat against the glass of the scanner.

16. Click Next. The background selection feature is not used in this case.

17. Click Next. The foreground selection feature is not used in this case.

18. Click Next. The sizing options are not used in this case. **It is critical that you not change any options on this page otherwise the grid alignment may become off.**

19. Click Next. The color options are not used in this case.

20. Click Next. The Ready to Import screen is then shown. Click Import to create a new design with the scanned chart as the background. You should then see the imported chart appear in the pattern pane of the window. The grid of the scanned chart should appear aligned to the grid of the new design.

21. Click Close. The new pattern will then be shown in a normal pattern window.

22. Click Save As from the File menu to save your design.

**Part D: Setting-up the Color Palette for the Design**

This task involves setting-up the color palette that was used for the existing design. You will need the color key that was provided with the original chart for this step. For details on how to add colors to the palette of a design, see “Adding a Color to the Palette” on page 79.

**Part E: Tracing the Stitches of the Existing Chart**

At this point a new chart has been started which includes the scan of the existing chart as the background and the color palette of the existing chart.

This task involves tracing over each stitch that is shown in the existing chart (or those that you want to be included in the new chart). The basic procedure is:

1. Select one of the symbols in the existing chart.
2. Determine the color that corresponds to the symbol using the original color key of the design.
3. Locate that color in the palette of the new design and click it to select it. (Placing the mouse pointer over a color in the palette will cause the color information for that color to be shown.)
4. Use the stitch tools to trace over each occurrence of that symbol in the design.
5. Repeat for the next symbol/color and for all other stitch types including back stitches and French Knots.

While tracing over the stitches, it is often useful to temporarily hide the existing chart to determine what stitches have been traced already or to see if any stitches are missing. To hide the background chart, press the F2 button. To re-show it, press F2 again.

By default, the display view of the new chart will be the Stitch view. Some users prefer to trace an existing chart using the Symbol view or Solid view. You may what to experiment using those views to determine what works best for you.

**Part F: Removing the Background Chart**

You can delete the background chart after you have finished tracing the existing chart and no longer need it. Use these steps to delete it:

1. Click the Rectangular Selection tool of the Drawing toolbar.
2. Click near one of the edges of the background picture. This will cause eight handles to appear around the picture.

3. Press the delete key of the keyboard. The picture will be deleted from the pattern.

Lesson 4: Using the Provided Clipart

This lesson describes how to create a design using the provided clipart.

Part A: Creating an Empty Design

This step involves creating an empty design and setting-up the fabric area of the new design. For this example a fabric area that is 70x50 stitches with a stitch size of 14 count will be created.

1. Select New from the File menu. This will open the Specify Fabric Properties dialog.

This dialog allows you to specify the fabric options. The options shown on the Size tab of this dialog are the most important options to initially specify. For more information on this dialog box, see “Fabric Features” on page 74.

2. In the box labeled Select Stitch Size, specify 14 for the stitches per inch horizontally. (The Square Stitch option should be selected.)

3. For the option labeled By Specifying the Size in Stitches, specify 70 for the width and 50 for the height.

4. Click Ok. You should now see a new design open that is 70 stitches wide and 50 stitches tall.

5. Select Save from the File menu to save your design. Specify a name for your design, and then click Ok. For more details on saving a design, see “Saving Pattern Files” on page 19.

Part B: Inserting a Clipart Item

This step involves browsing thru the provided clipart to locate one or more items that you want to insert into the design.

1. Select Copy from Library from the Library menu, or click the corresponding toolbar button: . This will open the Copy from Library dialog as shown below. If you have
purchased additional clipart, then the contents of this box may appear differently from what is shown below.

2. When this dialog is opened, all available clipart objects will be shown. To help you narrow your choices you can search using three methods: **By Library Theme, By Object Name, By Keyword Search.**

   For this example, click on the first item in the upper left corner to select it.

3. Click **Copy** to copy the object into your design. You should then see the selected item in the upper-left corner of the new design as shown below:
The edges of the stitches in the design will appear dark to indicate that they are currently selected.

4. Position the mouse pointer within the selection (ie. over the inserted object), and then click and hold down the left mouse button. Move the mouse to drag the selected clipart item to the desired location. Next, release the mouse button. For this example, the clipart item was positioned as shown below.
5. Click outside the dotted selection area to unselect the clipart item. The outlining of the edges of the stitches will then appear normal.

6. Repeat the above steps as desired to add more clipart to your design.

7. Select **Save** from the **File** menu to save your design.

**Part C: Adding Text to the Design**

This step can be used to add text to the design (if desired) by using the Text tool of the program. This tool makes use of cross-stitch alphabets (that are provided with the program) or TrueType fonts that you have installed on your computer.

1. Select the floss color to be used for the text by clicking the color in the **Palette Bar** at the bottom of the window. For this example, select DMC 310. For details on changing the palette, see “Palette Features” on page 79.

2. Click the **Text** button of the toolbar. This will open the **Text Options** dialog box as shown below.
3. For this example the Stitched font type will be used. Select the **Stitched** option of the **Select Font Type** box if it is not already selected. Select the font that you want to use from the **Available Stitched Fonts** drop-down list. The selected font will then be shown. Use the scroll bars if you wish to see other characters of the font. For this example, select **Font 4**.

4. Select the size from the **Size** list. For this example, select **size 11**. For more information on the other text options that are available, please see “Drawing Text” on page 51.

5. Click **OK** to begin entering text.

A cursor will then appear on the pattern. You can then begin typing your text. To correct mistakes while typing, press the **backspace** key. To move the location of the cursor, click elsewhere on the design. *Once the cursor position is changed by clicking the mouse, you cannot change/correct the text other than by editing the actual stitches that represent the text. However, the Undo feature can be used to completely remove blocks of text that were entered.*

For this example, click on the pattern at the location shown below to position the text cursor. Also, select the **175% zoom** value to enlarge the view.
6. For this example, type the words “The Best!” as shown below:

7. Select **Save** from the **File** menu to save your design.
Part D: Printing the Design

This step involves displaying the design using the Symbolic view and then printing it.

1. Select Symbols from the View menu, or click the corresponding toolbar button. The design will appear as shown below:

![Symbolic view of a design](image)

In this view each stitch is represented using a symbol. The Palette Options can be used to select different symbols and/or to change the colors used for the symbols. Note also that the color and thickness of the backstitch symbols can also be changed. For more details on how to change the Palette Options, please see “Palette Options” on page 81.

2. To print the design, select Print from the File menu. The design will be printed using one or more pages for the chart and one or more pages for the pattern information which includes the list of floss needed for the design.

Summary

This chapter provided the basic steps to creating designs using Pattern Maker. Since these lessons provided only basic information for using the program, it is recommended that you review the other chapters of this manual for more detailed information.
Stitch Features

It is easy to draw or erase stitches using Pattern Maker. This chapter describes how to draw each type of stitch support by the program.

Drawing Full, Petite, Half, and Quarter Stitches

To draw a full, petite, half or quarter stitch:

1. Select the floss color to be used for the stitch. This is done by clicking the color in the Palette Bar.
2. Click the Full, Petite, Half or Quarter stitch tool of the Drawing toolbar.
3. Position the mouse on the pattern where you want to draw the stitch.
4. Click the mouse (left mouse button) to draw the stitch.
5. If you want to draw several stitches in the same area, just click and hold the left mouse button, and drag the mouse where you want the stitches to be placed. To use only the first stitch orientation drawn, select the Repeat First Stitch Orientation item of the Stitch menu.

For petite, half, and quarter stitches, the orientation of the stitch within a particular grid location depends upon the position (i.e. top left, top right, bottom left, or bottom right) clicked by the mouse.

Any non-overlapping combination of stitches can be placed in a given stitch position of the pattern. For example, you can place all four types of quarter stitches in a stitch position with each quarter stitch having a different color.

To draw a three-quarters stitch, place a half stitch and a quarter stitch together in the grid position.

Petite stitches are useful when you are designing for linen fabric and need to have more detail in an area, such as the face of a person. In that case you can use petite stitches in place of full stitches to provide four times the amount of detail.

Erasing Full, Petite, Half, and Quarter Stitches

Full, petite, half, and quarter stitches are erased using the same procedure as used to draw these stitches except the right mouse button is used instead. Please refer to the previous section for more details.

Drawing Back and Straight Stitches

To draw a back stitch or straight stitch:

1. Select the floss color to be used for the stitch by clicking the color in the Palette Bar.
2. Click the **Back Stitch** tool or **Straight Stitch** tool of the Drawing toolbar.

3. If the display of grid lines is not selected, then select **Show Grid** from the **View** menu.

4. Position the mouse at the intersection of two grid lines where you want the stitch to begin. Click and hold the left mouse button.

5. Move the mouse pointer to the end point of the stitch, and release the mouse button. The end point can be at any other grid line intersection.

To allow back stitches to also start/end at the midpoints of the grid, select **Back/Straight Stitch Snap To** followed by **Corners and Midpoints** of the **Stitch** menu (or press **Ctrl+2**). To start/end only at the corners, select **Back/Straight Stitch Snap To** followed by **Corners** of the **Stitch** menu (or press **Ctrl+1**).

The **back stitch outline mode** is useful when you want to trace around an object in an underlay image or when you only want to draw back stitches that connect to adjacent grid intersections. In this mode, back stitches are automatically inserted into the design as you move the mouse pointer along a path. It is not necessary in this case to click and release the mouse button for each stitch. The following explains how to trace with back stitches:

1. Select the floss color to be used for the stitch.

2. Click the **Back Stitch** tool of the Drawing toolbar.

3. Select **Back Stitch Outline Mode** of the **Stitch** menu.

4. Click and hold down the left mouse button, and then move the mouse to trace around the object that you want outlined.

5. Release the mouse button when you are finished tracing. Select **Back Stitch Outline Mode** of the **Stitch** menu again to turn-off the outline mode.

---

**Erasing Back and Straight Stitches**

To erase a back stitch or straight stitch:

1. Click the tool used to draw the stitch. If the stitch is a back stitch, then click the **Back Stitch** tool of the Drawing toolbar. Otherwise click the **Straight Stitch** tool.

2. Position the mouse pointer near the stitch to be erased, and then click the left mouse button. This will cause selection markers to be displayed at each end of the stitch. These markers look like filled squares as shown below:

![Selection Markers](image)

3. While still positioning the mouse near the stitch, click the **right** mouse button. This will cause the stitch to disappear.

Sometimes more than one stitch will be near a point that you click. In that case, when you press the left mouse button you may find that the desired stitch is not selected, but instead another stitch. To select the desired stitch, simply click again at the same position. It may be necessary to click several times for the stitch of interest to be selected.

To **move** the end-point of a back or straight stitch:

1. Click the tool used to draw the stitch, and then select the stitch as described above.

2. Press and hold down the **shift** key.

3. While positioning the mouse pointer near one of the end points of the stitch, press and hold down the left mouse button. Move the mouse to move the end point of the stitch.
4. Release the left mouse button and the shift key.

**Drawing French Knots**

To draw a French Knot:

1. Select the floss color to be used for the stitch.
2. Click the French Knot tool of the Drawing toolbar.
3. If the display of grid lines is not selected, then select Show Grid from the View menu.
4. Position the mouse at the intersection of two grid lines or at one of the midpoints. Click the left mouse button.

**Erasing French Knots**

French Knots are erased using the same procedure as used to draw the French Knot except the right mouse button is used instead. Please refer to the previous section for more details.

**Drawing Beads**

To draw a bead:

1. Select the bead color to be used for the bead. A color from one of the bead color types (ex. Mill Hill Glass Seed Bead) must be used when drawing beads.
2. Click the Bead tool of the Drawing toolbar.
3. If the display of grid lines is not selected, then select Show Grid from the View menu.
4. Position the mouse pointer at the intersection of two grid lines or at one of the midpoints. Click the left mouse button.

To change the orientation of a bead in the design:

1. Click the Bead tool of the Drawing toolbar.
2. Click a bead in the design to select it. A dotted box will appear around the bead.
3. Select one of the Rotation options of the Edit menu, or click the corresponding button of the Command toolbar. The orientation will be changed by 90 degrees.

**Erasing Beads**

To erase a bead:

1. Click the Bead tool of the Drawing toolbar.
2. Left-click a bead in the design to select it. A dotted box will then appear around the bead.
3. Right-click the bead to delete it.

**Drawing Specialty Stitches**

To draw a specialty stitch:

1. Select the floss color to be used for the stitch.
2. Click the down arrow of the **Specialty Stitch** button.

3. A drop-down menu of specialty stitches will appear as shown below. (Note that there may be a delay the first time this menu is displayed. Thereafter it displays immediately.)

4. To see the name of a stitch, point to the stitch with the mouse. To select a stitch for drawing, click the stitch. The menu will then removed.

5. Use the mouse to point to the location where the stitch should be placed.

6. Click the left mouse button. The stitch will be drawn.

To move a specialty stitch:

1. Click the **Specialty Stitch** tool button of the Drawing toolbar.
2. Click a specialty stitch to select it. A dotted box will appear around the stitch.
3. Click and drag the stitch to the new location. The stitch can be moved by full grid position increments when dragging in this manner. To move a stitch ½ of a grid position, use one of the arrow keys of the keyboard.

Some specialty stitches are designed to allow the repeating of the stitch by stretching the stitch. Stitches with this capability will show a handle on one side of the stitch when it is selected.

To show repeats, click and drag the handle until the desired number of repeats are shown.
To change the orientation of a specialty stitch in the design:

1. Click the **Specialty Stitch** tool button of the Drawing toolbar.
2. Click a specialty stitch in the design to select it. A dotted box will appear around the stitch.
3. Select one of the **Rotation** options of the **Edit** menu, or click the corresponding button of the Command toolbar. The stitch orientation will then be changed by 90 degrees.

---

**Erasing Specialty Stitches**

To erase a specialty stitch:

1. Click the **Specialty Stitch** tool button of the Drawing toolbar.
2. Click a specialty stitch in the design to select it. A dotted box will appear around the stitch.
3. Right-click the stitch or press the **delete** key of the keyboard. The stitch will be removed.

---

**Drawing Text**

Pattern Maker allows you to quickly insert text into your designs. This text can be shown using either cross-stitched fonts included with the program, cross-stitched fonts that you have created, or TrueType fonts installed on your computer. The following describes how to insert text.

1. Select the floss color to be used for the text.
2. Click the **Text** button of the Drawing toolbar.
3. This will open the **Text Options** dialog box as shown below.

![Text Options dialog box](image)

4. Select the type of font to be used in the **Select Font Type** option box. Select **Stitched** to use one of the provided cross-stitch fonts (or one that you have created). Select **TrueType** to use one of the fonts installed on your computer.

5. Select the font that you want to use from either the **Available Stitched Fonts** or **Available TrueType Fonts** drop-down list depending upon the type of font chosen in step 4. For stitched fonts, the selected font will then be shown. Use the scroll bars to see other characters of the font.

6. Select the size from the **Size** list.

7. Select other options depending upon the font type:
   - **Use Font Color(s)** - select this option to use the actual colors of the font. Otherwise, the currently selected color in the palette will be used for the text.
   - **Bold** - select the bold attribute for the font.
   - **Italics** - select the italics attribute for the font.
   - **Fill Using Petite Stitches** - use petite stitches to represent the text instead of full stitches.

8. To have the text centered horizontally on the pattern, select **Center Text Horizontally**.

9. To increase the spacing between lines and/or between characters, specify the spacing in the **Line** and/or **Character** boxes.

10. To limit the text to a particular area of the design, specify suitable margins.

11. Click **OK** to begin entering text.

12. A cursor will then appear on the pattern. You can then begin typing your text. To correct mistakes while typing, press the **backspace** key. To move the location of the cursor, click elsewhere on the design. **Once the cursor position is changed by clicking the mouse, you cannot change/correct the text other than by editing the actual stitches that represent the text.**
To paste text from another application using the **Text** tool, first select and copy the text in the other application. Next, select **Paste** from the **Edit** menu or press **Ctrl+V** to paste the text into the pattern.

To create additional font patterns for use by the Text tool, see “Creating a Font Library” on page 161.

---

### Eyedropper Tool

Often when drawing and editing stitches it is useful to know the actual color that was used for an existing stitch. The Eyedropper tool can be used for this purpose. To use it, first click the **Eyedropper** button of the Drawing toolbar. The appearance of the mouse cursor will then resemble an eyedropper. As it is positioned over a stitch, the color and stitch type will be shown near the stitch.

To make the color under the Eyedropper the current color for drawing, click the left mouse button. To make the stitch type of the stitch under the Eyedropper the current drawing tool, click the right mouse button.

When drawing stitches, you can temporarily switch to the Eyedropper tool by pressing and holding the space bar key of the keyboard. The Eyedropper will remain active as long as you continue to press the space bar. When you release it, the previous tool will become active again.

---

### Stitch Options Dialog

The **Stitch Options** dialog box is used to specify the stitch thicknesses and outlining options. Several option pages are provided by this dialog. Each page is described in the following sections.

#### Actual Thickness

The **Actual Thickness** page of the **Stitch Options** dialog box allows you to specify the default thickness for each stitch type. To open this dialog box, select **Stitch Options** from the **Stitch** menu, and then click the **Actual Thickness** tab. This page is shown below.

![Stitch Options Dialog](image)

Specify the default stitch thickness for each stitch type. Click **Update Palette Settings** to have all palette colors in the palette use the defaults shown. This is useful when some of the colors were changed to use non-default values, but later you decide to use the same thickness for each type.

Select **Use For New Patterns** if you want these options to be used for new patterns.
Display Thickness

The Display Thickness page of the Stitch Options dialog box allows you to specify the display and printed thickness for each possible stitch thickness. To open this dialog box, select Stitch Options from the Stitch menu, and then click the Display Thickness tab. This page is shown below.

Specify how thick each of the possible strand counts should appear on the screen or printout. The thicknesses are measured in points. A point is 1/72 of an inch.

Select Use For New Patterns if you want these options to be used for new patterns.

Outlining

The Outlining page of the Stitch Options dialog box allows you to specify the options for the outlining effect. The outlining effect is used to enhance the appearance of stitches on the display and printout. To open this dialog box, select Stitch Options from the Stitch menu, and then click the Outlining tab. This page is shown below.
Click **Outline Stitches** to enable/disable the outlining effect.

Specify the thickness of the outlining effect using the **Thickness** drop-down list. The thickness setting is used for printing and exporting. For display, an outline thickness of 1 pixel is always used.

Use the **Color** options to specify the color of the outlining. These options are:

- **Use Stitch Color** – the outline effect uses the stitch color darkened or lightened by the specified percent.
- **Use Specified Color** – the specified color is used for the outline color.

Select **Use For New Patterns** if you want these options to be used for new patterns.

### Creating Specialty Stitches

This section describes how to create and edit the stitches used for the Specialty Stitch tool. This feature is only available in the **Professional** level.

To edit or create a Specialty Stitch, select **Edit Specialty Stitch** from the **Stitch** menu. This will open the following dialog box.

This dialog lists all available specialty stitches. To edit an existing stitch, select the stitch and click **Edit**. To delete a stitch, select the stitch and click **Delete**. To create a new stitch, click **New**. This will open the **Edit Custom Stitch** dialog box as shown below.
The top of this box includes a toolbar which has some of the tools available in the toolbars of the main Pattern Maker window. These tools are used in drawing a specialty stitch.

The middle portion of the dialog includes a grid where the specialty stitch is drawn. All stitches drawn in this grid become part of the specialty stitch being created or edited.

The lower portion of the dialog includes fields that are used for naming the stitch.

**Creating a Specialty Stitch**

The following steps can be used to create a new stitch. These assume you have already opened the Edit Custom Stitch dialog box.

1. Specify a unique name for the stitch in the box labeled **Unique Stitch Name**. Since this name is used as part of the file name used in storing the stitch, this name must be unique and conform to file naming limitations.

2. Optionally, to have a different name appear in the pattern information or page layout, you can specify that name in the **Stitch Name** field of the **Settings Used for Floss/Thread Info**. This allows you to use the same name for more than one stitch such as in the case where only the size of the stitch is different (i.e. over 2 vs. over 4).

3. When a stitch is setup to allow repeating (described below), you can specify the number of repeats that should be used when showing the stitch in the pattern information via the **Number of Repeats for Example Stitch** field.

4. Use the stitch drawing tools in the toolbar at the top of this dialog box to draw the stitch. All stitches drawn become part of the new stitch. The stitches are displayed in a design in the same order as drawn here. Only one color is used when drawing a stitch. The Curved Stitch tool is unique for this feature. This tool is described in more detail below.

5. Click **Ok** when you are finished drawing the stitch.

**Creating a Repeating Stitch**

The stitch editor allows the creation of stitches that can be made to repeat for filling an area. When drawing a specialty stitch, those stitches that have this capability will show a small handle (appearing as a filled square on one side) when the stitch is selected. The handle can then be clicked and dragged to make the stitch repeat as shown below.
A repeated stitch is created by defining 3 sets of stitches. These include the:

- **First Set** – This group of stitches is always drawn at least once.
- **Repeated Set** – This group of stitches is drawn as many times as needed to repeat the stitch.
- **Finishing Set** – This group of stitches is always drawn at least once. It is either drawn after the first set, or after the last repeated set.

In the case of the Back-Stitched Chain stitch, the following sets are used:

- **First Set**

- **Repeated Set**

- **Finishing Set**

For each case, the dark blue stitches represent the stitches of the current set while the light blue stitches represent the other sets. When the program repeats this specialty stitch, it will insert the first set and then insert the repeated set in the position shown above. If more repeats are needed, the program will then offset the repeated stitch the same amount that the first set and repeated set are offset in the stitch definition. After the repeated stitches are added, the finishing set will then be added. The relative positioning of the finishing set will be the same as in the stitch definition.

*When creating a repeating stitch, the first and repeated sets must be the same length (i.e. in the repeating direction).*

To create a repeated stitch, select the set that you want to draw and then use the stitch tools to draw that set. The current set is selected via the **Stitches to View and Edit** options.

**Curved Stitch Tool**

The Curved Stitch tool is available when creating specialty stitches. This tool allows you to draw smooth, curved stitches. Curved stitches are defined by specifying two or more points that line on the curve. The
program automatically calculates a smooth curve that will pass thru those points. Multiple points can be added to allow you to precisely control the shape. To draw this type of stitch:

1. Click the Curved Stitch tool.
2. Click the mouse where you want the stitch to begin. This will position the first point of the stitch. Thereafter, as you move the mouse a dashed line will be drawn to show where the stitch will be located.
3. Click the mouse again to position the next point of the curve. The curve will be updated to pass thru the previous point(s), new point, and to the current location of the mouse pointer.
4. Repeat step 3 as desired to add more points.
5. After all points have been added, right click to finish the curve. (The location that is right-clicked is not used.)

After a curve has been drawn, you can add, delete, or move points of the curve. You can also change the overall size of the curve.

Each of the following steps assumes the Curved Stitch tool is selected.

To add a new point to a curve:

1. Click on the curve to select it. A rectangular box will then be shown around the curve. (If you accidentally click too far away from a curve, the tool will add a new point for a new curve. In that case just right click to cancel the new curve.)
2. Right-click on the curve where you want to add the new point.
3. In the menu that appears, select Insert Point. A new point will be shown.

To delete an existing point on a curve:

1. Click on the curve to select it. A rectangular box will then be shown around the curve.
2. Right-click the point that you want to delete.
3. In the menu that appears, select Delete Point. The point will then be removed.

To move an existing point:

1. Click on the curve to select it. A rectangular box will then be shown around the curve.
2. Click and drag a point to move it.

To change the overall size of the curve:

1. Click on the curve to select it. A rectangular box will then be shown around the curve.
2. Grab one of the selection handles around the curve to stretch or shrink the size.

To move the overall position of the curve:

1. Click on the curve to select it. A rectangular box will be shown around the curve.
2. Click and drag (within) the selection box of the curve to move the stitch. The arrow keys on the keyboard can also be used to move the stitch by a fine amount.
This chapter discusses the editing features of Pattern Maker. These features include a rich assortment of editing commands that you can use to polish and refine your designs.

Overview

The editing features of Pattern Maker provide many features for modifying your design. These features include:

- Basic Editing
  - Cut, Copy, Paste, Move
  - Flip, Rotate
  - Clear
  - Flood Fill
  - Area Fill
  - Centering
  - Undo

- Advanced Editing *(Professional level only)*
  - Free-hand Selection Tool
  - Advanced Selection Features
  - Stitch Color/Type Replacement
  - Back Stitch Outlining
  - Advanced Area Fill
  - Paste Into Selection

Each feature is described in detail by this chapter.

Most of the editing features require that a selected area of the design be chosen. The following sections describe how to use the selection features. It is highly recommended that you study the following sections so you can get the most from the editing features.

Selecting a Pattern Area

Many of the editing features require that you first specify a portion of the pattern to be changed. Two tools are provided for making selections. These include the:

- Rectangular Selection Tool – used to select rectangular-shaped area
• Free-Hand Selection Tool - used to select an arbitrarily-shaped area (Professional level only)

When an area of a design is selected, that area can be repositioned within the design without the selected stitches combining with the non-selected stitches. In other words, the selection *floats* over the non-selected area. When the selection is ended, the stitches of the selection are then merged with the stitches that are currently under the selection.

**Drawing a Rectangular Selection**

To select a rectangular-shaped area of a design:

1. Click the **Rectangular Selection** tool [ ] of the Drawing toolbar.
2. Position the mouse cursor at the upper left corner of the area that you want to select.
3. Click and hold the left mouse button.
4. Drag the mouse to the lower right corner of the area. This will cause a dotted box to be drawn from the starting point to the current location of the mouse.
5. Release the mouse button. The dotted box will remain.

Stitches that are included in a selection are indicated via dark outlining around the edges of each stitch.

To de-select the area, simply click outside of the selection.

Note that when a pattern contains an image that was imported as a picture (as opposed to being converted into stitches), the picture will be selected whenever it is clicked with the **Rectangular Selection** tool. This can prevent you from selecting an area that lays over/under the image. In this case, you must temporarily hide the image via the **Show Picture** item of the **Fabric** menu to allow the selection to be made.

**Drawing a Free-Hand Selection**

To select an arbitrarily-shaped area of a design:

1. Click the **Free-Hand Selection** tool [ ] of the Drawing toolbar.
2. While holding-down the left mouse button, use the mouse to draw a selection around any group of stitches.
3. Release the mouse button. The selected area will then be outlined with a dashed border.

Stitches that are included in a selection are indicated via dark outlining around the edges of each stitch.

To de-select the area, simply click outside of the selection.

**Advanced Selection Features**

The **Professional** level of Pattern Maker includes advanced features that extend the capabilities of the selection tools. These features allow you to narrow the selection to contain only:

• Selected stitch types, and/or
• Selected colors

**Narrowing a Selection by Stitch Type**

To narrow a selection to only certain stitch types, first select **Show Selected Stitch Types** from the **Tools** menu. This will display the **Selected Stitch Types** toolbar as shown below.
This toolbar includes a button for every stitch type and orientation. When a stitch is included in a selection, the corresponding button of the toolbar will be enabled and appear blue. The buttons corresponding to stitches that are not included within the area of the selection are disabled and appear gray. In the example above, the corresponding selection included a full stitch, quarter stitch (upper-right orientation), and a back stitch.

In the example below, the toolbar and corresponding selection are shown.

This selection includes stitches of the three types indicated by the Selected Stitch Types toolbar.

In the example below, the full stitch type has been removed from the selection by clicking the full stitch button of the Selected Stitch Types toolbar.

The full stitches are no longer included in the selection.

To hide the Selected Stitch Types toolbar when you are finished using it, click the close icon in the upper right corner of the toolbar.

**Narrowing a Selection by Color**

When a selection is made, the Palette Bar indicates which colors are used in the selected area by showing a check mark on each color as shown below.
To exclude all stitches of the selection that use a particular color, click on the check mark of that color. The check mark will be replaced with an ‘x’ as shown below.

As shown, the stitches of the un-selected color are no longer outlined to indicate that they are no longer selected.

To un-select all colors of the selection, right click on one of the check marks or ‘x’, and then click the Select None option of the menu that appears. Similarly, to select all colors of the selection, choose the Select All option of that menu.

The Select None option is handy when you only want to select one color. In that case use the Select None option to de-select all colors, and then specifically re-select the desired color.

**Narrowing a Selection by Color and Stitch Type**

To narrow a selection so that it includes only certain stitch types and colors, simply combine the features of the previous two sections.

As an example of using them together, assume you wanted to select all back stitches in a certain portion of the design that use DMC 910 so you could change the color. You would first use one of the selection tools to select that area of the design. Next, you would use the techniques from the previous sections to select only DMC 910 and only the back stitches. You would then be left with only back stitches of the DMC 910 color included in the selection. The change-color editing command could then be used to replace the color of just those stitches.

---

**Basic Editing Features**

The following sections describe the basic editing features of Pattern Maker. These features are provided in all levels of Pattern Maker.
Cut, Copy, Paste

The Cut, Copy, and Paste commands can be used to duplicate or move a selected portion of a design either into the same design or into another design.

The Cut command \(\text{\(\text{\textcircled{\text{C}}\)}}\) removes the current selection from the design and places it on the Windows Clipboard. You can then paste it back into the same design or another design.

To use the Cut command, first make a selection, and then choose Cut from the Edit menu.

The Copy command \(\text{\(\text{\textcircled{\text{C}}\)}}\) works like the Cut command except that it does not remove the selection from the design. To use the Copy command, first make a selection, and then choose Copy from the Edit menu.

The Paste command \(\text{\(\text{\textcircled{\text{P}}\)}}\) is used to insert a selection that was previously cut or copied. This is useful when you want to copy a portion of one design into the same design or another design.

Follow these steps to paste a selection into the current design:

1. Choose Paste from the Edit menu. The selection will then appear in the upper left corner of the pattern window.
2. Position the mouse pointer within the selection, and then click and hold down the left mouse button.
3. Drag the selection to the desired location.
4. Release the mouse button.

The Copy As command of the Edit menu provides additional choices for the selection that is copied onto the clipboard. These are:

- **Bitmap** – This option copies a bitmap representation of the selection onto the clipboard. This bitmap can then be pasted into another program that can use bitmaps.

- **OLE Pattern Object** – (Professional level only) This option copies a Pattern Maker chart object onto the clipboard. This object represents the entire pattern and can be inserted into a document created by another program. For more details, see “Using Windows OLE” on page 117.

Drag-Move

Use the Drag-Move feature to move a selection to another location in the same design. Follow these steps to Drag-Move a selection:

1. Use a selection tool to make a selection.
2. Position the mouse pointer within the selection, and then click and hold down the left mouse button.
3. Move the mouse to drag the selection to the desired location.
4. Release the mouse button.

Drag-Copy

Use the Drag-Copy feature to copy a selection to another location in the same design. Follow these steps to Drag-Copy a selection:

1. Use a selection tool to make a selection.
2. Position the mouse pointer within the selection.
3. While pressing and holding the **shift** key of the keyboard, click and hold down the left mouse button.
4. Move the mouse to drag a copy of the selection to the desired location.
5. Release the mouse button.

**Quick-Copy**

When drawing borders for patterns, you often need to repeat a particular collection of stitches several times around the edges of the pattern. The **Quick-Copy** feature makes that task easy. Use the **Quick-Copy** feature to place a copy of the current selection either to the left, to the right, above, or below the selection. Follow these steps to **Quick-Copy** a selection:

1. Use a selection tool to make a selection.
2. Press and hold the **shift** key.
3. Press one of the **arrow** keys. The selection will be copied in the area adjacent to the selection corresponding to the direction of the key pressed.
4. Either release the **shift** key, or press an **arrow** key again to continue copying.

**Flip**

The **Flip** feature is often used to create a mirror image of a selection. Follow these steps to flip a selection:

1. Use a selection tool to make a selection.
2. Click either the **Flip Horizontally** or **Flip Vertically** buttons of the Commands toolbar. Or, select **Flip** from the **Edit** menu.

To create a mirror image of a particular region of a pattern, first copy the region and then apply the above steps.

**Rotate**

Use the **Rotate** feature to rotate a selection by 90 degrees either clockwise or counter clockwise. Follow these steps to rotate a selection:

1. Use a selection tool to make a selection.
2. Click either the **Rotate Clockwise** or **Rotate Counter Clockwise** buttons of the Commands toolbar. Or, select **Rotate** from the **Edit** menu.

**Clear**

Use the **Clear** feature to remove the stitches of a selection if one is currently active or clear the entire pattern if no selection is active. Follow these steps to clear a selection:

1. Use a selection tool to make a selection.
2. Click the **Clear** button of the Command toolbar, or select **Clear** from the **Edit** menu.

Follow these steps to clear the entire pattern:

1. De-select the current selection (if any).
2. Click the **Clear** button of the Command toolbar, or select **Clear** from the **Edit** menu. You will then be asked to confirm the clearing of the pattern.
3. Click **Yes** to allow the pattern to be cleared. Otherwise, click **No**.
**Flood Fill**

The **Flood Fill** tool fills an area by repeatedly filling adjacent stitch positions until either another stitch color is reached or a back/straight stitch is reached. The **Flood Fill** tool uses full and quarter stitches when filling. Quarter stitches are used whenever the stitch position to fill is already occupied by other partial stitches, or is partially covered by a back or straight stitch. The following shows a simple example of how the tool fills an area.

As shown above, full stitches are used to fill most of the area while quarter stitches are used to fill along the diagonals.

The **Flood Fill** tool can also be used to replace an area of contiguous stitch color. In this case the first stitch **left-clicked** is used to determine the color of stitches to be replaced. Only full, half, quarter, and petite stitches are affected. The following is an example of this case.

As shown above, the Flood Fill tool was used to change the area of yellow stitches into green (the current palette color).

The **Flood Fill** tool can also be used to un-fill an area of contiguous stitch color. In this case the first stitch **right-clicked** is used to determine the color of stitches to be removed. Only full, half, quarter, and petite stitches are affected. The following is an example of this case.
Area Fill

The **Area Fill** feature is used to fill a selection with stitches of the currently selected color. Follow these steps to fill a selection:

1. Use a selection tool to make a selection.
2. Select the floss color to be used.
3. In the **Standard** level, select **Fill** from the **Edit** menu. In the **Professional** level, select **Fill** followed by **Entire Selection** from the **Edit** menu. In both cases the following dialog box will appear:

![Select Stitch Types dialog box](image)

Select the stitch types that should be used to fill the area. Note that if the Full stitch type is selected, then Half stitch types cannot be selected. Click **Ok**.

4. The selection will be filled using the stitch types chosen in step 3.

When filling, the **Area Fill** feature will attempt to fill each stitch position of the selection starting with the largest stitch type down to the smallest type.

Centering

The **Centering** feature is used to center a selection either vertically or horizontally within the design. Follow these steps to center a selection:

1. Use a selection tool to make a selection.
2. From the **Edit** menu, select **Center** and then either **Horizontally** or **Vertically**.

To center the entire design:

1. Choose **Select All** from the **Edit** menu. This will select the entire design.
2. From the **Edit** menu, select **Center** and then either **Horizontally** or **Vertically**.

Undo

Often you may find it desirable to reverse a change that you made. This is easily done by clicking the **Undo** button on the Main toolbar, by selecting **Undo** from the **Edit** menu, or by pressing **ctrl-z** on the keyboard. The Undo feature remembers up to 100 changes. For each use of the **Undo** command, a previous change will be undone. Note that the Undo list is cleared whenever a pattern is closed.

The Undo feature can also undo changes made to the palette of a design.

Advanced Editing Features

The following sections describe the advanced editing features of Pattern Maker. These features are only available in the **Professional** level of Pattern Maker.
Stitch Color Replacement

The **Stitch Color Replacement** feature is used to replace the color of all selected stitches with the currently selected color. Follow these steps to change the color of a selection:

1. Use a selection tool to make a selection. Typically for this command you will also want to narrow the selection by color. (For more information, see “Advanced Selection Features” on page 60.)

2. Select the floss color to be used.

3. Click the **Change Color** button of the Commands toolbar. Or, select **Change Stitch Color** of the **Edit** menu. The color of all selected stitches will then be replaced with the current color.

Stitch Type Replacement

The **Stitch Type Replacement** feature is used to replace the type of all selected stitches with the chosen stitch types. This feature only applies to Full, Half, Quarter, and Petite stitches. Follow these steps to change the stitch type of a selection:

1. Use a selection tool to make a selection. Typically for this command you will also want to narrow the selection by stitch type. (For more information, see “Advanced Selection Features” on page 60.)

2. Select the floss color to be used.

3. Click the **Change Stitch Type** button of the Commands toolbar. Or, select **Change Stitch Type** of the **Edit** menu. The following dialog box will appear:

   ![Change-Stitch Options dialog box](image)

   In the **Find this Stitch Type** box, select the stitch type that should be replaced. In the **Replace with These Stitch Types** box, select the new stitch types to be used. When replacing a stitch, this feature will attempt to fill each stitch position of the selection starting with the largest stitch type (of the chosen replacement types) down to the smallest stitch type.

4. Click **Ok**. The stitches will be replaced.

Back Stitch Outlining

The **Back Stitch Outlining** feature can be used to automatically add back stitches:
• Between different colored stitches
• Between stitches and empty fabric area
• Around a selection

The following shows how this tool can outline between different colored stitches:

The following shows how this tool can outline between the stitches and the fabric:

The following shows how this tool can outline around a selection:

Use the following steps to outline an area:

1. Use a selection tool to select the stitches that you want to outline.
2. Click one of the outline buttons on the Command toolbar:
   - **Outline Between Colors**
   - **Outline Between Stitches and Fabric**
   - **Outline Around the Selection**
   Or, select **Auto Outline** from the **Edit** menu.

Advanced Area Fill

The **Advanced Area Fill** feature can be used to fill the empty fabric areas of a selection using selected stitch types. The following shows how this tool can be used:

Use the following steps to fill an area:

1. Use a selection tool to select the area that you want filled.
2. Click the **Fill Empty Area of Selection** button on the Commands toolbar. Or, select **Fill** followed by **Empty Areas Within Selection** of the **Edit** menu. The following dialog box will appear:
Select the stitch types that should be used to fill the area. Note that if the Full stitch type is selected, then Half stitch types cannot be selected. Click **Ok**.

3. The selection will be filled with stitch types chosen in step 3.

When filling, this feature will attempt to fill each stitch position of the selection starting with the largest stitch type down to the smallest type.

**Paste Into Selection**

The **Paste Into Selection** feature can be used to paste a previously copied selection into the current selection. The feature provides several options which give it an interesting range of uses. To use this feature:

1. Select and copy a group of stitches to the clipboard.
2. Select the portion of the design where you want to paste the previously copied stitches.
3. Choose **Paste Into Selection** from the **Edit** menu. The following dialog box will appear:

Select from the following options, and then click **Ok**.

The following options are available for the **Paste Info** category:

- **Entire Selection** – the copied stitches will be pasted into the entire selection in both empty areas and areas already occupied by stitches.
- **Empty Areas of Selection** – the copied stitches will only be pasted into the selection where there are not already stitches.
- **Areas Occupied by Selected Stitches** – the copied stitches will be used to modified the stitches of the selection as follows:
  - **Change Color of Existing Stitches** – the color of the existing stitches will be changed based upon the color of the stitches being pasted.
**Change Type of Existing Stitches** – the type of the existing stitches will be changed based upon the type of the stitches being pasted.

The following additional options are available:

- **Use Partial Stitches** – the pasted stitches will be reduced to partial stitches as needed to fill partial stitch positions.
- **Tile the Pasted Selection** – the pasted stitches will be repeated in a tiling manner to fill the selection. When this feature is not used, the pasted stitches are only used once to fill the selection.

The following examples are provided to help you better understand the capabilities of this feature.

The first example of this feature shows how to paste a set of stitches to produce a filling pattern.

![Example 1](image1)

In the example, the red and green stitches were first selected and then copied. The selection was exactly around the 2x2 stitch area containing the stitches. Next, a new selection was drawn as shown in the middle. Next, the **Paste Into Selection** feature was selected. The **Entire Selection** and **Tile the Pasted Selection** options were chosen for this case. As shown, the red and green stitches were then tiled within the selection.

The following is another example.

![Example 2](image2)

For this example the same steps were used as in the previous example, except the **Empty Areas of Selection** option of the **Paste Into Selection** feature was chosen. For this case, only the areas within the selection that were empty were filled with the red and green stitches.

When pasting into a selection that includes partial stitches (half, quarter, or petite), the **Use Partial Stitches** option of the **Paste Into Selection** feature can be selected to enable the use of partial stitches.

The following shows how that feature would affect the result.

![Example 3](image3)

As shown, the **Use Partial Stitches** option caused red quarter stitches to be used to fill some positions where the red full stitch would have been used.

The **Paste Into Selection** feature can also be used to fill that portion of a selection that contains stitches.
In this example the **Areas Occupied by Selected Stitches** and the **Change Color of Existing Stitches** options were selected. As shown, the color of the stitches in the selection was replaced with the color of the stitches that were pasted.

In a similar way, it is possible to use this feature to change the stitch types of the selected stitches based upon the stitch types of the pasted stitches.

### Options

Several options are available that relate to the pasting of a selection. These options can be turned on/off by selecting them from the **Paste Options** submenu of the **Edit** menu. These options include:

- **Add All Colors When Pasting** – When enabled, all colors of a pasted selection will be added to the palette of the design even if they are already included in the palette. This feature could be used when you are already using some of the same colors in the design for other stitches, but you desire to select different palette options (i.e. strands, etc.) for the pasted stitches.

- **Overlay Stitches When Pasting** – When enabled, the stitches of the pasted selection will be merged with the stitches that lie underneath the selection. When not enabled, all stitches underneath the selection are removed before pasting the selection.

- **Delete Hidden Stitches When Pasting** – When enabled, back stitches or straight stitches which become obscured by the stitches of a pasted selection are automatically deleted. Otherwise, the existing stitches are not affected.

### Layout Regions

The Page Layout feature of Pattern Maker allows Chart Objects to be inserted into a layout. A Chart Object is a graphic that is automatically generated and updated by Pattern Maker. An object can represent all or some portion of a design. When creating an object that only represents a portion of the design, it is necessary to first mark that area as a layout region.

To mark a layout region:

1. Select the Stitch, Symbolic, or Solid view.
2. Select the Rectangular Selection tool and use it to select the desired portion of the design. (Note that the advanced selection features are ignored in this case.)
3. From the **Edit** menu, select **Layout**, and then **Mark Layout Region**. This will open a dialog box where you can name the region. This name will appear in the list of regions that appears when creating a Chart Object.
4. Click **Ok**. The layout region will then be indicated on the chart by a box with the name of the region displayed.

To delete a layout region:

1. Select the Stitch, Symbolic, or Solid view.
2. From the **Edit** menu, select **Layout**, and then **Delete Layout Region**. This will open a dialog box that lists all of the currently marked regions.
3. Select the region to be deleted, and click Delete.

4. Click Ok.

To turn on/off the display of regions, select Layout followed by Show Layout Region from the Edit menu.

---

**Picture Sizing and Positioning**

Pattern Maker allows a graphics image to be imported into a pattern as an underlay or overlay picture. That is, the image is not represented using stitches. Once in the pattern, you may find it necessary to resize, move, or delete the picture.

*Please Note:*

The following steps only apply to a graphics image that has been imported into a design using the Include Image as an Underlay for Tracing option. If a graphics image was imported into a design by using the Convert the Image into Full Cross Stitches option, then the following instructions do not apply. To resize a design that was imported using the Convert option, you must re-import the image.

Follow these steps to **re-size** a picture:

1. Click the Rectangular Selection tool of the Drawing toolbar.
2. Click near one of the edges of the picture. This will cause eight handles to appear around the picture.
3. Position the mouse pointer over one of the handles.
4. Click and hold down the left mouse button.
5. Move the mouse to drag the border of the image. A dotted box will indicate the new size.
6. Release the mouse button when the dotted box represents the desired new size.

To more precisely re-size a picture after selecting it (step 2 above):

- Press and hold the shift key, and then press one of the arrow keys. This will change the size of the picture by one stitch size. *Or,*
- Press and hold the shift key and the ctrl key, and then press one of the arrow keys. This will change the size of the picture by a fraction of a stitch size.

Follow these steps to **move** a picture:

1. Click the Rectangular Selection tool of the Drawing toolbar.
2. Click near one of the edges of the picture. This will cause eight handles to appear around the picture.
3. Position the mouse pointer within the image and then click and hold down the left mouse button.
4. Move the mouse to drag an outline of the image.
5. Release the mouse button when the dotted box represents the desired new location.

To more precisely move a picture after selecting it (step 2 above):

- Press one of the arrow keys. This will change the position of the picture by one stitch position. *Or,*
- Press and hold the ctrl key, and then press one of the arrow keys. This will change the position of the picture by a fraction of a stitch position.

Follow these steps to **delete** a picture:
1. Click the **Rectangular Selection tool** of the Drawing toolbar.
2. Click near one of the edges of the picture. This will cause eight handles to appear around the picture.
3. Press the **delete** key of the keyboard. The picture will be deleted from the pattern.
The fabric selection features of Pattern Maker are used to setup the fabric so that it corresponds to the size and type required for your design. The fabric characteristics that you can control include the stitch size, color, and overall size.

The fabric settings for a pattern are edited using the Fabric Properties dialog. This dialog contains multiple pages for specifying the various fabric options.

## Sizes

The Sizes page of the Fabric Properties dialog box allows you to specify the stitch size and overall size of the fabric. To open this page, select Sizes from the Fabric menu. The Sizes page is shown below.

### Stitch Size

Enter the desired stitch size in units of stitches per inch in the two boxes labeled Horizontally and Vertically. Note that you only need to enter a size in the Horizontally box if the Square Stitch option is checked. In that case, the Vertically box will be automatically set to the same value as the Horizontally box. For cross-stitch designs, you will probably want to always keep the Square Stitch option checked.

Select Use Machine Stitch Sizes to have the finished size calculation at the bottom of the dialog based upon the actual size of a stitch as produced by an embroidery machine. Otherwise, the calculation will be made using the exact stitch size, which will not always correspond to the machine stitch size. This option is only available in the Machine Embroidery add-on.
**Fabric Size**

This dialog provides the following four ways to specify the size for the pattern:

1. By specifying the finished size of the design in inches or millimeters. For this case the number of stitches is automatically calculated based upon the stitch size.
2. By specifying the size in stitches.
3. By reducing the fabric size to fit the currently used area of the design. For this case, you can optionally specify how many extra stitches should be included on all four sides of the pattern to serve as a margin or additional design area.
4. By reducing the fabric size to only that area currently selected.

To choose one of these methods, click the button to the left of the option and then enter any additional information required for that option.

At times, the options for reducing the fabric size will not be available (i.e. grayed-out). In the case of the ‘reduce size to used area’ option, it is only available when there are stitches in the pattern. For the ‘reduce to selected area’ option, it is only available if a selection has been made.

Select **Use For New Patterns** if you want this size to be used for new patterns.

---

**Fabric Color**

The **Color** page of the **Fabric Properties** dialog allows you to choose the color of the fabric. To open this dialog, select **Color** from the **Fabric** menu. The **Color** page is shown below.

The top half of this dialog box shows the fabric colors that are available for selection. If the fabric color of the current pattern is in this list, then it will be marked with a dotted outline.

To select another color for the current pattern, simply click on the color box. When selected, the name of the color will be shown in the **Selected** box.

Select **Use For New Patterns** if you want this color to be used for new patterns.

---

**Adding/Editing/Deleting Fabric Colors**

To add a new color to the list of fabric colors, click the **New** button. This will open the **Define New Fabric Color** dialog box. This dialog box is shown below.
Enter the name of the fabric color in the **Color Name** box. Next, click **Select Color** to open the standard color selection dialog box. After selecting the color, it will be shown to the right of **Display Color**. Click **Ok** to add the new color to the list.

To make the entry of a new color as easy as possible, click on one of the existing colors that is close to the new color before you click **New**. When you do this, the **Define New Fabric Color** dialog will start with this color. You can then adjust this color to get the new color.

To **edit** an existing fabric color, click the color to select it and then click **Edit**. As a short cut, you can also double-click the color. Either method will open a dialog where you can adjust the name and/or color.

You can **delete** a color from the list by selecting the color and then clicking **Delete**.

---

**Fabric Type**

The **Type** page of the **Fabric Properties** dialog allows you to specify a description for the fabric required for the pattern. To open this dialog, select **Type** from the **Fabric** menu. This dialog is shown below.

In the **Fabric Type** box, type a description of the fabric. This description is printed as part of the pattern information.

Select **Use For New Patterns** if you want these options to be used for new patterns.

---

**Grid Options**

Pattern Maker allows you to customize the grid line style and major grid line spacing. To change these options, select **Grid Options** from the **Fabric** menu. This will open the **Grid Options** page of the **Fabric Properties** dialog, which is shown below.
Pattern Maker defines two types of grid lines; major and minor. Major grid lines are typically setup to occur every 10 minor grid lines. However, the spacing between the major lines can be specified via the Show Major Grid Line Every box.

The style of the minor and major grid lines is user selectable. Normally, the minor grid line is lighter or thinner than the major grid line. However, Pattern Maker lets you use whatever scheme you prefer.

Pattern Maker allows you to choose different grid line styles for both printing and screen display. This is often useful since the capability of the printer being used is different from that of the screen display. In other words, what looks good on the screen for editing purposes might not be the best when you print the pattern for publication. Also note that the print settings for the grid lines are used when using the exporting feature of the Professional level to create a graphics file of a chart.

To specify the thickness for a grid line, enter the thickness in the box labeled Thickness. The units for the thickness can be specified in either points, inches, centimeters, or millimeters. To select the units, click the units button.

To specify the color for a grid line, click the small triangle next to the color sample. This will show a list of common colors.

Click one of the colors to choose it, or click More Colors… to open the standard color selection dialog box.

Select Use For New Patterns if you want these options to be used for new patterns.

Other Options

Several other fabric-related options are provided. These options can be found at the bottom of the Fabric menu. These include:

- Gaps Between Stitches - Select to force space between each stitch. This is useful when you want to precisely locate the end points of adjacent stitches which have the same color. If the Grid is enabled, then this feature prevents the stitches from hiding the grid lines.
• **Show Fabric Color with Symbols** - Select to show the fabric color when the symbolic view is used. Otherwise, the fabric color is shown as white. Normally this option is not selected since it can be hard to see the symbols when darker fabric colors are used.

• **Show Picture** - Used to show/hide a picture that was pasted into a pattern. This command is useful for temporarily hiding the pasted picture when you are tracing over the picture with stitches.

• **Picture On Top** - Used when an image has been imported into a pattern as a picture (i.e. not converted into stitches). Select this option to have the image drawn on top of the grid and stitches. Unselect this option if you want to see the grid and stitches over the image. Unselecting this option allows you to trace over a pasted image to create a pattern.
This chapter describes the floss-related features of the program. These features allow you to choose floss colors for a pattern, maintain the various floss lists, choose symbols for floss colors, create re-usable palettes, plus more.

IMPORTANT NOTE:

Please note that the colors that are used to represent the various brands of floss, thread, bead, and other material are only approximations to the actual colors. It is not possible to perfectly represent the actual color on the computer screen. For solid color floss and thread, the colors included with the program are good approximations. For all other types, the colors that are shown are only rough approximations and are provided to support the use of those colors by professionals who are familiar with the actual colors and/or who have actual sample cards from the manufacturers.

Palette Basics

The palette of a design is shown in the Palette Bar which is located at the bottom of the Patten Maker window. (For more information on the Pattern Maker window layout, see “Window Layout” on page 13.) The Palette Bar can be used to perform several types of editing options on the palette such as color deletion and merging.

Some palette modifications require the use of the Palette Options Bar. This bar can be displayed as needed by double-clicking a color of the palette or by clicking the Show Palette Options button of the Palette toolbar. You can also use the Palette menu to open this bar. The options of this bar include color selection, symbol selection, symbols formatting, and more.

The remainder of this section describes how to perform the basic palette editing needed for any design. Other sections in this chapter discuss the more advanced aspects such as symbol formatting.

Adding a Color to the Palette

1. Select Colors from the Palette menu to open the Colors page of the Palette Properties Bar.
2. Find the desired color in the list of Available Colors. You can either browse thru the list or type the ID or color name in the Find box.
3. Double-click the color to add it to the palette. If you used the Find box to locate the color, then you can also press enter to add the color. That method can be used to quickly add a list of colors to the palette.

Note that you can add a particular color more than once to the palette. This allows you to select different options (i.e. strand count) for each instance of the color.

To have a particular floss/thread type shown as the default type, see “Palette” on page 179.
Deleting a Color from the Palette
1. Right-click the color in the Palette Bar that you want to delete. (If it is not visible, you may need to use the scroll bar.)
2. Select **Delete** from the menu that appears.

Deleting all Colors of the Palette
1. Right-click any color in the Palette Bar.
2. Select **Delete All** from the menu that appears.

Deleting all Unused Colors of the Palette
1. Right-click any color in the Palette Bar.
2. Select **Delete Unused** from the menu that appears.

Merging Colors of the Palette
Sometimes it is desirable to combine the usage of two colors into only a single color. For example, you may initially choose to use two shades of green in a design, but later decide that you don’t want two separate shades. To replace one of the colors with the other color, follow these steps:
1. Locate the color in the palette that you want to merge (i.e. the color that you don’t want anymore).
2. Point to that color with the mouse pointer, and then click and hold down the left mouse button. Before moving the mouse, **wait** until the mouse pointer switches to a ‘hand-shaped’ cursor.
3. Drag the selected color onto the color in the palette that you want to use to replace it.
4. Release the mouse button. This will cause the merged color to be removed from the list and all stitches using it to be replaced with the new color.

Replacing a Color of the Palette
Follow these steps to replace a palette color:
1. Select **Colors** from the **Palette** menu or double-click a color in the Palette Bar. This will open the **Colors** page of the Palette Options Bar.
2. Find the desired color in the list of **Available Colors**. If you know the color number or name, type it in the **Find** box. This will cause that color to be selected if it is present in the list.
3. Point to that color with the mouse pointer, and then click and hold down the left mouse button.
4. Drag the color onto the color in the palette that you want to replace.
5. Release the mouse button to allow the change.

Rearranging Colors of the Palette
After adding colors to the palette, you may find that you would like to group the colors so they are more organized (that is reds near the other reds, greens near other greens, etc.). Follow these steps to move a color to another location in the palette.

Method 1:
1. Click the color of the palette that you want to move.
2. Click either ← or → to move the color one position.

Method 2:

1. Press and hold the shift and ctrl buttons of the keyboard.
2. Point to the color with the mouse pointer that you want to move, and then click and hold down the left mouse button. Before moving the mouse, wait until the mouse pointer switches to a ‘hand-shaped’ cursor.
3. Drag the color to the position in the palette where you want it.
4. Release the mouse button. The color will then be moved to the selected palette position.
5. Release the shift and ctrl buttons or continue pressing them if you want to move other colors.

Palette Options

The Palette Options Bar is used to edit the palette of a design. This dialog contains several pages. Each page contains different options relating to the palette.

This bar can be opened by double-clicking a color box of the Palette Bar or by clicking the Show Palette Options button of the Palette toolbar. To close this bar, click the close button in the upper-right corner. This bar can be left open while drawing. To adjust the height of this bar, click and drag the window divider that is located at the top of the bar.

Once the Palette Options Bar is open, you can then click on a color in the Palette Bar to have its properties displayed. Often it is useful to display and/or change the properties for more than one color. To select multiple colors in the Palette Bar, use one of these methods:

- Press the Ctrl key while clicking a palette color to add it to the group of selected colors. If the color is already selected, then it will be removed from the group.
- Press the Shift key while clicking a palette color to add a range of colors to the selection.

When multiple colors are selected, one of the colors is the primary selection. The primary selection is made by clicking a color while no key is being pressed. The primary selection is used when drawing. All other selected colors are secondary selections. Both the primary selection and the secondary selections are used when editing the palette properties. The following shows the appearance of the Palette Bar when more than one color is selected.

In this example the dark green color is the primary selection. If a stitch were drawn, that color would be used. The red and pink colors are the secondary selections. If a palette property were modified, all of the selected colors would be affected, including the primary and secondary selections.

When multiple colors are selected, it is possible that some palette property settings will be different among those colors. In that case, the corresponding option on the palette property dialog will indicate an indeterminate setting. For example, if the property is selected by a drop-down list, then the current selection of that list will be blank. To force all of the selected colors to have the same setting, simply choose one of the options in the list. If no selection is made in that case, then that property will not be changed for those colors. This makes it possible to change certain properties that you want to be the same for the selected colors, but still allow other properties to be different for those colors.

The following sections discuss each page of the Palette Options Bar.

Colors

The Colors page of the Palette Options Bar allows you to select the colors for the palette of the current design. To open this page, choose Colors from the Palette menu, or double-click any color box of the Palette Bar. This page is shown below.
The drop-down list labeled **Type** is used to select the type (i.e. brand) of floss/thread that is displayed in the **Available Colors** list.

When there are more colors than can be displayed at one time, the scroll bars on the right can be used to scroll the list of colors. Another way to display more colors is to grab the window divider at the top of the **Palette Options Bar** and drag it to make the bar taller.

To display the colors in the list using larger boxes, right-click one of the colors and then select **Large Color Swatches** from the menu that appears. Selecting that option again will change the size back to the default size.

To see the color ID and description for a color in the list, place the mouse pointer over the color. That information will be temporarily displayed near the color.

To locate a particular color in the list, type its ID or color name in the **Find** box. By default the Find box will try to find an exact match with a color in the list. To allow the Find box to locate partial matches, right-click on the Find box and select **Find Using Exact Match** from the menu that appears to toggle-off that option.

**Defining New Floss Colors**

Pattern Maker allows you to add, delete, or revise the colors shown in the **Available Colors** list. To add a new color to the list, click **New**. This will open the **Define New Floss Color** dialog box as shown below.

![Define New Floss Color dialog box](image)

Enter the name and number of the floss color in the **Name** and **Number** boxes. Next, click **Select Color** to open the standard color selection dialog box. After selecting the color, it will be shown to the right of **Display Color**. Click **OK** to add the new color to the list.

To make the entry of a new color as easy as possible, click on one of the existing colors that is close to the new color before clicking **New**. When you do this, the **Define New Floss Color** dialog will start with this color. You can then adjust this color to get the new color.

To edit one of the existing floss colors shown in the **Available Colors** list, right-click the color and then select **Edit** from the menu that appears. This will open a dialog where you can adjust the name and/or color.
You can delete a color from the Available Colors list by right-clicking the color and then selecting Delete from the menu that appears.

**Defining Blends of Floss**

The Colors page also allows you to create and select blends of floss. A special floss type is used to collect the blends that you create. To view the current list of blends, select Blends in the Type list of the Colors page. To add a new blend to the list, click New. This will open the Define New Blended Color dialog box as shown below.

![Define New Blended Color](image)

You can select up to 4 existing floss colors for each blend. For each color select the floss type, the number/identifier, and the number of strands. Next, define the color that will be used to represent the blend by clicking Select Color. Note that the display color of the blend defaults to the average color of the selected floss colors. Click Ok to add the new color to the list.

To use a blended color in a design, select it into the palette just as you would for a non-blended color.

**Defining New Bead Colors**

The Colors page also allows you to create and select bead colors. To view bead colors, select one of the bead types. To add a new bead color to one of the bead types, click New. This will open the Define New Bead dialog box as shown below.

![Define New Bead](image)

Enter the name and number of the floss color in the Name and Number boxes. Next, click Select Color to open the standard color selection dialog box. After selecting the color, it will be shown to the right of Display Color. Specify the size of the bead in the Diameter and Length boxes. Click Ok to add the new color to the list.
To make the entry of a new color as easy as possible, click on one of the existing colors that is close to the new color before clicking **New**. When you do this, the **Define New Bead** dialog will start with this color. You can then adjust this color to get the new color.

**Undoing Changes to a Floss/Thread List**

The various floss/thread lists provided with the program can be edited by the user as described in the preceding sections. The changes can range from editing the description, editing the color value, deleting a color, adding new colors, or re-arranging the order of the colors in the list. In some cases it may be desirable to undo a change that has been made.

Follow these steps to undo a change that has been made to one of the floss/thread lists:

1. Close all patterns that are currently open.
2. Double-click one of the empty color boxes of the Palette Bar to open the **Colors** page of the **Palette Options Bar**.
3. Select the brand of floss/thread that you want to revise.
4. Right-click within the box where the available colors are shown.
5. In the menu that appears, select **Show Changes**. This will cause the **Palette Changes** dialog box to appear as shown below.

![Palette Changes dialog](image)

6. Click on an item in the list to select it.
7. Click **Undo Selected Changes** to undo that change.
8. Click **Ok** when you are finished undoing changes.

If you want to undo all changes that have been made, click **Undo All Changes**. To undo changes that have been made to the sorting order, click **Undo Sorting Changes**.

Please note that this feature only shows changes as compared to the original floss/thread list provided with the program. It does not keep a history of changes made to previous changes.

**Strands**

The **Strands** page of the **Palette Options Bar** allows you to specify the number of floss strands to be used for each color and stitch type of the design. To open this page, select **Strands** from the **Palette** menu. Or, right-click a color in the palette, and then select **Strands** from the menu that appears. This page is shown below.
Palette Features

To specify the strand count for a particular color in the palette:

1. Click the desired color in the palette list. (You can also select multiple colors at a time. For details, see "Palette Options" on page 81.)

2. Choose the desired strand count for each stitch type by selecting a count from the drop-down lists. Use Default if you want to use the default strand count of the design. The actual default value can be specified using the Stitch Options dialog. To open that dialogs, select Stitch Options from the Stitch menu. The Actual Thickness page of that dialog is used to specify the defaults. For more details, see “Actual Thickness” on page 53.

To use a different strand count for the same color, simply add that color to the palette again. You can then specify the options for that additional use independently of the original use of that color.

Symbols

The Symbols page of the Palette Options Bar allows you to choose the symbols that are used to represent the floss colors when the symbolic view is used. To open this dialog, choose Symbols followed by Full, Half, Quarter & Petite from the Palette menu. You can also right-click a color of the palette and select the same option from the menu that appears. This page is shown below.

You can choose symbols from any of the fonts installed on your computer. To select a font, choose it from the Font drop-down list. For best results, only use TrueType fonts since they can be scaled to any selected size with a high-quality result.

The Font drop-down list shows the fonts that are currently used in the design at the top of the list before the horizontal line. It also shows the default font that has been selected whether it is used for the current design or not. It is denoted by (def) shown before the name. The default font is used for new designs. To select a new default font, select the font from the list, and then click the Make Default button.

To see more or less symbols, click the + or – buttons, or click and drag the window divider at the top of Palette Options bar to change the height of the bar.

When a symbol has been selected for a color in the palette, the symbol will appear blue. Otherwise symbols are shown in black.

There are four ways to assign a symbol to a color. These are:

- Click and drag a symbol from the Available Symbols list down onto a color in the palette.
• Select a symbol in the **Available Symbols** list, select a color in the palette, and then click the **Use** button.

• Select a color in the palette and then double-click the symbol in the **Available Symbols** list that you want to use.

• Click **Auto Selection** to have the program automatically select the symbols. See below for more details on this feature.

To de-assign a symbol from a color, select the color in the palette, and then click **Unuse**.

To remove all symbol selections, click **Clear All**. This is useful in removing the default symbol selections when setting-up the symbol selections for the first time.

Pattern Maker allows the symbol selections for the palette to be different for each stitch type. For example, you could choose one symbol for the full stitches of a particular color while using another symbol for the half stitches of that same color.

To see the symbol selections for other stitch types, choose the stitch type via the **Show Symbols For** drop-down list in the lower right corner. For stitch types other than **Full Stitches**, when no symbol is chosen, the symbol used for full stitches will be used.

**Auto Selection** can be used to quickly assign a symbol to each color. In general, one common method used to choose symbols involves matching the 'weight' of a symbol to the lightness/darkness of a color. Pattern Maker uses this same approach.

In some cases it may be necessary for you to manually select some symbols after using the Auto Selection feature or when using the default symbols that are selected for a design. These cases include:

• When the symbolic view is setup to show half stitches using a large symbol. In this case, it is impossible to tell which symbols represent full stitches and which represent half stitches unless a different symbol is selected for half stitches.

• When petite and quarter stitches are used for the same color. In this case, it is impossible to tell which symbols represent petite stitches and which represent quarter stitches unless a different symbol is selected for one of them.

When setting-up the palette for the first time, click the **Quick Entry** box. When this box is selected, the selected color in the palette will be automatically moved to the next color in the list after you make a symbol selection. This allows you to select the first color in the list, double-click the desired symbol, and then continue double-clicking symbols to assign a symbol to each subsequent color.

### Symbol Format

The **Symbol Format** page of the **Palette Options Bar** allows you to choose the formatting of each symbol. To open this page, choose **Symbol Format** from the **Palette** menu. You can also right-click a color of the palette and select the same option from the menu that appears. This page is shown below.

---

**Palette Options**

<table>
<thead>
<tr>
<th>Palette Options</th>
<th>Colors</th>
<th>Strands</th>
<th>Symbols</th>
<th>Symbol Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Foreground</td>
<td>Black</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Background</td>
<td>Use actual floss color</td>
<td>Select</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Allow color behind symbols</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
</tbody>
</table>

| Sizes           | Full, half, French, bead: 100 % | Quarter, petite, half: 50 % |
| Style           | Bold | Italic |

---

To choose the formatting for the symbol of a particular palette color, first click the color in the palette to select it. You can also select multiple colors at a time. For details, see “Palette Options” on page 81.

The following options are available for the formatting of a symbol:
• **Foreground color** – the color used for the symbol
• **Background color** – the color shown behind the symbol. This option is available when the Allow Color Behind Symbol feature is used. The background color can either be the actual floss color or an alternative you select. To select an alternative, click **Select**.
• **Sizes** – the size of the symbol relative to the default size used by the program. This allows you to tweak the symbol size to fill more/less of the stitch position.
• **Style** – the character style of the symbol. **Bold** and **Italics** are available.

**Back Stitch Symbols**

The Back Stitch Symbols page of the Palette Options Bar allows you to choose the formatting of the back stitch symbols. These options are used by the program when displaying a pattern in the symbolic view. To open this dialog, choose **Symbols** followed by **Back Stitch** from the Palette menu. You can also right-click a color of the palette and select the same option from the menu that appears. This page is shown below.

To choose the formatting for back stitch symbols of a particular palette color, first click the color in the palette to select it. (You can also select multiple colors at a time. For details, see “Palette Options” on page 81.) Next, choose the desired options:

- **Style** – the line style used for the stitch
- **Thickness** – the thickness of the stitch as measured in points (i.e. 1 point = 1/72 of an inch)
- **Color** – the color used for the stitch. The actual floss color or a user-selected alternative can be used. Click **Select** to choose an alternative.

The **Include stitch endpoints** option is used to select the starting and stopping points of the line as shown below.

![Example of Include stitch endpoints](image)

The Include stitch endpoints option is **OFF** for the left example and **ON** in the right example.

**Straight Stitch Symbols**

The Straight Stitch Symbols page of the Palette Options Bar allows you to choose the formatting of the straight stitch symbols. These options are used by the program when displaying a pattern in the symbolic view. To open this dialog, choose **Symbols** followed by **Straight Stitch** from the Palette menu. You can also right-click a color of the palette and select the same option from the menu that appears. This page is shown below.
Palette Features

To choose the formatting for straight stitch symbols of a particular palette color, first click the color in the palette to select it. (You can also select multiple colors at a time. For details, see “Palette Options” on page 81.) Next, choose the desired options:

- **Style** – the line style used for the stitch
- **Thickness** – the thickness of the stitch as measured in points (i.e. 1 point = 1/72 of an inch)
- **Color** – the color used for the stitch. The actual floss color or a user-selected alternative can be used. Click **Select** to choose an alternative.

Please refer to the topic “Back Stitch Symbols” on page 87 for information on the Include stitch endpoints option.

**French Knot Symbols**

The French Knot Symbols page of the Palette Options Bar allows you to choose the formatting of the French Knot symbols. These options are used by the program when displaying a pattern in the symbolic view. To open this dialog, choose **Symbols** followed by French Knot from the Palette menu. You can also right-click a color of the palette and select the same option from the menu that appears. This page is shown below.

To choose the formatting for French Knot symbols of a particular palette color, first click the color in the palette to select it. (You can also select multiple colors at a time. For details, see “Palette Options” on page 81.) Next, choose the desired options:

- **Style** – either a dot or a symbol font character can be used to represent a French Knot. If the Font Character style is chosen, then the symbol selected via the Symbols page of the Palette Options Bar is used to represent the stitch.
- **Diameter** – the diameter of the dot used to represent the French Knot (when the Dot style is selected) as measured in points (i.e. 1 point = 1/72 of an inch)
- **Color** – the color of the dot used to represent a French Knot (when the Dot style is selected). The actual floss color or a user-selected alternative can be used. Click **Select** to choose an alternative.

**Specialty Stitch Symbols**

The Specialty Stitch Symbols page of the Palette Options Bar allows you to choose the formatting of the specialty stitch symbols. These options are used by the program when displaying a pattern in the symbolic view. To open this dialog, choose **Symbols** followed by Specialty Stitch from the Palette menu.
Palette Features

You can also right-click a color of the palette and select the same option from the menu that appears. This page is shown below.

To choose the formatting for specialty stitch symbols of a particular palette color, first click the color in the palette to select it. (You can also select multiple colors at a time. For details, see “Palette Options” on page 81.) Next, choose the desired options:

- **Thickness** – the thickness of the stitch as measured in points (i.e. 1 point = 1/72 of an inch)
- **Color** – the color used for the stitch. The actual floss color can be used or a user-selected alternative can be used. Click **Select** to choose an alternative.

**Bead Symbols**

The **Bead Symbols** page of the **Palette Options Bar** allows you to choose the formatting of the bead symbols. These options are used by the program when displaying a pattern in the symbolic view. To open this dialog, choose **Symbols** followed by **Bead** from the **Palette** menu. You can also right-click a color of the palette and select the same option from the menu that appears. This page is shown below.

To choose the formatting for bead symbols of a particular palette color, first click the color in the palette to select it. (You can also select multiple colors at a time. For details, see “Palette Options” on page 81.) Next, choose the desired options:

- **Style** – either a dot or a symbol font character can be used to represent a bead. If the **Font Character** style is chosen, then the symbol selected via the **Symbols** page of the Palette Options Bar is used to represent the stitch.
- **Diameter** – the diameter of the dot used to represent the bead (when the **Dot** style is selected) as measured in points (i.e. 1 point = 1/72 of an inch)
- **Color** – the color of the dot used to represent a bead (when the **Dot** style is selected). The actual floss color or a user-selected alternative can be used. Click **Select** to choose an alternative.

**Notes**

The **Notes** page of the **Palette Options Bar** allows you to specify information for each stitch type of each color used in the design. This information is printed as part of the pattern information and can also be used in a custom layout. These notes can be helpful in providing color-specific instructions to the user of the pattern. To open this dialog, choose **Notes** from the **Palette** menu. Or, right-click a color in the palette, and then select **Notes** from the menu that appears. This page is shown below.
To specify the notes for a particular palette color:

1. Click the desired color in the palette to select it.
2. Select the type of stitch for which you want to specify a note.
3. Type the note for that stitch type.
4. Repeat for other colors and/or other stitch types.

**Convert**

The **Convert** page of the **Palette Options Bar** allows you to convert one or more palette entries to another floss type. To open this dialog, choose **Convert Colors** from the **Palette** menu. Or, right-click a color in the palette, and then select **Convert Colors** from the menu that appears. This page is shown below.

In the drop-down list labeled **Convert to**, select the type/brand to which you want to convert.

Select the conversion method(s) from the options in the **Cross Referencing Method** box. The program can use cross-referencing tables or color matching to determine which colors correspond between types.

Click **Convert All** to convert all colors in the palette or click **Convert Selected** to only convert the currently selected palette color(s).

To edit the cross-referencing tables, click **Edit Tables**. The following dialog box will be opened.
Use the From drop-down list to select the brand that this table converts from. Select the To drop-down list to select the brand that this table converts to.

The left column lists the colors of the type selected in the From list. Normally you would not change this column.

The right column lists the equivalent color of the type selected in the To list. Simply click on a row to select it, and then click again in the cell of that row that you want to modify. The cursor will then appear to allow you to specify the color ID.

Click Ok to save your changes.

---

**Symbol Options**

The Symbol Options dialog box allows you to choose overall formatting options for the symbolic viewing mode.

To open the Symbol Options dialog box, choose Symbol Options from the Palette menu. This dialog box is shown below.

The Symbol Spacing Within Grid box allows you to choose the minimum space that should be provided between the stitch symbol and the grid lines. These spacings can be specified for both the screen display and the printout.
The box labeled **Sizing** allows you to select the sizing for all symbols in the palette. The sizing is relative to the default used by the program for full stitches. To set the symbol sizing, first specify the values for the stitch categories shown. Next, click **Update Palette Settings** to force all palette entries to use these settings.

The box labeled **Misc** contains various options that can be selected. These are:

- **Use Large Half Stitch Symbol** - select to use large symbols for half stitches. Otherwise the quarter stitch symbol size is used with a symbol in two corners of the grid position.

- **Use Triangles Behind Quarter Stitches** – select to enable the display of triangles behind quarter stitch symbols (instead of squares) when the **Show Floss Color Behind Symbols** option is selected.

- **Show Floss Color Behind Symbols** - select to display the floss color or an alternative color behind the symbol. Otherwise, white is shown behind the symbol.

- **Draw Symbols Over Back Stitches** – select to have symbols drawn over back, straight, and specialty stitch symbols. This option is not available when the **Show Floss Colors Behind Symbols** option is used.

The box labeled **Scale Symbol Font Using** allows you to choose how the font size is selected. Either or both of the following options can be specified:

- **Font Height** - a font size is chosen such that the tallest character always fits in the grid square

- **Maximum Font Width** - a font size is chosen such that the widest character always fits in the grid square

Select **Use For New Patterns** if you want these options to be used for new patterns.

---

**Usage Summary**

The floss usage summary feature reports how many of each stitch type for each color is used in a pattern. The program also calculates an estimate of the total number of floss skeins needed for the design.

To display the usage summary, select **Usage Summary** from the **Palette** menu or click the Usage Report button of the Palette toolbar. This will open the **Floss Usage Summary** dialog. This dialog is shown below.
As shown, the total number of each stitch type, for each floss color, is listed in a table. For certain types (back, straight, and specialty stitches) the total length of each color is shown.

To sort the list based upon the information in one of the columns, click on the column heading. For example, to sort by the number of full stitches, click the heading labeled ‘Full’. Clicking that heading again will cause the sort order to be reversed.

To see the floss description of the colors, use the scroll bar at the bottom to scroll the information. The size of this dialog box can also be enlarged/reduced by clicking and dragging one of the sides/corners of the dialog box.

To locate where a particular color is used in the design, first click on the color as shown in the usage summary list. Next, click the **Show Use in Design** button. The selected color will then become the selected color of the Palette Bar. In addition, for the Professional level, the stitch-highlighting feature will be enabled for that color. After closing the usage summary dialog box, you can disable the highlighting feature by clicking the **Highlight Color** button of the Palette toolbar.

The strand estimate shown is based upon information that you provide. This information can be edited by clicking **Skein Information**. This will open the Skein Usage Information dialog as shown below.

In the box labeled **Skein Definition** are fields that allow you to specify the length and number of strands in one skein. The floss estimates that are calculated by the program indicate how many of these skeins are required.

The box labeled **Floss Used Per Stitch Type** allows you to calibrate the floss usage calculation. In these boxes you specify the number of stitches that can be obtained from one inch of floss. You can specify this quantity for each stitch type and for up to four different fabric counts. To specify these numbers for a fabric count that is not listed, please select one of the columns and specify new numbers for each stitch type and for the fabric count shown at the top of the column.

The **Calculation Options** box in the upper right corner allows you to specify whether to adjust the calculated floss estimate by a specified percentage. This box also allows you to control whether the estimated floss usage is shown with fractional numbers of skeins or only using integer numbers of skeins by rounding up.

*The floss estimate provided by the Usage Summary is ONLY an estimate. You should verify these suggested floss amounts if you are creating a kit.*

Select **Use For New Patterns** if you want these options to be used for new patterns.
Saving and Opening Palettes

Pattern Maker allows you to create several palettes for a particular pattern. These alternate palettes let you vary the color scheme for a basic design. Sometimes this is useful when you are trying to choose the best set of colors for a design.

Each pattern stores one floss palette. Any additional palettes that you want to create for a pattern must be stored in a special file called a palette file. To save the current palette of a pattern to a palette file, select **Save Palette As** from the Palette menu. This will open a standard **File Save As** dialog box where you can name the file and specify the folder where you want the file to be saved.

To replace the current palette of a design with an existing palette file, select **Open Palette** from the Palette menu. This will open a standard **File Open** dialog where you can select the file.

Since the current palette of a pattern is replaced whenever you open a palette file, you should save each palette that is to be associated with a particular design into a separate palette file.

*The ordering of the palette colors should not be changed if you want to keep multiple palette files for a design. Also, do not delete or merge any colors of any of the palettes.*

Stitch Highlighting

The Stitch Highlighting feature can be used to help in locating all stitches of a particular color. When this feature is used, the selected palette color is displayed using an alternative color while the non-selected palette colors are faded into the background to make them less visible.

This feature is only available in the **Professional** level.

To enable this feature, click the **Highlight Color** button of the Palette toolbar, or select **Highlight Selected Color** from the Palette menu. This option is also available in the menu that appears when you right-click one of the colors in the palette.

Several options are available to fine-tune this feature. Select **Highlighting Options** from the Palette menu to see these options.

In the box labeled **Selected Color**, specify the color that will be used for the stitches of the currently selected palette color. The options are:

- **Use Actual Color** - display the stitches using the actual palette color.
- **Use Specified Color for Highlighting** - display the stitches using the selected color.

In the box labeled **Non-Selected Colors**, specify whether the non-selected colors of the palette should be faded into the fabric color. The **Fade Amount** slider can be used to vary the amount of fading. A value of **None** will display the stitches in the normal manner.
Importing Color Definitions

Version 4 of Pattern Maker stores the color definitions for each floss/thread type using a different method than used for previous versions. If you have floss/thread files from an earlier version that you would like to import into version 4, then select **Import Color Definitions** from the **Palette** menu for each file. The color definitions for each file will then override those definitions provided with the program.

The file names for the floss/thread files used for earlier versions have ‘thread’ as the main part of the name. For example, the file for DMC is ‘threads.dmc’.
Printing Features

Pattern Maker provides complete printing support for all viewing modes. The features described in this chapter describe how to print the design chart and corresponding information.

Printing a Pattern

To print your pattern, click the Print button of the Main toolbar, or choose Print from the File menu. The Print dialog box will then be shown.

The Print dialog is the standard Windows dialog box for specifying basic printing options. This dialog is shown below.

![Print Setup Dialogue Box]

Most of the time, you will probably just accept the default options by simply clicking the Ok button. However, sometimes you may want to only print certain pages of a pattern. In that case, you can enter the desired page numbers in the From and To boxes.

This dialog also gives you the option of adjusting the setup of the currently selected printer. To change the setup, click the Properties button.

Print Preview

Pattern Maker provides a print preview feature that can be used to preview the page layout of your pattern. This feature lets you see how the pattern will be positioned on the page and how the pattern will be broken into multiple pages when the pattern is too large to fit on only one page. In general, it is a good idea to preview a printout since it can save time and paper.

To preview a printout, select Print Preview from the File menu. This will cause the main window to display the print preview. During print preview, the Menu Bar and Toolbar area of the Pattern Maker...
window are replaced with buttons that are specific to print preview. An example of the print preview window is shown below.

To make the preview show the next or previous pages of the printout, click **Next Page** or **Prev Page**.

To have two pages displayed at one time, click **Two Page**. To change back to displaying only one page, click **One Page**.

If you want to make the page view zoom-in on a portion of a page, simply click the mouse where you want to see more detail. You can zoom-in several times. After the maximum zoom-in setting is reached, clicking the mouse again will return the view to the full-page view.

When you are finished previewing and you want to print the pattern, click **Print**. If you do not want to print it, then click **Close**.

## Page Setup

The **Page Setup** dialog box provides several pages of options that you can select to customize the printout. To open the **Page Setup** dialog box, select **Page Setup** from the **File** menu. (Please note that the Page Setup dialog box is different when the Layout view of the **Professional** level is selected.)

The following sections describe each page of this dialog box.

### Chart Sizing

The **Size** page of the Page Setup dialog box provides options for specifying the printed size of the chart. This page is shown below.
The chart sizing options are:

- **Same as Display Size** - select to have the chart size match the screen display size of the chart. For example, if your design is setup for 10 stitches per inch, and you have selected the 100% zoom factor, then the chart will printout at 10 stitches per inch. If you had selected a 200% zoom factor in this case, then the printout size would be 5 stitches per inch.

- **Fit to One Page** – select to have the chart sized to fit on one page.

- **Span Printing Over Specified Number of Pages** - select to use the number of pages for the chart as specified by the Pages Across and Pages Down boxes. For example, if you wanted the chart to be printed over 3 pages for the width and 3 pages for the height, then you would specify 3 in each of the boxes.

- **Size Using Specified Stitch Size** – select to use a specified size for the stitches of the printout. Enter the size in the box labeled Stitches Per Inch.

To have the chart centered on the page or pages used for the chart, select the **Center Chart on Page(s)** option.

### Page Content

The **Content** page of the Page Setup dialog box provides options for specifying the contents of the printout. This page is shown below.

The following options are available:

- **Print Chart** - select to have the chart of the design printed. The following options are available for the chart print-out:
- **Show Page Overlaps** – select to have 3 rows and columns repeated from the previous page. The repeated rows/columns are shaded to indicate that they are repeated. This feature enhances the printout by making it easier to follow the chart when transitioning between pages.

- **Fabric Printing** – select to have a space shown between each stitch and to have grid lines disabled. This makes it easier to locate the exact endpoints of adjacent stitches.

- **Show Centering Marks on All Center Rows/Cols** – select to have the centering marks shown on all chart pages containing the center row and/or center column. Otherwise, only the pages showing the ‘outside’ edges of the chart show the centering marks.

- **Show Grid Numbers** – select to have grid numbers printed along the edges of the chart

- **Print Information** - select to have the design information printed including the floss/thread list, general pattern information, and floss usage summary. The following options are available for the information printout.
  - **Show Floss Colors** - select to enable the program to print a sample of each color in the floss list. These samples are shown to the left of each entry of the floss list and thread usage summary.
  - **Show Floss Usage** - select to print the floss usage summary.
  - **Sort Floss List** - select to sort the floss list by type and number. When unselected, the floss list is ordered based upon the user-selected order of the colors in the palette.

### Page Header & Footer

The **Header & Footer** page of the Page Setup dialog box provides options for specifying the header & footer of the printout. This page is shown below.

The header and footer are printed on each page of the printout. Specify the text and special formatting options in the **Header** and **Footer** boxes.

The following special formatting options are available. To use one, specify it as part of the header/footer.

- **&t** – insert the pattern name as specified in the Pattern Information
- **&n** – insert the designer’s name as specified in the Pattern Information
- **&l** – insert the company name as specified in the Pattern Information
- **&2** – insert the copyright as specified in the Pattern Information
- **&d** – insert the current date and time
- **&l** – left align the text that follows
• &c – center the text that follows
• &r – right-align the text that follows

(For more information on specifying the Pattern Information, see “Specifying Summary Information” on page 20.)

The **Page Number** options include:

• **Show Page Numbers** – select to have a page number shown in the upper left corner or each page.

• **Show Adjacent Page Numbers** - select to have the other corners of each page show the page number of the adjacent page. This feature is useful when your pattern spans multiple pages. The adjacent page numbers can help you to piece the pages together. This option is only available if **Show Page Numbers** is checked.

**Page Margins**

The **Margins** page of the Page Setup dialog box provides options for specifying the margins of the printout. This page is shown below.

Specify the margins for all pages of the printout. Note that the **Top** and **Header** margins are both measured from the top of the page. If the **Top** margin is less than the bottom of the **Header**, then the **Top** margin is automatically increased to prevent an overlap. The same applies to the **Footer** and **Bottom** margins.

**Print Setup Dialog**

The **Print Setup** dialog box allows you to choose and/or configure the printer that is to be used for printouts. To open this dialog box, select **Print Setup** from the **File** menu. This dialog box is shown below.
Use this dialog to select the printer, paper setup, and print properties.

Depending upon the version of Windows that you are using, this dialog may appear differently.
Image Importing Features

Pattern Maker allows you to start a new design by importing a graphics image. Once imported into a pattern, you can then edit the pattern as desired to clean up and enhance the design.

You can import graphics images into the program either by directly specifying an existing graphics file, by pasting the image into Pattern Maker via the Windows® Clipboard, or by using the scanner interface.

Overview

The importing feature of Pattern Maker can be used to convert a graphics image into a cross-stitch design. The source of the graphics image can be:

- The scanner.
- An existing graphics file stored on your computer in one of the following formats: BMP, JPEG, TIFF, GIF, PCX, WMF, EMF, EPS (raster only), TGA, PNG, plus more.
- The Windows clipboard.

When converting a graphics file into a design, the program uses **full cross stitches** to represent the design. No other stitch types are used. The program automatically selects the floss/thread colors based upon the colors in the image.

Importing an image into a cross-stitch design is not an exact science. The quality of the result depends upon:

- **The detail in the image.** A large amount of detail in the image requires a large number of stitches. Keep in mind that typical scans of photographs are in the hundreds of DPI (dots per inch) where cross stitch provides effectively 10 to 22 DPI. It is simply impossible to maintain minute detail unless an enormous design is created.

- **The color in the image.** Some colors convert to floss better than others. In general, the palette of floss/thread colors is very limited as compared to the range of colors available in an image/photograph. In addition, the floss colors stored in the program are approximations to the actual colors.

- **The subject of the image.** Images containing people are often the hardest to import since the eye is able to spot subtle irregularities in facial tone and detail. Inanimate objects and animals are usually less difficult.

- **The amount of refinement.** The best results are obtained when the user experiments with the importing settings. You should try different settings for the number of stitches and/or stitch size to determine which settings provide the optimum detail. You should try different color settings to arrive at the optimum palette of colors. The Interactive Importing method (described below) is designed to help you quickly arrive at the most optimum settings.

- **The expectation of the user.** It must be understood that when converting to cross-stitch, the result is no longer a photograph. Instead, a completely different medium is used to represent
the image/photograph. In many cases, a stitched cross-stitch design will appear more pleasing when viewed from a distance since the colors tend to blend to the eye.

Two methods are provided for importing. These include the **Importing Wizard** and **Interactive Image Importing**. While both provide the same basic options, each provides a slightly different way of presenting the options.

The **Importing Wizard** method is good for those wanting the program to lead them thru a step-by-step procedure. This is helpful when first learning the program. The Importing Wizard is used for the importing example in the chapter “Creating a Design” on page 23. Please see that chapter for a step-by-step example.

The **Interactive Image Importing** method makes available all importing settings at one time. The user can modify any setting in any order. When a setting is changed, the user can then immediately see the result of making that change. An automatic feature can be enabled so that the imported design is automatically updated after a setting is changed.

The following sections discuss the Interactive Image Importing method.

---

### Interactive Image Importing

This section describes how to use the Interactive Image Importing (i.e. Interactive Importing) method of Pattern Maker.

The default importing method for the program is the **Importing Wizard**. To enable the interactive method, select **Use Interactive Importing** from the **File** menu (if not already selected).

To begin an Interactive Importing session, select **Import Image** and then **Import Into New Pattern** from the **File** menu, or click the Import Image toolbar button .

An Interactive Importing window will then appear as shown below.

![Interactive Image Importing window](image)

The **options pane** on the left side of the screen shows the importing options that are available. After an image has been selected or scanned, additional pages of options are available as shown below.
Interactive Image Importing

Each page can be accessed by clicking the corresponding tab.

The image pane in the middle of the window is used to display the image that you have selected for importing. You can zoom-in/out the image to see it better by left-clicking or right-clicking the mouse on it.

The pattern pane on the right side of the screen is used for showing the pattern that has been created by importing. It is updated when the Import button is clicked, or any time a change is made to the importing settings when the Auto option is selected.

The window divider between the image pane and pattern pane can be adjusted as desired to see more or less of one pane. Click and drag the divider to adjust the sizing.

While using the importing feature, it is recommend that you maximize the size of the Pattern Maker window so you can see as much of the image and imported pattern as possible. To maximize the screen, click the Maximum button which is located in the upper right corner of the main Pattern Maker window.

When you are finished importing, click Close to exit the Interactive Importing window. A normal design window will then be shown for the imported design.

The following sections discuss each options page of the Interactive Importing window.

Image Source

The Image page allows you to select the image to be imported. The following options are available:

- **Use an Existing Image** – allows you to select an existing image already on your computer. Click Browse to select a file.

- **Scan a Photo** – allows you to use the TWAIN feature of your scanner to directly scan a photograph. Click this option, and then the Scan button to open the scanner software of your scanner. After performing the scan, the scanner software will return back to Pattern Maker with the scanned image.

- **Use the Image on the Clipboard** – allows you to select an image that was copied to the clipboard from another program. Click this option, and then the Paste button to paste the image from the clipboard.

For all cases, the selected image will be shown in the image pane.

When scanning a photo for importing, a resolution that is approximately 10-15 times the desired stitch count is usually sufficient. For example, scan using 100 dpi when importing to create a 10-count design. This saves disk space and processing time while providing good conversion quality.

When using the Use the Image on the Clipboard option, the following dialog box may appear when there are multiple graphics formats on the clipboard.
Select the desired format of the clipboard image. In most cases the higher option in the list is the best to select.

**Importing Method**

The **Method** page allows you to select the method used to import the selected image. This page is shown below.

The program supports two methods for importing an image:

- **Convert the image into full cross stitches** - This option creates a pattern by translating the colors of the image into stitches in the pattern. Only full stitches are used.

- **Include image as an underlay for tracing** - This option includes the image in the new pattern without converting it. This allows you to trace the image. This method is useful when converting a sketch into a new design.

Both options can be used for an image.

**Imported Size**

The **Size** page allows you to select the stitch size and design size for the new design created by importing. This page is shown below.
The top portion of this page allows you to specify the size of the new design. The options are:

- **Size Specified in** inches/millimeters – use this option to specify the stitched-out size of the design. The actual number of stitches needed for the design is automatically calculated using the **Stitch Size** specified below.

- **Size Specified in Stitches** – use this option to choose the number of stitches used for the design. The stitched-out size will be equal to the number of stitches multiplied by the stitch size.

- **Size Corresponding to the Selected Region** – use this option to specify the size to be that of the current selection. This option is used to have the program import into a selected area of the design.

For all of the above options, the height is automatically calculated to maintain the proportions of the imported image when the **Preserve Aspect Ratio** option is selected.

The size of the stitches for the new design is specified in the **Width** and **Height** boxes. The stitch **Height** is forced to be equal to the stitch **Width** if the **Square Stitch** option is selected.

Select **Machine Stitch Sizes** to have the finished size calculation at the bottom of the dialog based upon the actual size of a stitch as produced by an embroidery machine. Otherwise, the calculation will be made using the exact stitch size which will not always correspond to the machine stitch size. This option is only available with the **Machine Embroidery** add-on.

The **Resulting Size** information is updated whenever a change is made to the settings of this page.

Note that if the Grid Alignment feature of the **Grid** page is used, then the size in stitches will be set for you. In that case, you should not change the size setting or the grid alignment will be off.

*The selection of the size for the new pattern is very critical and must balance between the need to maintain sufficient detail in the image while minimizing the number of stitches required for the design. As a result, you will most likely want to import an image several times while varying the pattern size and/or stitch size to determine the best settings.*

In cases where you do not want to lose any detail in the image, set the pattern width and height equal to the image width and height. Depending upon the image size, this may or may not be a reasonable pattern size. You may need to decrease the stitch size in this case (i.e. use a larger value for the stitches/inch).
**Color Palette**

The **Colors** page allows you to select the color options for the new design. This page is shown below.

The color palette from which colors are to be selected can be specified using the following options:

- **Use the Colors of this Floss/Thread Type** – select this option to use colors from the floss/thread type chosen from the **Type** drop-down list. Only solid color floss/thread types are included in this list. To enable all types to be shown in this list, please see “Palette” on page 179.

- **Use the Colors in this Palette File** – select this option to only use the colors in the specified palette file. Palette files are created by saving the palette of a design to a file. This option is useful when you want to limit the color choices to a set that you prefer. For example, you may want to limit the color to only gray-scale colors when importing a black and white photo. For more information on saving palettes, see “Saving and Opening Palettes” on page 94.

- **Use only the Colors Already in the Palette** – select this option to limit the colors to only those already in use for the imported design. This option is typically used when importing into an existing design.

Select the maximum colors to be used in the box labeled **Maximum Number of Colors to Use**. You can either type the maximum number in the box or use the slider to set the maximum. The program will use no more than the specified number of colors. It may use less if there are not enough suitable colors available to be used.

The slider control is very useful when the **Auto** importing option is selected. In that case, each time you move and release the slider, the imported design is updated. This makes it very quick and easy to narrow-in on the best number of colors to use.

The **Keep All Colors Already in the Palette** option is useful when you are importing into an existing design. This option prevents the importing feature from removing unused palette colors.

Click the **Advanced** button to open the **Advanced Color Options** dialog box. This dialog box provides additional palette-related options.
The **Dithering Method** determines how color is simulated when an exact match been an image color and a floss color is not available. The options include:

- **None** – no dithering is used.
- **Floyd-Steinberg** – the least amount of dithering is used
- **Stucki** – a medium amount of dithering is used
- **Burkes** – the most dithering is used

The most noticeable effect of dithering is the ‘speckling’ of colors that occurs. In most cases that effect is a positive effect as opposed to not using any dithering. With no dithering, a design will typically have a very blotchy appearance.

Select **Auto-Select Symbols After Importing** to have symbols chosen for each palette color when the Interactive Importing window is closed.

### Image Adjustments

The **Adjustments** page allows you to change the brightness, contrast, saturation, and hue of the image. The image can also be cropped. This page is shown below.

Use the adjustment bars to change the **Brightness, Contrast, Saturation**, or **Hue**. To undo those settings, click **Reset**.

To crop the image so that only a portion of the image is imported:
1. Select the cropping tool.
2. Click and drag a selection within the image to mark the desired portion. (Be sure to make the selection on the image in the image pane and not in the imported design.)
3. Click **Crop**.

To undo the cropping, click **Undo Cropping**.

### Background Selection

The **Background** page allows you to select those parts of the image that you do not want to be imported. This page is shown below.

To mark an area of the image as the background:

1. Select the background tool.
2. Position the tool over an area of the image that is part of the background.
3. Press and release the left mouse button. The selected area and all adjacent areas of similar color will then be marked using a crosshatch pattern.
4. To mark additional areas, press and hold the **shift** key while repeating steps 2 and 3. To undo the last background selection, click **Undo Last Selection**.

To adjust the sensitivity of the background tool, use the adjustment bars of the **Tool Sensitivity** box. The more sensitive the tool is made, the more selective it is when including image colors in the background.

An example of a background selection is shown below:
Even after marking the background, it may be necessary to clean up the edges between the background areas and the foreground areas after importing. This is typical in cases where the background color and the foreground colors are very different and the transition from one to the other is not sharp. The example shows this case around the head of the dog.

**Foreground Selection**

The **Foreground** page allows you to select those parts of the image that contain important foreground content. By marking the more important areas, the program can give more priority to those areas when choosing colors. This page is shown below.

To mark a foreground area:

1. Select the Foreground tool.
2. Position the mouse over the image.
3. Click the left mouse button and hold down.
4. Move the mouse to draw a free-hand selection around the foreground area. A dashed line will be drawn around the selection.
5. To mark additional areas, press and hold the **shift** key while repeating steps 2-4. To undo the last foreground selection, click **Undo Last Selection**.

![Interactive Image Importing](image_url)
6. Use the slider control to select the percentage of the palette that should be used for the foreground area(s). For example, if 75% is selected, then 75% of the palette colors will be used to represent the colors of the foreground areas while 25% will be used for all other areas.

The following shows an area that has been marked as part of the foreground.

For this foreground marking, the program will give more priority to the colors in face of the boy and head of the dog.

**Grid Alignment**

The Grid page includes a Grid Tool to assist in aligning the grid of the new design with a grid that may be present in the image being imported. This feature is useful when it is desired to trace over an existing cross-stitch chart. This page is shown below.

For a complete example of using the Grid Tool, see “Lesson 3: Tracing an Existing Chart” on page 31.

---

**Finishing the Imported Design**

After using the Importing Wizard or Interactive Importing to import your image, you can then click **Close** on the options panel to switch to a normal editing window. This will enable all of the normal editing features so you can manually polish the design as desired. Some of the editing that you may want to do includes:

- Simplifying the palette to eliminate colors that are used only a few times. The Floss Usage summary and the Stitch Highlighting feature are handy for helping in this. Sorting the palette
by usage (right-click a palette color, select **Sort**, and then **By Usage**) is also useful. For information on how to merge palette colors, see “Merging Colors of the Palette” on page 80.

- Editing the transition between the imported areas and areas excluded using the Background marking feature.
- Removing unwanted stitches that were not excluded using the Background feature.
- Refining color selections in cases where a precise color is essential. In this case it is important to have the actual floss samples available to reference the actual colors.
- Revising the symbol selection as desired to ensure the automatically selected symbols are easy to read and follow.

It is very important that you save your imported design to a file before printing and stitching. When saved, you can then re-open the design at a later time to re-print a page that might have been lost or rendered unreadable.

If you imported the image using the **Include image as an underlay for tracing** method, and if you did not use the grid alignment feature, then you may want to resize or reposition the image within the design. For more information, see “Picture Sizing and Positioning” on page 72. That section also describes how to delete an image from a design after you are finished tracing it.
Exporting Features

The *Professional* level of Pattern Maker allows you to export your patterns for use in other documents created with other applications such as publishing and word processing programs.

Pattern Maker allows you to export designs using two methods. The first involves exporting your design into a common graphics image file and a text file. These files can then be imported into another application. Most publishing and word processing programs allow you to import these types of files.

The second method of exporting your design involves using Windows® OLE technology which provides much greater convenience when using Pattern Maker with other Windows® applications which also support OLE.

Exporting a Pattern into a Graphics File and Text File

The *Professional* level of Pattern Maker allows you to export your pattern chart into the following types of graphics images: BMP, JPEG, TIFF (RGB, CMYK, and 8-bit grayscale), GIF, PCX, WMF, EMF, and EPS (8-bit grayscale, raster only).

The pattern information of your pattern can be exported into a Rich Text Format (RTF) file. This is a generic text format that maintains formatting information and is supported by most of the major word processing programs. After importing this file into your word processor or publishing program, you can then edit and reformat the information as necessary to fit your needs.

To begin the exporting process, select Export to Graphics File from the File menu. This will open the Export Pattern Wizard which will guide you through the exporting process. Please see the next section for details on how to use this wizard.

Export Pattern Wizard

The Export Pattern Wizard provides a step-by-step process for exporting a pattern. The following sections describe each step of the wizard.

**Select Output Format(s)**

The first step in exporting a pattern involves selecting whether you want the chart and/or the pattern information exported. This step of the wizard is shown below.
If Export the Chart is selected, then a graphics image will be created for the pattern. If Export the Information is selected, then a text file will be created for the pattern information.

To move to the next step of the Export Pattern Wizard, click Next.

**Select Graphics Image Resolution**

This step of exporting allows you to specify the resolution of the image that will be created for the chart. This step of the wizard is shown below.

The resolution that you specify will determine the quality of the image that is created. Keep in mind that the higher the resolution of the image, the larger the file size. For high-quality publishing, you will probably want to use 300 DPI or higher. Please check with your printer/publisher for recommendations on this value.
Select Graphics Image Type

The next step of exporting involves specifying the type of graphics image that should be created. This step of the wizard is shown below.

Choose an image type from the drop-down list. The JPEG and TIFF formats are very common and include compression which can help to reduce the size of the image file.

The Windows® Metafile format (WMF) and Enhanced Metafile format (EMF) are also good choices when the application you are importing into supports one of these. What makes the WMF/EMF file type different from all of the other types is that it stores the pattern chart as a collection of drawing commands instead of storing the chart as dots of various colors (i.e. raster format). As a result, the files are much smaller and the resulting image quality is as good as the capabilities of the display or printer being used. Another key benefit of this format is that it allows you to size the image within your publishing program without affecting the quality of the image.

Select Exported File Name

This step of the exporting wizard allows you to specify the name of the file(s) to be created and the location of this file on your system. This step of the wizard is shown below.
In the **Filename** box, type the name of the file and its location. Alternatively, click **Browse** to specify the file and location.

**Ready to Export**

At this point in the exporting process all information has been gathered. This step of the wizard is shown below.

The various options that you selected are shown. If you want to change any of these selections, then click **Back** as needed. To create the exported file(s) from these selections, click **Finish**.
Using Windows OLE

The Windows OLE capability of Pattern Maker allows you to embed or link a pattern into a document created by another OLE-capable Windows® program. The document might be a cross-stitch leaflet that is being created using a desktop publishing or word processing program. In this scenario, you would instruct your publishing program to insert or link a 'Pattern Maker Cross-Stitch Chart' object into your leaflet document. You would then see a 'picture' of the chart inserted into the document. You could then size and move the picture to fit into your chart. If you later found that you needed to edit the design, you could re-open it in Pattern Maker simply by double-clicking the picture. Pattern Maker would then open and allow you to edit the design. When you exited from Pattern Maker, the changes would automatically be reflected in the picture of the pattern shown in the document.

The following is a step-by-step example of using Pattern Maker OLE capabilities with the Microsoft WordPad application that comes with Windows®.

Create a New WordPad Document

The first step is to open WordPad. WordPad can be found in the 'Program - Accessories' group of the Windows® Start menu. When WordPad opens, a new document will be created.

Insert a Pattern Maker Object

For this example, a new Pattern Maker object will be inserted into the WordPad document. To do this, select Object from the Insert menu of WordPad. This will open the Insert Object dialog. In this dialog, it lists all of the available object types in the Object Type list. Scroll this list as necessary and select 'Pattern Maker Cross-Stitch Chart’. Next, click Ok.

At this point a picture of a pattern should appear in the WordPad document and Pattern Maker should open. Draw a few stitches in the new pattern and then select Exit & Return to Document from the File menu. Answer Yes when asked to save the changes.

WordPad should now show the pattern with the stitches that you added to the pattern. To make the pattern larger, click on the handle at the lower right corner of the picture and stretch by moving the mouse.

Please note that it is not a problem if the lines in the pattern object appear somewhat thin or having a low resolution. You can see a better representation of the pattern if you enlarge it or zoom-in (WordPad does not support zooming.) In addition, when you print the document containing the pattern object, the object will be printed at the full capabilities of your printer (or current quality setting of your printer).

Editing an Embedded Pattern Maker Object

To edit a Pattern Maker object that you embedded in a document, simply double-click the pattern object. Pattern Maker will then open. Make your changes and then select Exit & Return to Document from the File menu.

Inserting an Existing Pattern Maker Design

To insert an existing Pattern Maker design into a WordPad document, you would open the Insert Object dialog of WordPad, select Create from File, select the Pattern Maker file to insert, and the click Ok. The selected Pattern Maker design should then appear in the WordPad document.

Note that this approach to inserting a Pattern Maker document results in a copy of the pattern being inserted in the WordPad document. Since it is a copy of the original pattern, any future changes made to that pattern file will not be reflected in the WordPad document that contains a copy of the pattern. To have future changes to the original document reflected in the WordPad document, the pattern document should be Linked to the WordPad document.

To Link an existing pattern document to a WordPad document, select Link in the Insert Object dialog of WordPad. Note that you can still double-click the pattern object in WordPad to edit the pattern document.
The primary difference is that WordPad no longer stores the actual pattern in the file that it creates, but rather only the picture that it uses to represent the pattern.

Note that if you later move the original Pattern Maker document that was used to create a link to the WordPad document, then you will have to specify the new location to WordPad if you still want to have the capability of double-clicking the document to edit it or if you want to include future revisions of the pattern document in the WordPad document.

**Additional Capabilities**

Pattern Maker also allows you to link one or more selected areas of a pattern to another document. For example, you might want to create the front cover of a leaflet by linking the ‘stitch’ view of the pattern. You could also individually select and link those portions of the pattern (in the ‘symbolic’ view) that correspond to the other pages of the leaflet that show the chart. In this manner you could control exactly how the chart was paginated for your leaflet. For a special area of your design that needs specific instructions, you could select and link that area and place it in the ‘instructions’ section of your leaflet.

For these cases, a graphic is automatically produced by Pattern Maker which is then used by the other program to display that portion of the chart that was selected. When the graphic is double-clicked in the other program, Pattern Maker automatically opens the original document that was linked and re-selects the linked area of the chart.

To create a Link, first use the **Rectangular Selection** tool to mark that portion of the pattern. Next, select **Copy Object** from the **Edit** menu of Pattern Maker. In the program that is to receive the link, select the **Paste Special** item of the **Edit** menu. In the dialog box that opens, it should list 'Pattern Maker Cross-Stitch Chart’. Next, select the **Paste Link** option of that dialog box, and then click **Ok**. You should then see the selected portion of the pattern displayed in the document. Repeat as needed to link additional portions of the pattern to the document. Also note that the viewing options in use when a pattern is linked are remembered for each link.

**Summary**

The steps described for inserting Pattern Maker documents into a WordPad document are very similar, if not exactly the same as for other Windows® applications. To get the most out of the Windows® OLE feature, please consult the manual or help information for the publishing or word processing application that you use to contain Pattern Maker documents.
Machine Embroidery Features

The *Machine Embroidery* add-on of Pattern Maker allows you to very easily export your cross stitch designs into one of the common embroidery file formats for stitch-out on a machine.

Overview

The Machine Embroidery feature can export a design into any of the following machine file types:

- Brother/Baby Lock/Bernina (PES/PEC)
- Viking Husqvarna (HUS)
- Pfaff (PCS)
- Elna Xpressive (EMD)
- Janome Customizer 10000 (JEF)
- Janome New Home (SEW)
- Poem/Singer EU (CSD)
- Viking Huskygram (Old-style CSD) (CSD)
- Compucon/Singer PSW (XXX)
- Tajima (DST)
- Melco (EXP)

As necessary, the program will automatically split the design into multiple machine files based upon:

- Stitch limits imposed by the file type or memory card
- Thread change limits imposed by the file type or machine
- Hoop size

The limits used by the program in deciding when to split a design are fully selectable by the user. When it is necessary to split the file due to the hoop size being smaller than the design, the program will add alignment stitches along the boundaries between the sections to aid in the re-hooping or repositioning of the fabric. The program adds these alignment stitches in such a way that it is easy to remove them after alignment is done.

The thread order for the stitch-out of a design is based upon the order of the colors in the palette. To have a particular color stitch-out earlier, please use the Palette Properties dialog to adjust the position of the color in the palette. (Please see “Rearranging Colors of the Palette” on page 80 for more information.) Stitches are generated using three passes of the palette. In the first pass, all full, half, and quarter stitches are generated. In the second pass, back and straight stitches are generated. In the third pass, French Knots are generated.
In generating machine stitches to represent the design, the program attempts to minimize the number of jump stitches required. To aid the user in designing-out jump stitches, the display of jumps stitches (only after exporting) can be enabled for the currently selected palette color.

The program provides a detailed summary of the exporting results. This information includes the resulting design size, a list of all files created, and a thread change list for each file which includes stitch count per color. When stitching-out the design, the user should rely upon this thread list instead of the color descriptions that may be indicated by the machine. This information can be printed or displayed in a window that is updated each time the design is exported.

*Please note that some stitch types are not currently supported by the machine exporting feature. These include Petite and Specialty Stitches.*

The following sections provide detailed information regarding the machine embroidery features.

---

### Machine Exporting Wizard

The Machine Exporting Wizard provides a step-by-step series of dialogs that prompt you for the information needed to export your design.

To open the wizard, select **Export Using Wizard** from the **Machine Embroidery** menu or click the **Export to Machine File** button of the Machine toolbar.

Please note that it is possible to redefine the action of this toolbar button so that it immediately exports without showing the wizard. This is useful after you have become familiar with the exporting steps and are comfortable with the use of the **Export Settings** dialog that can be used to edit the exporting options separately. For more details, please see “Additional Options” on page 126.

The following sections describe each step of the wizard.

#### File Type

The first step in exporting to a machine file is selecting the file type to be created. This step of the wizard is shown below.

Choose a machine file type from the drop-down list.

To have your selection be shown as the default each time you export a new design, select the **Use for New Patterns** option.

---

Machine Embroidery Features  •  120
File Name

The next step in exporting is to specify the name and location of the file to be created.

In the **Filename** box, type the name of the file and its location. Alternatively, click **Browse** to specify the location to save the file.

Note that a default is provided for the name and location. The file name is the base file name of the design being exported with the file extension corresponding to the machine file type. The location for this file is same as the design file.

Note also that if the design must be split into multiple files, the name specified will be appended with information that identifies the use of each file (ex. the hoop number).

Hoop Options

The next step is to specify the hoop size and related options.
The drop-down list in the **Hoop Size** box can be used to select one of the hoop sizes supported by the selected machine file type. The size is specified as ‘width by height’. If the desired size is not shown in the list, then you can specify it as a **Custom** size. However, only use a custom size if your machine supports arbitrary-sized designs.

*Unless otherwise stated in the description of the hoop, it is assumed that the selection of a particular hoop implies that the machine to be used has a design area of at least that size.*

Depending upon the size of the hoop and the size of the finished design, it may be necessary to split the file into multiple sections which will require re-hooping of the fabric or repositioning of the hoop. The number of times you will need to re-hoop or reposition for the selected hoop is shown near the bottom of the dialog.

When re-hooping is needed, it may be desired to reserve a portion of each hoop to allow for fine positioning of the design within the hoop using the machine positioning controls. To reserve a portion of the hoop, specify the percent to reserve in the **Amount of Hoop to Leave Empty** box.

To aid the user in re-hooping a multi-hoop design, alignment stitches can be enabled. These are enabled by selecting the **Provide Alignment Stitches** option. The thread color used for the alignment stitches can either be the current thread color being used for the design at the time the alignment stitches are to be stitched, or a specific thread color as chosen by the **Color** option of this dialog. Using a specific color can be helpful since it will force a thread change after the alignment stitches are drawn thus pausing the machine. Additionally, a specific color can be useful when the design is very complex thus making it hard to identify the alignment stitches from the stitches of the design.

To have your selections shown as the default each time you export a new design, select the **Use for New Patterns** option.

### Stitch Thickness

The next step allows you to specify the thickness of the machine stitches.

![Machine Embroidery Wizard](image)

When creating a cross-stitch design using Pattern Maker, you can specify for each color of the palette how many strands of floss are to be used when stitching. Then, when stitching **by hand**, the user would thread that many strands onto the needle.

In the case of machine embroidery, the machine is threaded with a spool of thread which represents the equivalent of one strand. To produce more than one strand of thickness, the machine must stitch-over a given stitch multiple times.
This dialog allows you to choose how the thicknesses as specified in the design using strands are to be translated into the number of times a stitch is stitched-over. You can make this selection for three categories:

- Full, half, and quarter stitches
- Back and straight stitches
- French Knots

For each category you can specify the machine stitch thickness for each strand count supported by Pattern Maker.

For example, to have all thread colors that have been specified as 2 strands in the design stitched-over 4 times by the machine, select 4 from the drop-down list located to the right of 2 strands.

The best choices depend upon the size of the stitches. For large stitch sizes such as 11 per inch, you will likely want to select the largest value (6) to ensure the stitches have a suitable thickness in comparison to the stitch size. For small stitch sizes such as 22 per inch, you will likely want to select the smallest value (2).

*When selecting the thickness for back and straight stitches, it is recommended that you select an even number. If you select an odd number, the resulting machine file may require a large number of jump stitches when stitching the back/straight stitches.*

This dialog also allows the French Knot size to be specified. The size is specified relative to the size of a full cross-stitch. The thickness setting for the French Knot specifies how many times a French Knot is stitched over by the machine.

To restore the settings to typical defaults, click Set to Defaults.

To have your selection shown as the default each time you export a new design, select the Use for New Patterns option.

### File Splitting Options

The next step allows you to specify options for limiting the number of stitches and/or the number of thread color changes saved in each file.

![Machine Exporting Wizard](Image)

To limit the number of thread color changes per machine file, specify the limit in the **Split if the Number of Thread Changes Exceed** box.
To limit the number of stitches per machine file, specify the limit in the **Split if the Number of Stitches Exceed** box. In this case, selecting **Backup to Last Thread Change** will cause the file to be split between thread changes. (The 'backup' option may be overridden by the program if the stitch limit prevents all of the stitches from fitting in one file.)

Note that the limits shown depend upon the type of machine file selected. If these values are changed, the changes only apply to the currently selected file type.

To restore the settings to the defaults, click **Set to Defaults**.

### Color Conversion

The next step allows color conversion options to be specified.

These options are only available for the Pfaff, Janome New Home, Poem/Singer EU, and Viking Huskygram machine file formats.

Select the **Use Standard Colors Only** option when you want the colors stored in the file to only be those colors supported by the native software application used to create that file type. Specifically:

- PCS – PC Designer by Pfaff
- CSD – Singer EU Software
- SEW – Scansoft by Janome

Select the **Use Best Colors** option to allow the use of an extended set of colors.

In most cases it is recommended that you select **Use Best Colors**, and then rely upon the thread list that Pattern Maker provides as part of the exporting results.

To restore the settings to the defaults, click **Set to Defaults**.

### Ready For Exporting

After all options have been specified, the wizard will summarize your selections.
The various options that you selected are shown. If you want to change any of these selections, then click **Back** as needed. To create the machine file(s) from these selections, click **Finish**.

After exporting is complete, the wizard dialog will close. Please see the next section to learn how to display/print the exporting results.

### Exporting Results

To view the results of exporting select either:

- **View/Print Exporting Results** from the **Machine Embroidery** menu, or
- **Machine Embroidery Information** from the **View** menu.

The first option will open a Print Preview window that can be zoomed or scrolled to see more detail. To print this information, click **Print** at the top of the window. The other options at the top of the window can be used to see additional pages, change the viewing zoom level, and exit the display of this information.

The second option, the **Machine Embroidery Information** item of the **View** menu, can be selected to see this information in a normal viewing window of the pattern. In this case, it is possible to have this information displayed in a window next to another window for the same design where the stitches are displayed. You can then view the results with the pattern stitches also in view. To open an additional window for a design, select **New Window** of the **Window** menu. You can then select the desired view for that window using the **View** menu. Select **Tile Horizontally** of the **Window** menu to arrange the windows side-by-side.

The information shown in either case is summarized below.

- **Design File** - the file name of the original design
- **Design Size** - the actual size of the design as stitched by the machine
- **Hoop** - a description of the hoop that was selected for this design
- **Hoop 1 Center** - the position of the center of the first hoop in the case of a multi-hoop design. The diagram that prints with this information indicates the location of the hoop(s) relative to the overall design. In most cases the first hoop corresponds to the top left corner of the design.
- **Machine File List** - a list of one or more files that were created during the exporting of the design. For each file the number of stitches, colors, and the corresponding hoop position (for
Machine Embroidery Features

multi-hoop designs) is indicated.

When multi-hoop designs are created, the filename will include ‘_Hoop<Number>’ as part of the name, where <Number> is the hoop number.

When a design is split into multiple files due to thread change or stitch limits, the filename will include ‘-<Letter>’ as part of the name, where <Letter> can be from ‘A’ to ‘Z’.

- **Thread Lists** - a list of thread colors for each machine file. This information includes the color identifier, color description, number of stitches, and the number of jump stitches (jump stitch count is only shown in the Machine Embroidery View window).

### Jump Stitch Display

After exporting it can be useful to know where jump stitches were needed. To display the jump stitches for the currently selected color of the palette, click the Show Jump Stitches button of the Machine toolbar, or select Show Jump Stitches from the Machine Embroidery menu. You can then easily examine your design to determine where the addition or removal of stitches of a certain color might reduce the number of jumps.

You may also want to select the Highlight Selected Color option of the Palette menu to make it easier to see the stitches connected by the jump stitches.

Several options are provided to fine tune the display of jump stitches. To view/change these options select Jump Stitch Display Options from the Machine Embroidery menu. The following dialog box will open.

![Jump Stitch Display Options](image)

In the Show Jump Stitches For box, you can select whether jump stitches are displayed for the stitch-out of Full, Half, and Quarter stitches and/or for Back/Straight Stitches and French Knots.

In the Line Options box you can specify the color and thickness of the line used to represent a jump stitch.

### Hoop Position Display

In the case of multi-hoop designs, it can be useful to know where the various hoop positions fall relative to the stitches of the design. To have the program indicate this, select Show Hoop Boundary from the Machine Embroidery menu. Green lines will then be drawn over the design to reflect the hoop positions.

### Additional Options

After you have become familiar with the options that are available when exporting your designs to a machine format, you may want to more selectively edit the exporting options for a design. In addition, you
may want to have the Export to Machine File button of the Machine toolbar be used to immediately export the current design instead of opening the wizard.

To view the machine exporting settings as a normal dialog, select Export Settings from the Machine Embroidery menu. The following dialog will appear.

With the exception of the Options page, each page of the dialog corresponds to a step of the Machine Exporting Wizard. You can click the tab corresponding to a page to directly access those options and edit as desired.

The Options page of this dialog is shown below.

For the Toolbar Button Behavior option, you can specify whether the Export to Machine File button of the Machine toolbar opens the wizard or immediately exports using the current settings. The ‘immediate’ option is convenient when you want to make changes to the design and then quickly see the
results of the changes as viewed in the Machine Embroidery Information window or in the display of jump stitches in the Stitch view.

The **Printout Format** box includes options that apply to the formatting of the information that is displayed when the **View/Print Exporting Results** item of the **Machine Embroidery** menu is selected. These options allow you to specify the number of columns that are used for the thread list and whether stitch counts are included for each color in the thread list.
Page Layout Features

The Page Layout feature of Pattern Maker allows you to create a custom document layout for your design from within the program. This feature is only available in the Professional level.

Basic Layout Features

The Page Layout feature (or Layout feature for short) is made available using a built-in word processor. This word processor provides many of the basic capabilities found in common word processing applications. These capabilities include:

- Text formatting
- Paragraph formatting
- Tables
- Sections (with selectable column numbers and page size/formatting)
- Headers and Footers
- Insertion of objects from other applications

Additional specialized capabilities are also provided to blend the word processing features with the design capabilities of Pattern Maker. These specialized capabilities include:

- Floss/thread tables whose content and formatting can be customized
- Chart graphics whose content and size can be customized
- Pattern information fields filled using information from the design

By providing these specialized tables, charts, and fields the program can automatically update the layout whenever a change is made to the design. This eliminates the need to manually revise a design leaflet or publication when only a small design change is made.

Pattern Maker Window

When the Layout feature is selected, a different set of menus and toolbars are displayed. These contain commands and options which specifically apply to creating a layout. The following is an example of the Pattern Maker window when a layout is open.
The following differences in the window can be noted from this screen example:

- Layout toolbars (for font selection and specialized tools)
- Menus (layout-specific menus shown, design-specific menus omitted)
- Ruler (showing page position and paragraph formatting markers)
- Status bar (showing section, page, line, and column position of the cursor)

**Specialized Layout Features**

The Layout feature includes specialized capabilities which blend the word processing features with the design capabilities of Pattern Maker. These capabilities are described in this section.

**Chart Graphics**

One or more Chart Graphics can be inserted into a layout. Once a Chart Graphic is inserted into a layout, Pattern Maker will automatically update it as the design is revised.

A Chart Graphic can represent all or just a portion of the design. The display options for each graphic are independent. As such, you could insert a Stitch view of the design and also a Symbolic view of the design into the same layout. For details on how to insert and edit a Chart Graphic, see “Chart Graphic” on page 136.
Floss/Thread Tables

One or more Floss Tables can be inserted into a layout. A Floss Table is essentially a generic table that is filled and formatted automatically by Pattern Maker. The user specifies the content and general formatting of the table using special configuration dialog boxes. After a table is inserted into a layout, Pattern Maker will automatically update it as needed to ensure that it corresponds to the design. For details on how to insert and edit a Floss Table, see “Floss/Thread Table” on page 138.

Pattern Information Fields

Pattern Information fields serve as placeholders in a layout for design-specific information. Once a field is inserted into a layout, the program automatically fills it and keeps it updated. This information originates from either the Pattern Information dialog box (i.e. Pattern Title, Designer’s Name, etc.) or from calculated values such as the used/total size of the design. For details on how to insert Pattern Information Fields, see “Pattern Information Field” on page 148.

Creating a Layout

This section provides an example of creating a new layout starting from an empty layout. This example is based upon the ‘layout_exercise’ design that is included with the program. It is assumed that the reader will want to reference the other sections of this chapter for more specific details while following this example.

Step 1 – Starting the Layout

To begin this example, first open the design called ‘layout_exercise’ which is located in the ‘Patterns’ folder where sample designs are stored. Next, click the Layout view toolbar button, or select Layout from the View menu.

The layout for a design can be started from either a blank layout or an existing layout template. Since the example design does not currently contain a page layout, the following dialog is shown.

If the ‘Empty Layout’ option is selected, then a blank page will be shown. If the ‘Existing Layout’ option is selected, then a list of available layout templates will be shown. After the user selects a template, the layout will be formatted using that template and displayed. In either case, the user can then begin creating/editing the layout as desired.

For this example, select the ‘Empty Layout’ option. You should then see a blank page.

Step 2 – Document Structure

At this point the structure of the document should be decided. (For a discussion of document structuring, see “Document Structuring” on page 149.) The layout for this example will be comprised of:

- One page
- Chart graphic at the top of the page
To organize the floss tables and other information, a generic table will be used. That table will be inserted in a later step. The resulting page layout after following the steps of this example will appear as:

### Step 3 – Inserting the Chart Graphic

To insert a graphic that shows the chart for the design, select **Insert/Edit Chart** from the **Layout** menu.

You can also click the corresponding toolbar button: ![Chart](icon). Either method will open the **Chart Options** dialog box. For a detailed description of the options available via this dialog box, see “Chart Graphic Options” on page 137.

For this example, use the following chart settings:

- **Region:** **Entire Pattern**
- **Sizing:** **By Using Specified Overall Width:** 6 inches
- Use defaults for all other settings.

After clicking **Ok**, the new chart graphic should then appear in the layout as shown below.
After inserting the chart, the cursor will be flashing on the left side of the chart. Move the cursor to the right side of the chart by pressing the right arrow key on the keyboard. Next, press the enter key on the keyboard to add a line to the layout. The cursor should then appear below the chart. Press the enter key again to add another line.

**Step 4 – Inserting a Generic Table**

To provide a way to organize the bottom portion of the page, a generic table will be inserted. To insert the table, select **Insert Table** from the **Table** menu. In the dialog box that appears, specify 1 row and 2 columns. After clicking **Ok**, the table should then appear in the layout below the graphic inserted in Step 3.

**Step 5 – Inserting the Floss Tables**

In this design only full, quarter, back and French Knots stitches are used. For this layout, two floss tables will be used as follows:

- Table 1: used for full & quarter stitches
- Table 2: used for back stitches & French Knots

Although this example uses two tables, it is possible to setup one table for all of the stitch types.

**Inserting the Full & Quarter Stitch Table**

To insert the floss table for full and quarter stitches, first make sure the cursor is in the left cell of the table inserted in Step 4. If not already in that cell, then click the mouse in that cell. The cursor should then appear there. Next, select **Insert/Edit Floss Table** from the **Layout** menu. You can also click corresponding toolbar button: . Either method will open the **Table Options** dialog box. For a
detailed description of the options available via this dialog box, see “Floss/Thread Table Options” on page 139.

For this example, use the following settings:

- Table Title: Full & Quarter Stitches
- Use defaults for all other settings of this dialog box.

Click the Choose/Edit Columns button on this dialog box. This will open the Table Column Selection dialog box. In the list of available columns, click the Symbol – Full Stitches type and then click the Use button. It should then appear in the selected columns list. Repeat for the following column types:

- Symbol – Quarter Stitches
- Floss Number/ID
- Alternate Floss Number/ID
- Floss Color Desc.

Next, a few options for some of the columns will be selected. Click the Floss Number/ID type (located in the list of selected columns) to select it. Click the General Options button. In the General Column Options dialog box that appears, specify the Heading Text as “DMC”. Click Ok.

Click the Alternate Floss Number/ID type (located in the list of selected columns) to select it. Click the General Options button. In the General Column Options dialog box that appears, specify the Heading Text as “Anchor”. Click Ok.

With the Alternate Floss Number/ID type still selected, click the Special Options button. In the dialog that appears, select the ‘Anchor’ type as the alternative brand. Click Ok.

Click Ok to close the Table Column Selection dialog box. Click Ok to close the Table Options dialog box. At this point a new table should be visible within the generic table added in Step 4.

You will notice that some of the floss table columns are too narrow to hold their contents without wrapping to a new line. To fix this, it is necessary to enlarge the cell of the generic table that contains this floss table. To enlarge the cell, click and drag the cell border of the generic table that is just to the right of the floss table. Make the size of the left cell about three-quarters of the total table size. To have the floss table reformatted so the extra space can be used, select Refresh from the Layout menu. The table should then be reformatted to better fit the table. If some of the columns of the floss table are still wrapped, then repeat the above steps.

After resizing the generic table so that the floss table fits without wrapping, resize the generic table again so that the left cell is just slightly large enough for the floss table. That will leave room in the right cell for other information to be added in a later step.

**Inserting the Back Stitch/French Knot Table**

Before inserting the back stitch/French Knot table, it is necessary to position the cursor to the location where the table should be inserted. For this example, the table will be placed below the full/quarter stitch table. It will be necessary to add a blank line below the full/quarter stitch table.

To add a line below the full/quarter stitch table, first click on the last cell of that table. (For this design, that cell should contain the text “Jade – VY LT”.) Next, press the right arrow key until the cursor moves to the left side of the table. It will appear slightly lower than the bottom row of the table as shown below.
Next, press the enter key to add a line below the table. This new line should still be within the left cell of the generic table.

Next, select Insert/Edit Floss Table from the Layout menu. The Table Options dialog box will then appear. For this example, use the following settings:

- Table Title: Back Stitches & French Knots
- Use defaults for all other settings of this dialog box.

Click the Choose/Edit Columns button on this dialog box. This will open the Table Column Selection dialog box. In the list of available columns, click the Symbol – Back Stitches type and then click the Use button. It should then appear in the selected columns list. Repeat for the following column types:

- Symbol – French Knots
- Floss Number/ID
- Alternate Floss Number/ID
- Floss Color Desc.

Next, a few of the options for some of the columns will be selected. Click the Floss Number/ID type (located in the list of selected columns) to select it. Click the General Options button. In the General Column Options dialog box that appears, specify the Heading Text as “DMC”. Click Ok.

Click the Alternate Floss Number/ID type (located in the list of selected columns) to select it. Click the General Options button. In the General Column Options dialog box that appears, specify the Heading Text as “Anchor”. Click Ok.

With the Alternate Floss Number/ID type still selected, click the Special Options button. In the dialog that appears, select the ‘Anchor’ type as the alternative brand. Click Ok.

Click Ok to close the Table Column Selection dialog box. Click Ok to close the Table Options dialog box. At this point the back/French Knot table should be visible below the table added for full/quarter stitches as shown below.

<table>
<thead>
<tr>
<th>Back Stitches &amp; French Knots</th>
</tr>
</thead>
<tbody>
<tr>
<td>---------------------------</td>
</tr>
<tr>
<td>744</td>
</tr>
<tr>
<td>564</td>
</tr>
</tbody>
</table>

Step 6 – Inserting Pattern Information

This step will add several Pattern Information Fields to the layout.

Click the mouse within the right cell of the generic table added in Step 4. The cursor should then appear in the upper left corner of that cell.

At the cursor position, type the text “Fabric:” followed by enter key. On the line below the text that was typed, press the space bar 4 times to indent that line (note that there are better ways available to indent a line).

Next, select Insert Design Info from the Layout menu. This will open the Insert Information Field dialog box. (For more details on this dialog box, see “Pattern Information Field” on page 148.) Select Fabric Type from the list and then click Ok. The fabric type should then appear in the layout.
Move the cursor to the position after the last character of the fabric type, and then press the `enter` key to insert a new line. (If you move the cursor one too many positions, it will move to a position below the table. In that case just press the `left` arrow key to move it back.) Press the space bar 4 times to indent the new line. Next, insert the fabric size by selecting `Insert Design Info` from the `Layout` menu and selecting `Total Size – Stitches` from the list of fields. After clicking Ok, the size will be inserted.

Move the cursor to the position after the last character of the fabric size, and then press `enter` key to insert a new line. Press `enter` again to insert another line.

At the cursor position, type the text “Finished Size:” followed by the `enter` key. On the new line, press the space bar 4 times. Next, insert the finished fabric size by selecting `Insert Design Info` from the `Layout` menu and selecting `Total Size – Finished Units` from the list of fields. After clicking Ok, the size will be inserted.

Use the mouse to click and drag a selection over the “Fabric:” text that was added above. Next, select `Bold` from the `Font` menu. Repeat for the “Finished Size:” text.

To complete the layout, a header will be setup. The header will contain the design title centered in the header. To edit the header of the layout, select `Edit Header/Footer` from the `Edit` menu. The cursor position should move automatically to the header area of the page.

From the `Paragraph` menu, select `Center`. Next, select `Insert Design Info` from the `Layout` menu and select `Pattern Title`. Click `Ok`. Click the mouse on the title to ensure the cursor is within the title text. Next, use the font selection toolbar to select a size of 22 pts with the bold style. Turn-off header editing by selecting again the `Edit Header/Footer` item of the `Edit` menu.

### Step 7 – Printing the Layout

To print the layout, select `Print` from the `File` menu. To preview the printout select `Print Preview` from the `File` menu. Note that to print the layout of a design, the layout view of the design must be selected.

### Conclusion

The example presented by this chapter is only one of many possibilities for a design layout. You will get the most from this feature if you experiment with the options that are available.

---

**Chart Graphic**

This section describes how to use Chart Graphics in a layout.

### Inserting a Chart Graphic

To insert a Chart Graphic, position the cursor in the layout where you want the chart to be inserted, and then select `Insert/Edit Chart` from the `Layout` menu, or click the following toolbar icon: ![Chart Icon]. After a chart has been inserted into a design, you can right-click the chart and select `Edit Chart` to open the options dialog box for the chart. For all of the above cases, the `Chart Options` dialog box will be opened as shown below.

### Deleting a Chart Graphic

To delete a Chart Graphic, right-click the chart and then select `Delete Chart` from the menu that appears. Note that undo is not available in this case.

### Copying a Chart Graphic

Often you may find it useful to create a new chart by starting with the settings of a chart that you have already inserted into your layout (such as when you want to split the design into several blocks). To copy a chart:
1. Right-click the chart and select **Copy Chart** from the menu that appears.
2. Position the text cursor where you want the new chart to be inserted.
3. Select **Paste** from the **Edit** menu or press **Ctrl+V**.
4. Right-click the new chart and select **Edit Chart** to edit the settings of the new chart.

**Chart Graphic Options**

This section describes the options that are available for configuring a Chart Graphic. The **Chart Options** dialog box is shown below:

![Chart Options Dialog Box](chart_options.png)

**Region**

These options allow you to select what portion of the design is shown by the Chart Graphic. You can either select the entire design or a portion of the design. To only show a portion of the design, it is necessary to mark that portion by creating a ‘layout region’. For more details, see “Layout Regions” on page 71.

**Sizing**

There are several options for setting the size of the Chart Graphic. These options include the following:

- **By Specifying the Width** - The chart will be sized to have the width specified. The height will be calculated to maintain correct proportions. When this option is used, it is possible to manually adjust the size of the graphic after inserting it. To adjust the size after inserting it, first click the graphic to select it, and then grab and drag one of the handles around the edge of the graphic.

- **By Specifying the Stitch Width** - The chart will be sized such that each stitch (i.e. grid position) has the specified width. The height is calculated to maintain the correct proportions of the stitch.

- **By Splitting into Blocks** - The design will be split into blocks having the specified size using the specified stitch width. Based upon those settings, one or more blocks will be available for insertion into the chart. This effectively partitions the design into rows and columns of blocks of the specified size. Since multiple blocks typically result from this option, it is necessary to select which block you want to use for this Chart Graphic using the
Select Block options. You would then insert additional Chart Graphics for the other blocks. This provides a way to split a design over multiple pages/areas of the layout.

Viewing Options

Several options can be specified for controlling the appearance of the chart. These include the viewing mode, grid line display, the use of stitch outlining, and whether to show an under/overlay picture.

Centering Marks

Centering marks can be shown or not shown for the Chart Graphic. When shown, you can select whether the position of the marks is relative to the entire design or just the portion of the chart shown by the Chart Graphic. You might choose to use centering marks that are relative to only the portion shown in a case where the overall design is comprised of several independent areas.

The centering mark options also allow you to select the sides of the Chart Graphic on which the marks are displayed.

Overlapping

When the overall design is shown using more than one Chart Graphic (i.e. multiple blocks or regions are used). It is often useful to have each block overlap (i.e. repeat) a few rows/columns from the previous block. This makes it easier for the person stitching to follow the design. To enable overlapping, select the Show Overlapping option. When enabled, several options can be selected by clicking the Options button. The following dialog box will be displayed in that case.

The following options are available:

- **Amount To Overlap** - Select the number of stitches to repeat on each page.
- **Color** - Select the color and blending amount that will be used to shade the overlapping stitches.
- **Other Options** - Select whether the overlap color is used in place of the background color normally used when the ‘Color-behind Symbol’ feature is used. Select whether an alternative color is used for certain stitch types that are in the overlapped area.

Floss/Thread Table

This section describes how to use Floss/Thread tables in a layout.

Inserting a Floss/Thread Table

To insert a Floss Table, position the cursor in the layout where you want the table to be inserted, and then select Insert/Edit Floss Table from the Layout menu, or click the following toolbar icon: ![Floss Table Icon]. After a table has been inserted into a design, you can right-click the table and select Edit Table to open the options dialog box for the table. For all of the above case, the Table Options dialog box will be opened as shown below.
Deleting a Floss/Thread Table

To delete a Floss Table, right-click the table and then select **Delete Table** from the menu that appears. Note that undo is not available in this case.

Copying a Floss/Thread Table

Often you may find it useful to create a new table by starting with the settings of a table that you have already inserted into your layout (such as when you want to manually split a table). To copy a table:

1. Right-click the table and select **Copy Table** from the menu that appears.
2. Position the text cursor where you want the new table to be inserted.
3. Select **Paste** from the **Edit** menu or press **Ctrl+V**.
4. Right-click the new table and select **Edit Table** to edit the settings of the new table.

Floss/Thread Table Options

This section describes the options that are available for configuring a Floss Table. The **Table Options** dialog box is shown below.

![Table Options Dialog Box](image)

**Table Title**

Specify the name of the table. This title will be shown above the table. Leave this blank if you want to manually insert text into the layout for the title or if you do not want the table to have a title.

**Row Ordering**

Use this option to specify how the rows of the table should be sorted. You can either sort them according to the floss color identifier or have them listed according to the user-selected order of the palette.

**Include Color**

This option allows you to select whether to always list a palette color in the table when a color is used somewhere in the design (**If Used by Design** option) or to only included the palette color if its symbol is used by one or more of the selected columns of the table (**If Symbol Shown in Table** option). The later case is useful when inserting multiple tables where each table handles only certain stitch types. For that case you would only want the colors used by a particular stitch type to be included in the corresponding table.

**Table Splitting**

When a table includes a large number of palette colors, it may be desirable to split-up the table into several tables. While the layout feature will automatically split a table across pages, this feature allows the user to
control exactly where a table is split by choosing the First and Last color item that should be shown in the table.

For example, if a table would result in 25 colors being listed, and if it were desired to split the table so that the first 12 were shown in one table with the remainder in a separate table, then the following splitting values would be used:

First table:  **First Color = 1, Last Color = 12**

Second table:  **First Color = 13, Last Color = 25**

When splitting over multiple tables, it is necessary to create each table using exactly the same options except for different first and last color settings. Also, it is usually best to make the **Last Color** value for the last table to be a large number in case more colors are added to the design at a later time.

**Row Height**

There are several options for controlling the row height of a table. When the **Automatic** option is selected, the program will automatically use a row height that is large enough for the contents of each row.

When the **At Least** option is selected, a particular row height can then be selected such that the height of each row is at least that height. If the row height needs to be larger to contain the contents of a row, then the height will be automatically increased.

When the **Exactly** option is selected, the specified row height is used regardless of whether the contents of each row fits within that height.

There are separate row height selections for the header row and the rows containing the contents of the table. All content rows use the same row height setting.

**Choose/Edit Columns**

To select the columns of the table, click the **Choose/Edit Columns** button of this dialog box. This will open the Table Column Selection dialog box.

**Table Column Selection**

The **Table Column Selection** dialog box is used to select the columns of a Floss Table. This dialog box is shown below.

The **Available Columns** box provides a list of all the available column types that have not already been selected for the table. The **Selected Columns** box shows a list of the columns that have been selected for the table. The order (top to bottom) of the column types in this list corresponds to the order (left to right) of the columns in the table that is created.

The following are the available column types:

- **Item Number** – shows the table row number
- **Color Sample Box** – shows a box filled with the floss/thread color
- **Symbol – Full Stitch** – shows the symbol used for full stitches
Symbol – Half Stitch – shows the symbol used for half stitches
Symbol – Quarter Stitch – shows the symbol used for quarter stitches
Symbol – Petite Stitch – shows the symbol used for petite stitches
Symbol – Back Stitch – shows the symbol used for back stitches
Symbol – Straight Stitch – shows the symbol used for straight stitches
Symbol – Specialty Stitch – shows the symbol used for specialty stitches
Symbol – French Knot – shows the symbol used for French Knots
Symbol – Bead – shows the symbol used for beads
Strands – shows the strand count
Floss Type – shows the floss type (ex. DMC)
Floss Number/ID – shows the floss ID (ex. 123)
Floss Type and Number/ID – shows both the floss type and ID (ex. DMC 123)
Alternate Floss Number/ID – shows an alternative brand of floss/thread for the design (use the special options to select the alternate brand)
Floss Color Desc. – description of the floss/thread color
Floss Color Desc. And Note – description of the floss/thread color followed by the palette note(s)
Note – palette note(s)
Note as Footnote – palette note shown in a table below the floss/thread table. A number is shown in this column which references the note in the footnote table.
Usage – Full Stitches – the number of full stitches used in the design
Usage – Half Stitches – the number of half stitches used in the design
Usage – Quarter Stitches – the number of quarter stitches used in the design
Usage – Petite Stitches – the number of petite stitches used in the design
Usage – French Knots – the number of French Knots used in the design
Usage – Beads – the number of beads used in the design
Usage – Back Stitches – the total length of back stitches used in the design
Usage – Straight Stitches – the total length of straight stitches used in the design
Usage – Specialty Stitches – the total length of specialty stitches used in the design
Usage – Total – the skein estimate for the design

To add a new column to the selected list:
1. Click on the desired column type shown in the Available Columns list.
2. Click the Use button. The column type will then appear in the Selected Columns list. To adjust the position of the column type in the list, click the Up or Dn button.

To remove a column from the select list:
1. Click on the column type that you want to remove.
2. Click the Unuse button.

When a column has been added to the Select Columns list, you can then select the options that are available for that type of column. There are two categories of options that are available:

- General – options available for all column types
- Special – options specific to a certain type of column.
To select the general options, click the **General Options** button. To select the special options for a column, click the **Special Options** button. Note that special options are not available for all column types.

**General Options**

The General Options dialog box is shown below.

![General Column Options dialog box]

**General**

In this group of options the **Maximum Width** for the column can be selected. This option is useful for columns such as the **Floss Color Desc.** column where the width would normally be a large as needed for the longest color description. By setting a suitable value for the **Maximum Width**, the description can be made to wrap to another line to keep the overall table width from getting too wide.

The **Column Margin** can also be specified. This margin is applied to the left and right side of the column.

To select different units for the **Maximum Width** and/or **Column Margin**, click the units box shown to the right of the value.

**Heading**

The Heading options allow the column heading and alignment of the heading to be selected.

**Column**

The Column options allow the alignment of the column contents to be selected. For the **Horizontal Alignment**, the overall column alignment can be specified separately from the per row alignment. For example, to have each item of the column right aligned relative to the other row items, but have the overall column aligned in the center of the column, the following settings would be used:

- **Column**: Center
- **Data**: Right

Select **Save as default** to have these options used as the default for new tables.
Special Options: Color Sample Box

Size
Specify the size of the color sample box.

Customizations
Choose whether to include a black outline around the color sample.
Select **Save as default** to have these options used as the default for new tables.

Special Options: Symbol – Full Stitch

Formatting Type
The symbol for a full stitch can be shown using either the actual font character with no formatting (**Show as Unformatted Symbol**), or the symbol can be shown formatted as it is shown in the chart (**Show as Formatted Symbol**).

For the unformatted case, an alternative label can be specified in place of the actual symbol by selecting the **Use Alternative Label** option and then specifying the label.

For the formatted case the symbol is formatted as it shown in the chart. This option results in a small graphic being inserted into the column. The height of the symbol in that graphic can be adjusted as a percentage of the default symbol height. An outline around the graphic can also be selected.

Additional
To have the table use only one column for full, half, quarter, and petite stitches, select the option called **Same Column for Full/Half/Quarter/Petite Stitches**. Otherwise it is necessary to add separate columns for each of those types.

Select **Save as default** to have these options used as the default for new tables.
Special Options: Symbol – Half/Quarter/Petite Stitch

Formatting Type

The symbol for a half/quarter/petite stitch can be shown using either the actual font character with no formatting (Show as Unformatted Symbol), or the symbol can be shown formatted as it is shown in the chart (Show as Formatted Symbol).

For the unformatted case, an alternative label can be specified in place of the actual symbol by selecting the Use Alternative Label option and then specifying the label.

For the formatted case, the normal formatting of the symbol will result in a graphic with a small symbol in either one or two corners of the graphic depending upon the stitch type. To force the symbol to be a full-sized symbol instead, select the Use Full-Sized Symbol option.

Select Save as default to have these options used as the default for new tables.

Special Options: Symbol – Back/Straight Stitch

Formatting Type

The symbol for a back/straight stitch can be shown using either a text description with no formatting (Show as Unformatted Symbol), or the symbol can be shown formatted as it is shown in the chart (Show as Formatted Symbol).

The unformatted option for this symbol type always requires that a description be provided. This is necessary since backstitches do not have a font symbol associated with them.

For the formatted case, a graphic is generated which shows the appearance of the stitch as shown in the chart. The options available for this case are the width of the graphic and whether to outline the graphic.

Select Save as default to have these options used as the default for new tables.
Special Options: Symbol – French Knot/Bead

Formatting Type

The symbol for a French Knot/bead can be shown using either the actual font character with no formatting *(Show as Unformatted Symbol)*, or the symbol can be shown formatted as it is shown in the chart *(Show as Formatted Symbol)*.

For the formatted case, a graphic is generated which shows the appearance of the stitch as shown in the chart. The options available for this case are the height of symbol within the graphic and whether to outline the graphic.

Select *Save as default* to have these options used as the default for new tables.

Special Options: Symbol – Specialty Stitch

Content

A sample of the stitch and/or the name of the stitch can be selected for display in the table.

Customizations – Stitch Size

To specify the overall size of the sample stitch, specify the display height of the stitch, and then select the *Total Height of Stitch* option. This option is useful if you want all of the sample stitches to have a uniform height. To specify the size of each grid unit of the sample stitch, specify the grid unit height, and then select the *Height of 1 Grid Unit* option. This option is useful for ensuring that each stitch will be large enough to ensure readability.
Customizations - Other
To have an alternative label used in place of the sample stitch and stitch name, select the **Use Alternate Label in Place of Stitch** option and specify the label.
To have each stitch shown on a separate line of the table, select the **One Stitch Per Row** option.
Select **Save as default** to have these options used as the default for new tables.

**Special Options: Floss Number/ID, Floss Type and Number/ID**

Select **Show strand counts for blends** if you want the strand counts shown to the right of the color ID for blended colors. Select **Save as default** to have this option used as the default for new tables.

**Special Options: Alternate Floss Number/ID**
Specify the alternate floss/thread brand to be used for this column. The program will automatically determine the nearest equivalent color using the selected method(s) in **Cross-Referencing Method** box.
To edit the cross-referencing tables used by this feature, please see “Convert” on page 90.
This type of column can be used multiple times in a table.
Select **Save as default** to have these options used as the default for new tables.

**Special Options: Note as a Footnote**
Specify the maximum width of the footnote table. Footnote tables are shown below the main table.
Select **Save as default** to have the selected width used as the default for new tables.

**Formatting a Floss/Thread Table**
After a Floss Table has been inserted into a layout, the following formatting options can be modified:

- Font style
Page Layout Features

- Border color and width
- Table cell color and shading

**Font Style**

The default font style used for table cells and all other layout text is selected via the Default Font item of the Layout menu. When a table is inserted, it will use that default font.

The font style and font size can be selected for each column of a table. In addition, the style/size for the heading row is independent from the style/size of the content rows of the table.

To select the style or size, position the cursor on the text of the cell. Next, either use the font options toolbar, or the options on the Font menu to modify the font style. In either case the table will be redrawn to reflect the changes that were made.

The same method applies to the font style of the table title. Note that it is not necessary to select the entire title text or table cell text when changing the font style since only one settings is saved for each type. In other words, it is not possible to format part of a cell using one font and a different part of the same cell with a different font.

**Border Color and Width**

The color and the width of the table cell borders can be selected. The border style chosen for the header row of the table can be different from the style chosen for the content rows of the table. However, all content rows for a given column will always have the same border style.

To specify the border style for a particular column of cells, click on one of the cells so that the cursor is inside that cell. Next, select Border Color & Width from the Table menu. The following dialog box will open:

Select the width and color from the corresponding options. For the color option, click the small arrow to choose the color.

Next, select how you want the changes to apply to the table via the Apply Changes to option. These options are:

- **Table** – the style chosen will only apply to the outside edges of the table
- **Cell (All Rows)** – the style chosen will only apply to the cell where the cursor is located (or all cells of that column if the cell is in the body of the table)
- **All Cells** – the style chosen will apply to all cells of the table
- **Selected Cells** – the style chosen will apply to all selected cells

When multiple cells are selected, the **Cell (All Rows)** option is not available, but the **Selected Cells** option is available (and vice versa).

Next, click the Position buttons as desired to turn on/off the border lines. When a border line is shown in gray, then more than one color or thickness is used in the table at that position. To force all applicable cells
to use the current style selection, turn off and then on that position. It will then appear using the current color and thickness.

**Table Cell Color and Shading**

The color and shading of the table cells can be selected. The style chosen for the header row of the table can be different from the style chosen for the content rows of the table. However, all content rows for a given column will always have the same style.

To specify the cell color and shading for a particular column of cells, click on one of the cells so that the cursor is inside that cell. Next, select **Cell Color & Shading** from the **Table** menu. The following dialog box will open:

![Cell Style Dialog Box]

Select the color and shading from the corresponding options. For the color option, click the small arrow to choose the color.

Next, select how you want the changes to apply to the table via the **Apply Changes to** option. These options are:

- **Cell (All Rows)** – the style chosen will only apply to the cell where the cursor is located (or all cells of that column if the cell is in the body of the table)
- **All Cells** – the style chosen will apply to all cells of the table
- **Selected Cells** – the style chosen will apply to all selected cells

When multiple cells are selected, the **Cell (All Rows)** option is not available but the **Selected Cells** option is available (and vice versa).

---

**Pattern Information Field**

This section describes how to use Pattern Information Fields in a layout.

**Inserting a Pattern Information Field**

To insert a field, position the cursor in the layout where you want the field to be inserted, and then select **Insert Design Info** from the **Layout** menu, or click the following toolbar button: ![Insert Design Info Button]. The **Insert Information Field** dialog box will then be opened as shown below.

![Insert Information Field Dialog Box]

Select one of the field types from the list and then click **Ok**. The following are the available field types:

- **Pattern Title** – the title specified via the **Pattern Information** dialog box
Designer – the designer specified via the Pattern Information dialog box
Company – the company specified via the Pattern Information dialog box
Copyright – the copyright specified via the Pattern Information dialog box
Used Size – Stitches – the actual size of the design in stitches
Used Size – Finished Units – the actual size of the design in inches/cm
Used Size – Finished Units (Alt. Count) – the actual size of the design in inches/cm relative to the alternate fabric counts specified in the Pattern Information dialog box
Total Size – Stitches – the total size of the fabric in stitches
Total Size – Finished Units – the total size of the fabric in inches/cm
Total Size – Finished Units (Alt. Count) – the total size of the fabric in inches/cm relative to the alternate fabric counts specified in the Pattern Information dialog box
Fabric Type – the fabric type as specified in the Fabric Properties dialog box
Fabric Color – the fabric color as specified in the Fabric Properties dialog box
Fabric Stitch Count – the fabric stitch count as specified in the Fabric Properties dialog box
Note – the note as specified in the Pattern Information dialog box

Deleting a Pattern Information Field
To delete a field, right-click the field and then select Delete Field from the menu that appears. Note that undo is not available in this case.

Formatting a Pattern Information Field
After a field has been inserted into a layout, the font style can be modified. Note that the default font style used for information fields and all other layout text is selected via the Default Font item of the Layout menu.

To select the font style or size, position the cursor on the text of the field. Next, either use the font options toolbar, or the options on the Font menu to modify the font style. In either case the field will be redrawn to reflect the font changes.

Note that it is not necessary to select the entire field when changing the font style since only one setting is saved for the entire field. In other words, it is not possible to format part of a field using one font and a different part of the same field with a different font.

Document Structuring
To create an efficient and attractive layout, it is important that the user understand the methods that are available for organizing the page area. The two primary methods are thru the use of sections and tables.

If tables or sections are not used, then each item of the layout will be positioned on the page or pages on separate lines using a single column.

The following discusses the use of sections and tables.

Sections
The layout for a design can consist of one or more pages. For each page or group of pages, one or more Sections can be created. For each Section the paper orientation (i.e. landscape or portrait), page size, page margins, page numbering options, and number of columns can be chosen.

To select/edit the section options, first position the cursor within the section of the document that you want to modify. Next, select Page Setup from the File menu. This will open the Page Setup (Custom
**Layout** dialog box which contains multiple pages of options. Note that for some options, it is possible to select whether to apply the changes to all sections of the document or just the current section.

When selecting the **Page Setup** options, the current printer will be used to determine the available paper options.

The following describes each page of the Page Setup dialog box.

**Paper Size**

![Paper Size Dialog Box]

Select the page size and orientation for this section or the entire document. Modify the **Width** and/or **Height** to specify a custom page size.

**Paper Source**

![Paper Source Dialog Box]

Select the paper source for the first page of the section/document and all subsequent pages.
Section Options

Select the number columns for this section via the **Number of Columns** option. Select the spacing between columns via the **Column Spacing** option. To have the section start at the beginning of a new page, select **Begin Section on New Page**. To have the page numbering of the document restarted for this section, select **Restart Page Numbering** and specify a value for **First Page Number**.

Margins

Specify the margins for this section. Note that the **Top** and **Header** margins are both measured from the top of the page. If the **Top** margin is less than the bottom of the **Header**, then the **Top** margin is automatically increased to prevent an overlap. The same applies to the **Footer** and **Bottom** margins.

Tables

Tables are useful for dividing the area of a page into several independent areas or cells. The contents of each cell can then be filled with any type of information/object supported by the Layout feature. For example, if a 1-row, 2-column table were created, then the left column could be filled with a chart object representing the design while the right column could be filled with a floss/thread table.

To insert a **generic** table (as opposed to a Floss/Thread Table) for organizing a page, first position the cursor on the page where you want the table to be inserted. Next, select **Insert Table** from the **Table** menu. This will open a dialog where you can specify the number of rows and columns for the table. After specify the table size, the table will be inserted. You can then click on one of the table cells and insert a Chart Graphic, a Floss/Thread table, a Pattern Information field, or any other text or object.

The width of a table can be changed by clicking and dragging one of the column divider lines of the table. Be sure that the **Show Grid Lines** option of the **Table** menu is selected. In cases where the right side of
a table extends beyond the right edge of the page, you can still click and drag the right side of the table to resize it to fit the page.

## Layout Templates

Pattern Maker allows a Page Layout to be stored as Layout Template to make it easy to re-use a layout for another design. To save the layout of a design as a template, select the **Save as New Template** menu item of the **Layout** menu. This will open the **Save Layout As** dialog box where you can specify a name for the new template file.

To choose an existing template for a design, select **Select Existing Template** from the **Layout** menu. After selecting a template, it will be loaded and filled using the current design.

## Miscellaneous Features

### General Word Processing

The layout feature provides many basic word processing features including paragraph formatting, text formatting, tables, and headers/footers. Since the features are very similar to other applications of this type, only a brief description is provided below.

#### Paragraph Formatting

The paragraph formatting features are most useful when formatting text that you have either typed or copied into the design. To format a paragraph, click on the paragraph to position the cursor on it, or drag a selection to include one or more paragraphs. Once selected, the following paragraph formatting options are available via the **Paragraph** menu.

- **Normal** – reset the paragraph to default settings
- **Left Justify** – align the paragraph to the left margin
- **Center Justify** – center the lines of the paragraph
- **Right Justify** – align the paragraph to the right margin
- **Justify Both** – align the paragraph to the left and right margins
- **Double Space** – double the spacing between the lines
- **Left Indent +** – increase the left indentation
- **Left Indent -** – decrease the left indentation
- **Hanging Indent** – indent the first line of the paragraph
- **Set Tab** – set tab positions
- **Clear Tab** – clear tab position
- **Clear All Tabs** – clear all tab positions
- **Bulleted List** – create a bulleted list
- **Numbered List** – create a numbered list
- **Border and Shading** – select the border line style and shading for the paragraph
- **Background Color** – select the background color of the paragraph

Note that some of these options are available via the **Layout - Paragraph** toolbar. To show this toolbar, right-click on the toolbar area near the top of the Window and select **Layout – Paragraph**.

The ruler that is shown at the top of the layout window indicates the margins, indentation, and tab positions for the current paragraph. The following indicators are used:
• Triangle on top row – indicates the indentation for the paragraph
• Triangles on bottom row – indicates the left and right margins
• Tab position markers – indicates the position of each tab

To move one of the markers, click and drag the marker using the mouse.

**Text Formatting**

The text formatting features allow a wide variety of text formatting options to be applied to any text of the layout. The following text formatting options are available via the **Font** menu.

- **Normal** – turns-off all style selections (i.e. bold, underline, etc.)
- **Bold** – enables the bold style
- **Underline** – enables the underline style
- **Double Underline** – enables the double underline style
- **Italic** – enables the italic style
- **Superscript** – enables the superscript style
- **Subscript** – enables the subscript style
- **Strikethrough** – enables the strikethrough style
- **Protect** – enables text protection. This prevents the text from being edited.
- **Fonts** – displays the font selection dialog box where the typeface, style, size, and effects can be selected
- **Text Color** – allows the text color to be selected
- **Background Color** – allows the background color to be selected
- **Spacing** – allows the character spacing to be adjusted
- **Boxed** – enables the drawing of a box around the text

Note that some of these options are available via the **Layout - Font** toolbar. To show this toolbar, right-click on the toolbar area near the top of the Window, and select **Layout – Font**.

The default font that is used for the layout can be chosen by selecting **Default Font** from the **Layout** menu. This font is used when Floss/Thread Tables and Pattern Information Fields are inserted into the layout.

**Table Formatting**

The table formatting features can be used for generic tables and Floss/Thread Tables. In the case of Floss/Thread Tables, only a subset of the table formatting features is available. The unavailable features are disabled when a floss table is selected. The following table formatting options are available via the **Table** menu.

- **Insert Table** – inserts a table into the document
- **Insert Row** – inserts a row into the current table above the current row
- **Insert Column** – inserts a column into the current table
- **Split Cell** – splits the current table cell into two cells
- **Merge Cells** – merges the selected table cells into one cell
- **Delete Cells** – deletes the selected table cells, current row, or current column
- **Horizontal Alignment** – used to select how the overall table is horizontally aligned on the page
- **Vertical Alignment** – used to select how the contents of the table is vertically aligned within each table cell
Border Color & Width – used to select the border color width of one or more table cells

Cell Color & Shading – used to select color and shading of one or more table cells

Header Row – used to mark the current table row (i.e. the table row where the cursor is currently located) as a header row. The contents of the header row are automatically repeated when the table is split across a page boundary.

Show Grid Lines – enables the display of lines showing the table cell boundaries.

For generic tables, the width of the table cells can be manually edited by using the mouse to click and drag the cell border lines.

**Headers and Footers**

Headers and footers can be setup for the layout. To edit the contents of the header or footer, select Edit Header/Footer from the Edit menu. This will allow the cursor to be placed in the header or footer area of the page. Text, fields, and tables can be inserted into the header or footer area.

The Edit Header/Footer option should be turned-off after editing the header/footer since some formatting commands are not available during header/footer editing.

**Inserting Breaks**

Several types of breaks can be selected via the Insert Breaks item of the Insert menu. These include the following:

- **Page Break** – used to force the page contents starting at the current cursor position to begin on the next page
- **Column Break** – used to force the page contents starting at the current cursor position to begin on the next section column
- **Section Break** – used to force the page contents starting at the current cursor position to begin on a new section

**Unique Features**

**Inserting Pictures and Objects**

The Page Layout feature allows pictures and OLE objects from other programs to be inserted into the layout. For example, it might be desirable to insert a bitmap or metafile of a company’s logo into the layout.

To insert a picture (ex. bitmap or metafile) into a layout, position the cursor where you want the picture to be inserted, select Picture from the Insert menu, and then select the picture using the Open dialog box. Once inserted, click the picture to select it, and then click and drag one of the handles in a corner to resize the picture.

To insert an OLE object into a layout, position the cursor where you want the object to be inserted, select Object from the Insert menu, and then select the type of object from the list. After the program that provides the object is closed, a graphic of that object will appear in the layout. The size can then be adjusted as described above for pictures.

It is also possible to insert OLE objects that have been copied to clipboard from another application. In that case, select Paste Special from the Edit menu. That will result in the Paste Special dialog box opening from which the available types of objects will be displayed. Select an object from the list and then click Ok. The object will then be displayed in the layout. The size can then be adjusted as described above for pictures.

**Exporting Layout As an RTF File**

The Page Layout can be exported as a Rich Text Format (RTF) file. This allows the layout to be further edited using other programs such as MS Word.
To export a layout as an RTF file, select Export As RTF from the Layout menu. A dialog box will open where you can choose the name of the exported file.

**Text Protection**

The Page Layout feature uses a text protection feature for marking the special features such as Floss Tables and Pattern Information Fields as protected. This is used to remind the user that those items should not be manually edited since the program automatically updates them. In some cases it may be necessary to manually delete an item instead of using the right-click menu that is available. In those cases it is necessary to first turn-off the text protection feature before trying to delete the item.

To turn-off the text protection feature, first select the item to be deleted by pressing the left mouse button and dragging the mouse over the item or text. Next, select Protect from the Font menu to turn-off that setting. It should then be possible to delete the item or text.

**Miscellaneous Commands**

The following are miscellaneous commands that are available.

- **Edit Menu – Picture Settings** – used to specify the size of an inserted picture and its alignment.
- **Edit Menu – Repaginate** – used to force repagination to occur. Normally this not required since repagination is automatically done as needed.
- **View Menu – Show Field Names** – used to display/hide the field names of information fields and tables that have been inserted into the layout.
- **View Menu – Paragraph Maker** – used to display/hide paragraph markers
- **Insert Menu – Page Number** – used to insert the page number field into the layout. This field is automatically updated.
- **Insert Menu – Page Count** – used to insert the total number of pages used by the layout. This field is automatically updated.
- **Insert Menu – Date/Time** – used to insert the date and/or time into the layout. This field is automatically updated.
- **Layout Menu – Refresh** – used to cause the layout to be completely refreshed using the current settings and current pattern design.
Pattern Maker includes advanced color-management features that can be used to enhance the quality of the pattern display and printout.

**Overview**

Windows 98/2000/Xp provides Image Color Management (ICM) technology that can be used by software applications to improve the presentation of color. With this technology, color can be shown more consistently between different computers and also between display and printing. Pattern Maker includes support for this technology.

This technology makes use of color profile information that is provided by the manufacturer of monitors and printers. A color profile is stored in a file and is specific for a particular brand and model of monitor or printer. The profile describes the range of colors and other information that describes the capabilities of the monitor/printer in generating color.

The color profile that is provided for a monitor or printer is designed for use with that particular model. Since each manufactured unit of that model may vary somewhat in how it renders color, and since the color rendering capability can change as the device ages, the manufacturer-provided profiles should be only considered a good starting point. For the best possible results, it is necessary that a color profile be created for a particular monitor or printer. Various products are available for this purpose. These products use special hardware and software to measure the color capabilities of a monitor and/or printer. If you are working in a production environment, then it may be desirable to investigate that type of product to ensure that the most accurate profiles are available for your hardware.

The main benefits of using color managements with Pattern Maker are:

1. It makes it possible to display a design on multiple computers and see the same rendition of color.
2. It makes it more likely that you will see the floss/thread colors the same way as they were imported by HobbyWare.
3. It makes it possible to perform soft or hard proofing of a design that will be ultimately printed elsewhere.

**Using Color Management**

The first step in using the color management features of Pattern Maker is acquiring and installing suitable color profiles for your hardware. Since some monitors and printers include color profiles as part of the installation of the hardware, this step may already be complete. You can verify if a profile has been setup for a monitor or printer by opening the device properties for the device and then selecting the ‘Color Management’ category. All installed profiles for that device will be listed.

In general, the acquisition and installation of the color profile is beyond the scope of this manual. However, the best place to look for color profiles is at the web site of the manufacturer of the monitor or printer.
Once color profiles are installed for your hardware, the next step is to enable this feature and select the various options. To open the options dialog box for this feature, select **Color Management** from the **File** menu. The following dialog box will appear:

![Color Management Dialog Box](image)

This is the standard Windows dialog box for selecting the color management options.

Use the **Enable Color Management** checkbox to enable or disable this feature. Once enabled, you can then select between two basic modes of operation:

- **Basic color management** – use this option to have the program show color as accurately as possible for the monitor and printer connected to this computer. This is the normal mode for the color management feature.

- **Proofing** – use this feature to see color on your monitor and/or printer as it would appear on another monitor or printer. For example, you might use this feature to get an idea of how the color will appear when the design is printed on a printing press for publication. For this option to work, you must have an accurate profile for the monitor and/or printer connected to your computer, as well as for the other printer (or monitor) that is being emulated.

The range of colors that a given device (i.e. monitor, printer, etc.) can produce is called its gamut. No one device can reproduce all possible colors. The gamut is usually dependent upon the technology used to generate color. For example, the gamut of CMYK printers is different from the gamut of RGB monitors. As a result, some colors that can be displayed on a monitor cannot be shown as accurately when printed, and vice versa.

When a given color cannot be shown exactly on the monitor or printer, the color management feature of Windows makes use of the **Rendering Intent** option to control how the color is translated. The **Rendering Intent** can be one of these settings:

- **Pictures** – When a color of the design falls outside of the range of colors that the monitor or printer can produce, the Picture intent will cause all of the colors of the design to be adjusted so that every color in the design falls within the range of color that can be rendered and so that the relationship between colors is preserved as much as possible. (This setting is sometimes referred to as the ‘perceptual intent’ in other applications.)

- **Graphics** – When a color of the design falls outside of the range of color that can be produced, the Graphics intent will cause the saturation of the colors to be preserved at the expense of the hue and lightness. This option is often used for business graphics where it is more important that the colors be vivid and have good contrast rather than specific colors be produced. (This setting is sometimes referred to as the ‘saturation intent’ in other applications.)

- **Proof** – When a color of the design falls outside of the range of color that can be produced, it is adjusted to the closest color that can be produced while all other colors are left unchanged. This setting does not preserve the ‘white point’ of the colors. (This setting is sometimes referred to as the ‘colorimetric intent’ in other applications.)
• **Match** - When a color of the design falls outside of the range of color that can be produced, it is adjusted to the closest color that can be produced while all other colors are left unchanged. This setting preserves the ‘white point’ of the colors. (This setting is sometimes referred to as the ‘absolute colorimetric intent’ in other applications.)

---

**Additional Information**

When the Graphics Exporting feature of Pattern Maker is used to create a graphics image of the design, the Color Management settings are not used. In this case, all colors of the exported graphic will be relative to the sRGB color space. When importing the resulting image into a program that supports color management, that program should be configured to associate the sRGB color space with the image.

The graphic generated by the OLE feature of Pattern Maker is also relative to the sRGB color space.

When importing an image into Pattern Maker, Pattern Maker assumes all colors in the image are relative to the sRGB color space. Most scanners use this color space as the reference for the colors saved during scanning.
Pattern Maker allows you to create libraries of cross-stitch objects that you can then easily insert into new designs. Add-on libraries are also available from HobbyWare. These libraries make it easy to build designs from existing design elements.

What is a Pattern Maker Library?

A Pattern Maker library is essentially a pattern that has been organized into a collection of cells. Each library cell can contain one object that can be given a name. For example, you might create a library pattern of flowers with one of the cells in the library call 'bluebonnet'. To insert this particular cell into a pattern that you are designing, you would simply choose that library and select the 'bluebonnet' item. The stitches representing the bluebonnet would then be inserted into your pattern.

Creating a New Library

You can create a new library from either an existing pattern or a new pattern. Follow these steps to create a library from a new pattern.

1. Create a new pattern by selecting New from the File menu.
2. Mark the pattern as a library by selecting Use as Library from the Library menu.
3. Select Options from the Library menu. The Library Options dialog will then open as shown below.

4. For the Library Type, select General. For the Cell Size, specify the largest object size that you plan to create. Each object must fit within this size. You can change the size later, but it will probably require you to re-arrange the existing objects in the library. Next, select Ok. The pattern should now show a blue grid marking the boundaries of each library cell.
5. Draw one of your library objects in one of the cells. It does not matter which cell is used.

6. Mark the used area of the cell if the actual size of the object is smaller than the cell size. To do this, first use the Rectangular Selection tool to draw a box around the object you placed in the cell. Next, select **Mark Usable Cell Area** from the Library menu (or press `ctrl+m`). You should then see markers drawn in the cell to indicate the area that you selected.

7. Name the cell by selecting **Set Cell Name** from the Library menu. This will open the **Library Cell Names** dialog as shown below.

```
In the **Cell** box, enter the cell number that you want to name. The cell number is displayed in each library cell. In the **Name** box, enter the name that you want to use for the cell. 
Optionally, specify keywords which describe the object. These keywords can later be used to help find this object when using the **Copy From Library** dialog.

To avoid the need to enter the cell number, position the mouse pointer over the cell and then press `ctrl+i`. This will open the **Library Cell Names** dialog with the cell number filled-in for the cell.

Click **Ok**.
```

8. Give the library pattern a descriptive name by specifying the **Pattern Name** in the **Pattern Information** dialog (see “Specifying Summary Information” on page 20). The name that you specify here will be listed in the **By Library Theme** list of the **Copy From Library** dialog.

Please note that it is allowable to specify the same pattern name for one or more library patterns. In this case, the objects from all patterns of the same name will be shown when you select that name from the **By Library Theme** list of the **Copy From Library** dialog. However, in most cases you will want to uniquely name each library pattern.

9. Save the library file by selecting **Save As** from the File menu. You must save your library in the **Library** subfolder of the default pattern folder (`\My Documents\PM Patterns` by default) for it to be available as a library.

---

**Inserting an Object from a Library**

It is very easy to insert an object from a library pattern.

1. Select **Copy from Library** from the Library menu, or click the corresponding toolbar button: ![Copy from Library](icon). This will open the **Copy from Library** dialog as shown below.
2. Click on one of the objects to select it.

3. Click **Copy** to copy the object into your design.

When this dialog is opened, all available objects will be shown in the **Library Objects Found** box. When using a clipart library, there can be hundreds of objects to choose from. To help you narrow the choices, you can search using three methods:

- **By Library Theme** - Shows only the objects fitting a particular theme.
- **By Object Name** - Select from a list of object names.
- **By Keyword Search** - Shows only the objects having any or all of the keywords that you specify.

To see fewer or more objects displayed on each page of the **Library Objects Found** list, select one of the options in the **Items To Show** list.

---

### Creating a Font Library

The text entry feature of Pattern Maker uses pre-made font patterns. These are specialized library patterns where each letter/number/symbol of the font is drawn in one cell of the library. The cell name for each cell of a font pattern is the actual font character that the cell represents.

The following steps can be used to create a custom font:

1. Create a new pattern by selecting **New** from the **File** menu.
2. Draw all letters/numbers/symbols for your font.
3. Determine the Width, Descent, Ascent, and Height of your font. These are defined as:
   - **Font Width** - the widest character of the font
   - **Font Baseline** - the imaginary line onto which all characters rest.
   - **Font Descent** - the most any character extends below the baseline.
   - **Font Ascent** - the most any character extends above the baseline.
   - **Font Height = Descent + Ascent**
4. Create a new pattern having the following size:
   - **Pattern Width = (Font Width + 2) x 26**
   - **Pattern Height = (Font Height + 2) x 3**
5. Use the Rectangular Selection tool to copy the font from your original pattern where you drew the font to the new pattern. You will want to paste into the new pattern as far to the right and bottom as possible.

6. Mark the pattern as a library by selecting Use as Library from the Library menu.

7. Select Options from the Library menu. The Library Options dialog will then open as shown below.

8. For the Library Type, select Font. Specify the other fields as:
   - Horizontal Cell Size = \(\text{Font Width} + 2\)
   - Vertical Cell Size = \(\text{Font Height} + 2\)
   - Font Baseline Position = \(\text{Font Descent} + 1\)
   - Default Line Spacing = \(\text{Font Height} + 2\)
   - Font Size = \(\text{Font Height}\)

9. Click Ok. The pattern should now show a blue grid marking the boundaries of each library cell. The horizontal dotted line marks the baseline of the font.

10. Give the font a descriptive name by specifying the Pattern Name in the Pattern Information dialog (see “Specifying Summary Information” on page 20). The name that you specify here will be used in the Text Options dialog box to describe the font.

11. Save the library file by selecting Save As from the File menu. You must save your library in the Library subfolder of the default pattern folder (\My Documents\PM Patterns by default) for it to be available as a font pattern.

The next series of steps involve moving each letter/number/symbol of the font to a specific cell of the font library. The following steps should be repeated for each letter/number/symbol of the font. For consistency, it is recommended that you move capital letters to the first row of cells, lower-case letters to the second row, and number/symbols to the third row of cells.

12. Use the Rectangular Selection tool to draw a box around the stitches representing a particular character of the font. Click and drag the selected character to an empty library cell. Position the character so that it rests on the baseline with one column of space on the left side. If all of the font characteristics were properly determined above, there should be at least one column/row of stitches on the other three sides of the character.

13. Use the Rectangular Selection tool to draw a box around that portion of the cell that is actually used by the character of the font as shown below. Be sure the selection box touches the character on the left, leaves one column of stitches on the right, and extends to the top and
14. Next, select **Mark Usable Cell Area** from the **Library** menu (or press **ctrl+m**). You should then see markers drawn in the cell to indicate the area that you selected.

15. Click outside the selected area to remove the selection.

16. Position the mouse over the cell and press **ctrl+i**. This will open the **Library Cell Names** dialog as shown below.

![Library Cell Names dialog](image)

17. In the **Name** box, type the character that this cell represents. The **Keyword** fields of this dialog are not used for fonts.

18. Repeat steps 12-17 for each character of the font.

19. Create a ‘space’ character. To do this, select an empty cell to be used for the space character, and then mark the usable cell area as in step 13 above. The marked area should include roughly half of the cell size. Next, name the ‘space’ cell as in step 16 by simply typing a **single** space as the name.

20. Save and then try-out your font pattern.
This chapter describes the licensing features of Pattern Maker.

Overview

Some versions/releases of Pattern Maker include software license management. These versions require that each copy of the program be authorized before it can be used. For these versions, Pattern Maker will run in a trial mode for several days. To use the program after the trial period, it must be licensed.

A license can be obtained in two ways. These include:

- Via the Internet using a provided serial number. In most cases the program is shipped with a serial number. This serial number is unique for that copy and can be used to automatically authorize the program over the Internet.
- Via telephone or email. After purchasing the program, the user can obtain a site key for the program. This key will unlock the program.

A license can only be used on the computer for which it was issued. However, it is possible to transfer a license from one computer to another.

When an unlicensed version of Pattern Maker is opened, the Licensing Wizard will be shown. This wizard guides you through the steps for installing a license for your copy.

It is also possible to install or upgrade licenses which unlock additional feature levels/add-ons. These licensing options are found under the Licensing submenu of the File menu.

The licensing features are discussed in more detail in the following sections.

Licensing Wizard

The Licensing Wizard is shown each time the program is opened when a valid license has not been installed. This wizard includes several pages which guide you thru the licensing options. The first page is shown below.
Two options are available when this page is shown:

- **Install a License** – use this option to install a license
- **Start the 2-day Trial Period** – use this option to use the program in an unlicensed mode for 2 days. After the trial period expires, the program must be licensed. Note that when the program is run after starting the trial period, the **Continue Trial Period** option is shown instead.

When **Start the 2-day Trial Period** is selected, the Licensing Wizard closes and the program continues. However, if the trial period has already expired, then a message is shown indicating that.

**Note that the actual trial period available may be different in the copy that you receive.**

After choosing an option, click **Next**.

When **Install a License** is selected, the following page is shown.

The following options are available:

- **I received this serial number.** Select this option if you received a serial number with the program and if you have Internet access on the computer running Pattern Maker. Enter the serial number that you received in the **Serial Number** box.

- **I received this unlocking key.** Select this option if you were provided a site key. For this case, enter the key in the **Site Key** box. This option is typically used when using the telephone or email to license the program. In this case you would provide the **Site Code** shown on this page of the dialog, and HobbyWare would then provide the corresponding **Site Key**.
• **I want to transfer a license from another computer.** Select this option if you are transferring a license from another computer. Please refer to “Transferring a License” on page 167 for more details.

After choosing an option, click **Next**.

In the case of the option **I received the following unlocking key**, the program will verify the Site Key that you specified and then open the program if it is valid.

In the case of the option **I received this Serial Number**, the program will show the following page.

![Licensing Wizard](image)

Click **Next** to continue. The program will then connect to HobbyWare and validate the serial number. If unsuccessful, a message will be shown. The following are typical sources of problems:

- Serial number was miss-typed – check the number and correct if necessary.
- Internet connection not available – verify that you can access the Internet using other applications such as the web browser.
- HobbyWare server temporarily unavailable – retry later.

If successful, a valid license will be installed for the program and the following will be shown.

![Licensing Wizard](image)

Click **Finish** to use the program.
Transferring a License

After a license has been installed for a copy of Pattern Maker, it is possible to transfer that license to another computer. This is useful when upgrading to a new computer.

The following procedure should be used to transfer a license.

1. Install and then run the copy of the program that is to receive the license.
2. When prompted by the Licensing Wizard, select Install a License and then click Next.
3. On the following screen, select I want to transfer a license from another computer and click Next. The following screen will then be shown.

4. Insert a diskette into the computer and then click Next. The following screen will be shown.

5. Remove the diskette and insert it into the computer that has the licensed copy of Pattern Maker. On that computer, run Pattern Maker and select License followed by Transfer from the File menu. The following will be shown.
6. Click **Next**. The following will be shown.

7. Click **Finish**. At this point the copy on this computer can no longer be used since it is unlicensed. Remove the diskette and insert it into the computer that has the unlicensed copy of Pattern Maker. On that computer the following should still be displayed:

Click the **Next** button shown above.
8. The license transfer is complete. The following will be shown.

License Status

To determine the current status of your Pattern Maker license, select **License** followed by **Status** from the **File** menu. This will open the following dialog box.

The **Copies** field indicates the number of copies currently licensed. The **Type** field indicates whether any time or use limitations apply. The **Remaining** field is used in case a duration or use limit is in effect.

Upgrading an Installed License

A Pattern Maker license can be upgraded to include additional levels or add-on features. To upgrade a license, first purchase the new level or add-on feature. Next, select **License** followed by **Install/Upgrade** from the **File** menu. This will open the Licensing Wizard as shown below.
If you have an Internet connection, then select the **I received this serial number** option, and enter your serial number in the **Serial Number** box. Click **Next** to have the program contact HobbyWare to automatically obtain the new unlocking key for the new feature.

If you do not have an Internet connection, then you will need to obtain a new **Site Key** from HobbyWare that unlocks the new feature. The **Site Code** shown in this dialog must be provided to HobbyWare when obtaining the new site key for the new level or add-on. After receiving the new site key from HobbyWare, type it into the **Site Key** box, and then click **Next**. The program will then indicate whether the specified key is valid. Next, close and restart Pattern Maker for the new feature to be available.

---

**Important Considerations**

There are a few considerations that should be understood regarding the licensing facility of Pattern Maker. These include:

- A separate license is needed for every copy of the program installed on a particular computer.
- If Pattern Maker is uninstalled, the Site Code for that installation will no longer be valid, and as a result, a new Site Key will be required.
- Certain hard disk defragmentation/disk optimization programs can cause the licensing of Pattern Maker to be invalidated. For that type of program, you should configure it to not move files of the following types:
  - *.ent
  - *.key
  - *.rst
This chapter provides assistance in solving potential problems that you might encounter while using Pattern Maker. This chapter is organized as a series of questions and answers.

**Printing**

**Why are one or more rows and/or columns missing at the edges of my printout?**

This usually occurs when you are using a driver for your printer that was not designed for your printer. Please verify that you are using a driver that was designed for your printer. It is also a good idea to check for a more recent version of the driver by contacting the manufacturer of the printer. Most printer manufacturers make available driver updates via their web sites.

**Why is there a large gap between the left and top edges of the paper and the design?**

This usually occurs when the **Center Chart on Page(s)** option of the **Page Setup** dialog box is selected and the pattern only requires slightly more than one page. To prevent this, either turn-off the centering option or specify the **Fit to One Page** option of the same dialog box.

**Why does my printer indicate an 'out of memory' error sometimes when I print a fairly large/complex design?**

This usually occurs on printers which are setup to use HPGL mode instead of raster mode. Please check your printer setup and select the ‘raster’ mode if it is available. Alternatively, you may be able to add more memory to your printer to solve this problem. Please note that it is generally better to use the HPGL mode when possible since it reduces the time necessary for printing.

**When I print to my laser jet printer, why does the print-out appear fuzzy for some patterns, but not for others?**

This can occur on laser printers where either not much memory is installed on the printer or when the pattern is very complex. In that situation, the printer automatically reduces the resolution of the print-out to make it possible to print the entire page. This issue has been seen on printers such as the HP LaserJet 5L where only 1Mbyte of memory is provided standard in the printer. The best solution is to add more memory to the printer.

**Why are the grid lines hard to read or missing when I print my design?**

Depending upon the capabilities of your printer, you may need to adjust the grid line options to ensure an easy-to-read grid. The grid style is selected via **Grid Options** of the **Fabric** menu.

**When I print, why does Windows indicate that it cannot print to the spool file?**

This usually occurs when the available hard disk space is too low. Free up more space and try printing again.

**Why do the grid squares appear rectangular instead of square when I print?**

This can happen if a printer resolution is chosen which has differing horizontal and vertical resolutions. The printer resolution is selected via the printer properties dialog box of your printer. To open this dialog, click the **Properties** button of the **Print** dialog.
When I print to my HP Deskjet 932/952 printer, the program appears to hang-up.

A bad font is supplied with one of the add-on programs included with the HP Deskjet 932/952 printer. This font is called ‘BD Denver’. Since this font is unusable and causes problems, delete this font from the font list of the Control Panel.

Machine Embroidery

After I export a design to a machine file, close the design, and then reopen it, why is the View/Print Exporting Results option no longer available for the design?

The exporting information is only produced when the user selects the exporting feature. The exporting information no longer corresponds to the design after you make a change to the design (i.e. you add/remove a stitch). To avoid confusion, the program does not save the exporting information in the design file. To re-generate this information, just re-export the design. Be sure to always printout this information after exporting so you will have the exporting information that corresponds to the machine files.

Why do I see the same palette color listed more than one time in the thread change list for a design?

The program generates machine stitches using three passes. First, machine stitches are generated for the full, half, and quarter stitches of each color. Next, machine stitches are generated for the back and straight stitches of each color. Finally, stitches are generated for the French Knots.

Is there a quicker way to repeat the exporting of a file without having to step through each step of the Machine Exporting Wizard?

Yes. The program is configured to initially use the Machine Exporting Wizard when you click the Export to Machine File button of the Machine toolbar. However, you can redefine this button to immediately export using the current settings. To redefine this icon, first select Export Settings from the Machine Embroidery menu. In the dialog that opens, click the Options tab. For the Toolbar Icon options, select Exports using the current settings.

Why were so many jump stitches used for the back stitches when I chose a thickness of 1 thread (or 3 threads)?

When an even number of threads are specified for the thickness of a back (or straight) stitch, the program generates machine stitches which result in a back stitch getting stitched from one end to the other end, and then back to the starting end. While stitching a particular back stitch, if another back stitch is reached which branches off of the current stitch, the program generates stitches for that branching back stitch. The stitches generated for the branching stitch will complete back at the original stitch which will then be continued.

In the case of an odd number of threads per machine stitch, the needle does not end where it starts for a particular back stitch. Therefore, it is not possible to handle back stitches that branch off of a back stitch without using jump stitches. It is recommend that odd values only be used in special cases where you need the full range of thicknesses.

When I created my design I specified the finished size for the design. After exporting to a machine file, I notice that the resulting size is smaller than what I originally specified.

When exporting to a machine file, the design size will correspond to that portion of the fabric actually containing stitches. Any extra fabric around the design will be ignored in the size calculation.

When I created a multi-hoop design, I found that one of the sections did not contain any stitches except for alignment stitches. Should this section be stitched?

The program will generate alignment stitches for all sections of a multi-hoop design. In some cases these stitches are not needed, but in other cases these alignment stitches should be stitched so that subsequent sections can be aligned. For example, if 3 sections across by 3 sections down are required to represent a design, and if the middle section contains no stitches except for alignment stitches, it is still important to stitch the alignment stitches of that section since they will be needed to position the section to the right and below it.
Importing

Why is the detail in the imported design less than the detail in the original image?

The original image detail is maintained with no loss only if the size of the pattern that is created is equal to the size of the image. For example, the detail in a 300x200 pixel image would be perfectly reproduced if a 300x200 stitch pattern were created. Any pattern size that is less than the original image size will result in some loss of detail. The amount of detail loss depends heavily on the image.

However, since it is typically impractical (due to size reasons) to create designs where a stitch is used for each pixel of the image, it is necessary to sacrifice some detail.

When importing a photograph of a person, why do the facial tones appear blocky or otherwise less accurate?

In general, it is fairly difficult to import photographs of people. Be sure to use the Foreground selection tool to mark that portion of the scanned photo that corresponds to the face. Sometimes it can also help to lighten or darken the image. This can shift the colors in the image such that better floss equivalents may be available.

What is the best image file format to use for importing?

Most of the image formats work equally well. However, you may want to consider using a format such as JPEG or TIFF which provides image compression so that the file sizes are easier to manage.

What is the best image resolution to use for importing?

It is not necessary to use very high resolutions when importing your designs. In general, a resolution that is approximately 10 times the desired stitch count is usually sufficient. For example, scan using 100 dpi when importing to create a 10-count design. This saves disk space and processing time while providing good conversion quality.

Why do I get an error when I try to scan directly into Pattern Maker?

This error usually occurs when the TWAIN driver for the scanner is not a 32-bit driver. Please check with the manufacturer of the scanner for a 32-bit driver.

How can I force Pattern Maker to use a certain palette of colors when it imports an image?

First, create a new design and setup the palette of the design with the desired set of colors that you want to use when importing. Next, save the palette of this design to a palette file. This is done by selecting Save Palette As of the Palette menu. When you import, select this palette file via the Use the Colors in This Palette File option of the Image Importing Wizard. Only those colors listed in this palette file will be used for importing.

What is the best scanner to use for importing?

Most any 24-bit, flatbed scanner with reasonably good software support should work fine with Pattern Maker.

Exporting

What is the best image file format to use for exporting?

The TIFF and JPEG formats are good choices since they provide good image compression. In addition, these are currently very popular formats which are supported by most publishing programs. Please contact your publisher/printer for more advice on this option.

What is the best image resolution to use for exporting?

The image resolution requirement will depend upon how you plan to print the image. For professional printing, please contact your publisher/printer for more advice on this option. If you plan to print on a laser or color printer, a resolution in the 300-600 dpi range is probably sufficient.

Why are the grid lines not printing correctly when I use the OLE capabilities of the program to insert a pattern object into another program?
You may need to adjust the grid line thickness setting for the pattern before inserting the chart into the other program. To adjust the settings, select **Grid Options** of the **Fabric** menu.

**Why are the colors behind my symbols appearing dithered (displayed using a combination of colors) instead of as pure colors when I export?**

You must setup your video card to use 16-bit color or higher.

---

**Palette**

**How can I make Pattern Maker open each time with a new pattern that has an empty palette?**

First, create a new design and remove all colors from the palette. Next, save the palette of this design to a palette file called `default.pal` in the `\My Documents\PM Patterns` subfolder. (If you have changed the default pattern folder to be a different folder, then you will need to save the `default.pal` file to that folder instead.) This is done by selecting **Save Palette As** of the **Palette** menu. Next, select **Preferences** from the **File** menu and verify that the **Create a New Pattern on Startup** option is selected. Close and then restart Pattern Maker for the palette change to take effect.

**When ‘color behind symbol’ is enabled, why does the symbol background color not always appear as selected in the Palette Properties dialog box?**

When displaying alternative symbol colors, you must use the 16-bit color setting (or higher) for your graphics adapter.

**When I select Usage Summary from the Palette Menu, why does it indicate that it cannot calculate the usage summary for this fabric count?**

The usage calculations of the usage summary are based upon ‘calibration’ values for a particular stitch size (i.e. fabric count). For example, the number of full stitches that can be obtained from one inch of floss must be specified for the stitch size being used. The program includes values for 10, 14, 18, and 22 count. If you use a stitch size other than one of those, you will need to specify appropriate settings for that size.

To specify settings for another stitch size, click **Skein Information** on the **Floss Usage Summary** dialog box. This will open another dialog. In box labeled **Floss Used Per Stitch Type**, select one of the columns, enter the stitch count at the top of the column, and then enter the settings for each stitch type.

**I deleted (or changed) a color in the list of available colors for one of the thread/floss brands. How do I recover the original color?**

Any change made to the list of available colors for a particular brand can be undone. Please see “Undoing Changes to a Floss/Thread List” on page 84 for more details.

---

**General**

**I upgraded to version 4, but now when I select ‘Open’ under ‘File’, I do not see my pattern files listed. Where are my files?**

Version 4 was changed to store pattern files in a more easily accessible location. This location is: `\My Documents\PM Patterns`. If you have existing pattern files, you can either copy those files to this folder, or change the default folder where Pattern Maker looks for files to be that folder where your files are currently stored. To change the default folder, select the **Preferences** option of the **File** menu. The folder used by previous versions for storing patterns was `c:\\program files\\hobbyware\\pattern maker for cross stitch\\patterns`.

**I have a sketch upon which I want to base a design. How can Pattern Maker help me with this task?**

First, scan your drawing. Next, import the scan into Pattern Maker using the **Include Image as an Underlay for Tracing** option of the image importing feature. This will create a new pattern with your drawing included as an image behind the grid. You can then trace your drawing using the various stitch types.

**I want to make a backup of all files that I have created or changed, or that store settings that I have changed. Where should I look for those files?**
There are several folders on your computer where you should look for files to backup. These include:

- `\My Documents\PM Patterns` – all files and subfolders in this folder should be backed-up. These folders contain your designs files. You may also need to backup other folders if you have used additional folders for storing designs.

- `\Documents and Settings\All Users\Application Data\Pattern Maker for cross stitch` - contains the following folders which should be backed-up:
  - Color – This folder contains all user-changes to the various floss lists.
  - Stitch – This folder contains all user-changes and additions to the custom stitches.
  - Template – This folder contains all design layout templates.

---

**Licensing**

When I run Pattern Maker, the **Licensing Wizard** appears. What should I do?

The **Licensing Wizard** is part of the license management of Pattern Maker. Some levels of Pattern Maker require that the program be authorized before use. This is an easy process that is as simple as entering the provided serial number, and then allowing Pattern Maker to contact the HobbyWare license server. Once the program is authorized, the program will work without the need to re-enter the serial number. This feature also makes it very quick and easy to upgrade to the Professional level after purchasing the upgrade. To learn more, see “Licensing Features” on page 164.

I was using Pattern Maker in the trial mode. However, now the program shows the **Licensing Wizard** when I open it.

After the trial period has expired, you can no longer select the trial option. Please see the question above for more information.

I was using Pattern Maker in the trial mode, but it appears to have ended the trial mode too early.

In some cases the trial mode will be terminated if the date on the computer is changed too much. Also, certain disk optimization software can cause conflicts (see below).

I used the **Licensing Wizard** to successfully authorize my copy of the program a while back. However, I now find that the **Licensing Wizard** is appearing again.

In some cases an installed license can be lost if certain disk optimization/defragmentation software is used. For that type of software, please configure it to exclude files having the following extensions: ‘ent’, ‘key’, and ‘rst’. If this problem occurs, please re-use your serial number to re-authorize the program via the **Licensing Wizard**.
Managing Multiple Design Windows

Pattern Maker allows you to open multiple view windows for the same pattern. One way to use this feature is to setup another window to show a zoomed-in view of the same pattern. With this arrangement, you could edit the pattern by drawing in the zoomed-in view while also watching the other view to see the appearance of the overall pattern. The following shows an example of this scenario.

The following shows another example where the right window shows a symbolic view of the pattern and the left window shows the stitch view of the same pattern.
In general, any additional window that you open for a pattern can be setup independently with a different zoom factor, view format, or any other view-related option.

To open an additional view window, select **New Window** from the **Window** menu.

**Selecting an Open Window**

To view a list of the currently open view windows, pull-down the **Window** menu. All open windows are listed at the bottom of this menu. Simply select the name of the window of interest to force it to become active.

**Organizing Open Windows**

When several view windows are open at one time, you may find it desirable to organize them in some way. Pattern Maker allows you to organize them in the following ways:

- **Cascade** - Windows are arranged so that the Title Bar of each window is visible.

- **Tile Horizontally** - All windows are sized so that they all fit within the Pattern Maker window without overlapping. If three or less windows are open, then the windows are arranged side-by-side.

- **Tile Vertically** - Same as Tile Horizontally, but if three or less windows are open, then the windows are arranged one on top of the other.

**Organizing Iconized Windows**

To arrange all of the view windows that have been iconized, select the **Arrange Icons** command of the **Window** menu.
Preferences

Several program-level preferences can be selected using the Preferences dialog box. Select Preferences of the File menu to open this dialog box. This dialog box contains several pages of options. The following sections discuss each page.

File

The File options page of the Preferences dialog box is shown below.

The following options are available.

- **Create a New Pattern On Startup** – select to have the program create a new, empty pattern each time the program is started.

- **Create a Backup File When Pattern is Saved** – select to have the program create a backup file each time a pattern is saved to disk. Backup files have the same base name as the pattern file, but with a ‘bak’ file extension instead of ‘xsd’. To open a backup file, first rename the file so that it has ‘xsd’ as the file extension, and then open it as usual. You can delete backup files if you no longer need the previous changes.

- **Show Pattern Preview in File Open Dialog Box** – select to show the pattern preview pane of the File Open dialog box. When this open is not selected, you can still show the preview pane by clicking the preview button in the File Open dialog box.

- **Default Pattern Folder** – used to specify the folder of your computer that will be displayed when the File Open dialog box is used to open a pattern. To specify a different folder, click Browse. Please note that the default location of the folder where the sample patterns are installed is: \My Documents\PM Patterns.

Workspace

The Workspace options page of the Preferences dialog box is shown below.
The following options are available.

- **Automatically Show/Hide Toolbars** – select to have toolbars automatically hidden when not needed and shown when needed. For example, some toolbars such as the Layout toolbars are only needed when the Layout view is used. This option will hide those toolbars for you whenever the Layout view is not open. This feature helps to save screen space so that more of the pattern or layout can be seen.

- **Reset All** – click to restore the position of each toolbar back to its default position.

- **Remember Main Window Size and Position** – select to have the Pattern Maker window position and size saved and restored each time the program is closed and then reopened.

- **Remember Opened Documents and Window Placement** – select to have all designs that are open when the program is closed be re-opened when the program is re-opened.

**Palette**

The **Palette** options page of the Preferences dialog box is shown below.

The following options are available.

- **Default Floss/Thread Type** – the type/brand selected by default in the Colors page of the Palette Options bar.

- **Symbol Font Smoothing** – used to select whether fonts are smoothed to soften the edges. The following option are available:
  - **Use Windows Setting** – smoothing is done if selected via the **Effects** page of the **Display Properties** dialog box (of Windows).
  - **Smooth Font Edges** – smoothing is always done.
  - **Don't Smooth Font Edges** – smoothing is never done.

- **Color Difference Handling** – used to specify how the program should handle the case where a color is defined differently in a design than in the main floss/thread list. (Since each
design saves a copy of the definition of each color used in the design, it is possible for the color definitions stored in the file to be different from those in the main floss/thread lists. This occurs when the color definitions are manually edited or a floss update is provided by HobbyWare that includes ‘tweaked’ color values.) The options are:

- **Always Ignore Color Definition Changes in the Design** – select to ignore the color definition differences in a design. This prevents the main floss/thread lists from being changed when a pattern is opened. An exception to this is when a pattern is opened that includes a color that is not in one of the main lists. For that case, the color is added.

- **Always Use Color Definition Changes in the Design** – select to always use any color definition differences in a design.

- **Ask How to Handle the Color Definition Changes** – select to have the program prompt you each time a pattern is opened that contains color definition differences.

- **Only allow solid-color floss/thread types for importing** – select this option for the best importing results. Uncheck this option to allow all floss/thread/bead types to be available for selection when importing. It strongly recommended that this option be selected.

---

## Color Picker

The following dialog box is used by the program for choosing colors.

![Color Picker Dialog](image)

The **Old Color** box displays the current value for the color selection that is being changed. The **New Color** box shows the new value as selected via this dialog box. When the color management feature of Pattern Maker is used, the **New Color** value will be shown using the current settings.

A color can be selected in several ways:

1. **By using the color wheel and the brightness bar.** Click and drag the small box on the color wheel to select the hue/saturation. Click and drag the box on the brightness bar to select the brightness of the color.

2. **By clicking and dragging the small boxes on the RGB cube.**

3. **By directly entering a color value in RGB or HSB format.**

Click **Ok** when you have finished selecting a new color.
Short-Cut Keys

The following keys can be used to directly select certain menu items or toolbar options.

F1  Opens the help window
F2  Shows/hides the under/overlay image
F3  Selects previous thread in the palette
F4  Selects next thread in the palette
F7  Selects the Full stitch tool
F8  Selects the Half stitch tool
F9  Selects the Quarter stitch tool
F10 Selects the Back stitch tool
F11 Selects the French Knot tool
F12 Selects the Select tool
Space bar Selects the Eyedropper tool while pressed

Ctrl+N  Creates a new pattern
Ctrl+O  Opens an existing pattern
Ctrl+S  Save the current pattern
Ctrl+P  Prints the current pattern

Ctrl+A  Select all
Ctrl+Z  Undoes the previous editing operation
Ctrl+X  Cuts the selection from the pattern
Ctrl+C  Copies the selection
Ctrl+V  Pastes the Clipboard contents

Ctrl+E  Exports to a machine file using the current settings
Ctrl+I  Sets the name of a library cell
Ctrl+L  Copies from a library
Ctrl+M  Marks the usable area of a library cell

Ctrl+1  Snap back stitches to only the corners of the grid
Ctrl+2  Snap back stitches to the corners and mid-points of the grid

keypad +  Zooms-in to next level
keypad –  Zooms-out to next level
Index

A
Actual thickness · 53, 85

C
Centering marks · 22, 99, 138
Color Management · 156, 157, 158
Color Picker · 180

D
Design Methods · 23
  Importing · 26
  Manual · 23
Display thickness · 54
Drawing
  Back and straight stitches · 47
  Beads · 49
  French Knots · 49
  Specialty stitches · 49
  Text · 43, 51
  Text options · 42, 52, 162

E
Editing · 10, 26, 59, 62, 66
  Add all colors when pasting · 71
  Advanced area fill · 59, 68
  Advanced selections · 59, 60, 67
  Area fill · 59, 66
  Back stitch outlining · 59, 67
  Centering · 22, 59, 66, 99, 138
  Clear · 15, 59, 64, 86, 152
  Cut, copy, paste · 59, 63
  Delete hidden stitches when pasting · 71
  Drag-copy · 63
  Drag-move · 63
  Flip · 15, 59, 64
  Flood fill · 16, 59, 65
  Layout regions · 71, 137
  Overlay stitches when pasting · 71
  Paste into selection · 59, 69, 70
  Quick-copy · 64
  Rotate · 15, 59, 64
  Selecting an area · 59
  Stitch color replacement · 67
  Stitch type replacement · 67
  Undo · 10, 15, 35, 36, 37, 43, 59, 66, 84, 109, 110
Erasing
  Back and straight stitches · 48
  Beads · 49
  French Knots · 49
  Specialty stitches · 51
Exporting · 11, 113

F
Fabric · 10, 24, 39, 74
Color · 75, 76, 149
Gaps between stitches · 77
Grid · 76, 171, 174
Show fabric color with symbols · 78
Size · 75
Stitch Size · 24, 29, 39, 74, 98, 106, 145
Type · 76, 135, 149
Feature Overview · 7
Floss Type/Brands
  Anchor · 2, 7, 134, 135
  DMC · 2, 7, 25, 29, 42, 62, 95, 134, 135, 141

G
Grid · 22, 48, 49, 99, 151, 154

I
Image Importing · 26, 30, 102
  Background · 9
  Foreground · 9, 28, 110, 173
  Grid alignment · 106, 111
  Import as a picture for tracing · 105, 112
  Import into stitches · 105
  Interactive · 103
  Wizard · 26, 30, 31, 33, 103, 111, 173

J
JPEG · 102, 113, 115, 173

L
Library · 15, 39, 40, 53, 159, 160, 161, 162, 163
  Cell name · 160, 163
  Creating · 159
  Options · 159, 162
  Licensing · 7, 164, 175

M
Machine Embroidery · 1, 7, 8, 9, 11, 14, 16, 17, 18, 23, 24, 74, 106, 119, 120, 125, 126, 127, 128, 172
Exporting results · 16, 17, 125, 128, 172
  File types · 119, 124
  Hoop · 16, 119, 121, 122, 125, 126
  Jump Stitch · 16, 126
  Menu Bar · 14, 18, 96